[问题]supertux不能运行!

游戏讨论
回复
头像
anway
帖子: 398
注册时间: 2007-07-22 12:13
送出感谢: 1 次
接收感谢: 0

[问题]supertux不能运行!

#1

帖子 anway » 2008-04-18 11:09

xubuntu7.10,TNT2显卡,顺利安装supertux,不幸的是,不能运行。
终端运行时出错信息如下:
Invalid button '0' in buttonmap
Invalid button '1' in buttonmap
Fatal: Unexpected exception: Couldn't set video mode (800x600-0bpp): Couldn't find matching GLX visual
段错误 (core dumped)

网上找了一个,有人建议:
检查下你的xorg.conf ,把800x600的分辨率加进去,检查下glx加载了没。
在xorg.conf 里加入:
Section "Extensions"
Option "Composite" "disable"
EndSection

结果:问题依旧。

还有人建议改显示为16位,也没用。

游戏主页上有人反应这个问题,回答:I don't think that's SuperTux' fault。(看来不是游戏的错!)

倒有一个人也许说得对:显卡驱动把系统原openGL文件修改了导致这个问题。建议把这些文件改回发行版即可。
可惜没说出解决方案。
HOW TO?remove?
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#2

帖子 luojie-dune » 2008-04-18 20:29

更改下 家目录的 /.supertux 可以从8.04镜像里找到supertux2 玩---即supertux0.31 试试。
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
solcomo
帖子: 2838
注册时间: 2007-04-25 13:12
送出感谢: 0
接收感谢: 0
联系:

Re: [问题]supertux不能运行!

#3

帖子 solcomo » 2008-04-18 20:59

anway 写了:在xorg.conf 里加入:
Section "Extensions"
Option "Composite" "disable"
EndSection


Section "Extensions"
Option "Composite" "Enable"
Option "RENDER" "Enable"
EndSection
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS
头像
anway
帖子: 398
注册时间: 2007-07-22 12:13
送出感谢: 1 次
接收感谢: 0

#4

帖子 anway » 2008-04-23 15:01

搞了半天,瞎忙,装个最新稳定版就OK了。
回复

回到 “游戏和游戏模拟器”