wine魔兽世界出了问题,帮忙看下

游戏讨论
回复
polarfox_x
帖子: 6
注册时间: 2007-12-04 20:47
送出感谢: 0
接收感谢: 0

wine魔兽世界出了问题,帮忙看下

#1

帖子 polarfox_x » 2008-04-23 20:13

按照网上的方法设置了wine ,安装了 ies4linux, 其他的 设置都调了,结果出现了登录界面背景是黑的,进游戏之后没有人物和怪物的模型,建筑物的模型也没了 ,但是可以正常打怪(全鼠标操作,键盘没反应)
附件
Screenshot.png
Screenshot-1.png
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#2

帖子 luojie-dune » 2008-04-24 7:10

换另一个版本的wine
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
commando
帖子: 150
注册时间: 2005-09-21 0:27
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 commando » 2008-04-24 15:40

把插件禁用了试一下。
朱弦一抚余音在,却是当时寂寞心
头像
pollothana
帖子: 262
注册时间: 2007-03-08 10:47
送出感谢: 0
接收感谢: 0

#4

帖子 pollothana » 2008-04-24 15:43

BS楼上不负责任;
楼主是ATI显卡吧,我也遇到过这个问题,论坛里翻译的那篇文章这部分不全,估计作者是N卡,(你不用opengl模式应该可以游戏但是会很卡)。
参考了翻译的原文中troubleshooting一节,ati卡的话在Config.wtf中加入以下代码:

SET M2UseShaders "0"

另外就是翻译文章中提到的:

sudo gedit /etc/X11/xorg.conf

在ATI device section一项下面加入以下代码:

Option "Capabilities" "0x00000800"
Option "UseFastTLS" "off"
Option "KernelModuleParm" "locked-userpages=0"

编辑后的文件应该是像这样:

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "Capabilities" "0x00000800"
Option "UseFastTLS" "off"
Option "KernelModuleParm" "locked-userpages=0"
EndSection
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#5

帖子 luojie-dune » 2008-04-24 15:58

Thanks~~~ while I do have Nvidia graphics and not play full commericial game~~~
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
polarfox_x
帖子: 6
注册时间: 2007-12-04 20:47
送出感谢: 0
接收感谢: 0

#6

帖子 polarfox_x » 2008-04-24 21:46

感谢4楼的,问题已经解决
iceblock
帖子: 44
注册时间: 2008-05-10 0:14
送出感谢: 0
接收感谢: 0

#7

帖子 iceblock » 2008-05-17 0:16

pollothana 写了:BS楼上不负责任;
楼主是ATI显卡吧,我也遇到过这个问题,论坛里翻译的那篇文章这部分不全,估计作者是N卡,(你不用opengl模式应该可以游戏但是会很卡)。
参考了翻译的原文中troubleshooting一节,ati卡的话在Config.wtf中加入以下代码:

SET M2UseShaders "0"
这个config.wtf文件在哪里啊?
linux2ubuntu
帖子: 78
注册时间: 2007-10-25 11:26
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 linux2ubuntu » 2008-05-19 12:08

这个config.wtf文件在哪里啊?

在你的wow文件夹的wtf文件夹下。
crony
帖子: 2
注册时间: 2009-09-11 14:18
送出感谢: 0
接收感谢: 0

Re: wine魔兽世界出了问题,帮忙看下

#9

帖子 crony » 2009-09-11 14:21

兄弟们,有没有遇上过这种情形?

按照楼主所介绍的方法试过了,还是不行。
附件
blackscreen of WOW.png
运行WOW(Wine)黑屏
回复

回到 “游戏和游戏模拟器”