当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 7.0 下如何安装SDL图形库
帖子发表于 : 2008-08-01 9:45 

注册: 2006-02-05 18:11
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
ubuntu 7.0 下如何安装SDL图形库
如题。想装SDL图形库,结果都是搜了一下wiki没有关于SDL的内容!!!!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-01 9:50 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
???
软件都不会装???
重新读基础文档吧。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-01 12:56 

注册: 2006-02-05 18:11
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
zhaozhy@zhaozhy-desktop:~$ sudo apt-get install SDL
[sudo] password for zhaozhy:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包 SDL


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-01 14:13 
头像

注册: 2006-04-12 18:54
帖子: 4669
送出感谢: 0 次
接收感谢: 7
sdl是库

别老是apt-get

老老实实新立得不好么……


_________________
blog:杰林修·呓


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-01 15:35 

注册: 2006-02-05 18:11
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
有很多,需要装哪几个阿,要全装吗???开发的


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-01 16:05 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
开发的不自己编译吗。。。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu 7.0 下如何安装SDL图形库
帖子发表于 : 2008-08-01 16:16 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
zhaozhy 写道:
ubuntu 7.0 下如何安装SDL图形库
如题。想装SDL图形库,结果都是搜了一下wiki没有关于SDL的内容!!!!!


sudo apt-get install libsdl-dev 即可。

其实我推荐另外一个更简单的办法。随便想象你知道的一个使用sdl的软件,例如我知道有 chromium 使用它,然后
sudo apt-get build-dep chromium 就可以了。

又例如你要搞kde的开发,怎么把kde相关的库装进去呢?随便想象一个功能很全的kde程序。。。哦konqueror可以,kate也行。然后 sudo apt-get build-dep kate


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-01 16:19 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
jarlyyn 写道:
sdl是库
别老是apt-get
老老实实新立得不好么……


因为不是每个人都装了新立得。也不是每个用ubuntu的人都知道新立得是什么东东。

例如我用ubuntu半年之后才知道原来有个东东叫新立得,为什么我没有呢,原来,非要装gnome的环境才有这个东东,而且只有装中文支持才有。——但是不用gnome环境的人呢?不装中文支持的人呢?不装图形界面的人呢?那是没有新立得可用的。


页首
 用户资料  
 
9 楼 
 文章标题 : 谢谢楼上各位,我才知道有个新力的
帖子发表于 : 2008-08-02 10:30 

注册: 2006-02-05 18:11
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
1) For Ubuntu users, it's recommended that you use the built in package manager. You can access the package manager going to system -> administration -> Synaptic Package Manager. Once you're in, search for "libsdl1.2-dev" (without quotes), which is the SDL development package. Once you find it, click and install it.

2) For those of you who have Advanced Packaging Tool available you can enter the command:
apt-get install libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev
You need to have root priviledges, so use the "su" command or "sudo" command.

3) For the Yellow dog Updater, Modified you can enter the command:
yum install SDL-devel SDL_mixer-devel SDL_image-devel SDL_ttf-devel
As with apt-get, you'll need root priviledges.

4) For RPM based distros, you'll need the SDL development RPM.
You will find them on the SDL website, specifically on this page.

Scroll Down to the Development Libraries section and download the Linux development library:

Now run the RPM and let it do it's thing.

Now that you've installed the development libraries, it's time to start up your IDE/compiler.


http://lazyfoo.net/SDL_tutorials/lesson ... /index.php
有完整的安装步骤!!!


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-08-02 10:39 

注册: 2006-02-05 18:11
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
我一般都用apt装,不用心力的!!!!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-08-02 15:36 
头像

注册: 2006-04-12 18:54
帖子: 4669
送出感谢: 0 次
接收感谢: 7
poet 写道:
jarlyyn 写道:
sdl是库
别老是apt-get
老老实实新立得不好么……


因为不是每个人都装了新立得。也不是每个用ubuntu的人都知道新立得是什么东东。

例如我用ubuntu半年之后才知道原来有个东东叫新立得,为什么我没有呢,原来,非要装gnome的环境才有这个东东,而且只有装中文支持才有。——但是不用gnome环境的人呢?不装中文支持的人呢?不装图形界面的人呢?那是没有新立得可用的。


Ubuntu中文 论坛首页


_________________
blog:杰林修·呓


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-08-02 15:38 
头像

注册: 2006-04-12 18:54
帖子: 4669
送出感谢: 0 次
接收感谢: 7
zhaozhy 写道:
我一般都用apt装,不用心力的!!!!


那请您多看看man apt-get


_________________
blog:杰林修·呓


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-08-02 17:03 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
...没关系。
我用了Ubuntu有4个多月才开始用apt-get,因为没有
代码:
apt-get search

只有
代码:
aptitude search


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-08-02 19:30 
头像

注册: 2006-04-12 18:54
帖子: 4669
送出感谢: 0 次
接收感谢: 7
luojie-dune 写道:
...没关系。
我用了Ubuntu有4个多月才开始用apt-get,因为没有
代码:
apt-get search

只有
代码:
aptitude search

man apt-get的see also里第一个就是apt-cache


_________________
blog:杰林修·呓


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-08-02 20:17 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
jarlyyn 写道:
luojie-dune 写道:
...没关系。
我用了Ubuntu有4个多月才开始用apt-get,因为没有
代码:
apt-get search

只有
代码:
aptitude search

man apt-get的see also里第一个就是apt-cache

实际上我刚装Ubuntu时什么文档也没看。不过似乎没有问一些低级问题。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译