显卡驱动已正确安装,但用cedega游戏仍然很卡?

游戏讨论
回复
godblesh
帖子: 28
注册时间: 2006-03-29 11:11
送出感谢: 0
接收感谢: 0

显卡驱动已正确安装,但用cedega游戏仍然很卡?

#1

帖子 godblesh » 2006-05-02 12:13

我的显卡是ati M7 LW:
godblesh@ubuntu:/media/hda5/Program Files/Wom$ glxinfo|grep direct
direct rendering: Yes

godblesh@ubuntu:~$ glxinfo | grep -e 'driver' -e 'OpenGL'
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI Radeon 20050528 AGP 4x TCL
OpenGL version string: 1.2 Mesa 6.4.1
OpenGL extensions:

glxgears -iacknowledgethatthistoolisnotabenchmark
4808 frames in 5.0 seconds = 961.558 FPS
4762 frames in 5.0 seconds = 952.326 FPS
4765 frames in 5.0 seconds = 952.843 FPS
4764 frames in 5.0 seconds = 952.675 FPS
4772 frames in 5.0 seconds = 954.229 FPS
4768 frames in 5.0 seconds = 953.544 FPS
4770 frames in 5.0 seconds = 953.987 FPS
4766 frames in 5.0 seconds = 953.096 FPS
4750 frames in 5.0 seconds = 949.920 FPS
4496 frames in 5.0 seconds = 899.038 FPS
显卡驱动应该已经正错安装并驱动了。。。我的驱动是直接用Ubuntu自带的,只是修改了一下Xorg.conf,没做其他改动,我的Xorg.conf如下:
Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility M7 LW [Radeon Mobility 9000]"
Driver "radeon"
BusID "PCI:1:0:0"
Option "RenderAccel" "true"
Option "AGPMode" "4"
Option "AGPFastWrite" "true"
Option "EnablePageFlip" "True"
Option "UseInternalAGPGART" "no"
Option "backingstore" "true"
Option "AllowGLXWithComposite" "true"
EndSection
我这是按网上说的修改的其他部分没有改动。。。

我用cedega模拟War3是画面只有3~5祯,还有大量贴图错误。模拟和金装备1是在视频选项里只有软件加速,没有看到M7显卡的硬件加速,并且人物的行动方式很奇怪,就像是放快动作一样,但背景音乐正常。。貌似游戏里面不能正确识别我的显卡。
不知道这是什么问题,希望高手指点:)
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-05-02 12:40

测试显卡驱动的标准是quake,不是cedega。真正用quake测试的人士,会使用quake的参数。quake的参数比lin常规命令多几倍的。呵呵,试试吧。
cedega你使用--window先试试吧。
● 鸣学
godblesh
帖子: 28
注册时间: 2006-03-29 11:11
送出感谢: 0
接收感谢: 0

#3

帖子 godblesh » 2006-05-02 13:14

我不是只是想玩War3而已。。不想搞什么测试阿。。楼上说的quake之的是游戏quake III吗?我试了--window还是全频,还是很卡。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-05-02 16:47

Option "AllowGLXWithComposite" "true"
Option "RenderAccel" "true"
这些是自己加的?一个一个去掉试试。ati的不熟悉啊。等用ati的来答吧。
● 鸣学
godblesh
帖子: 28
注册时间: 2006-03-29 11:11
送出感谢: 0
接收感谢: 0

#5

帖子 godblesh » 2006-05-03 19:12

今天装了个cedega 5.0。用里面的Tools>System Tests测试了一下,发现Opengl Direct Rendering:Failed;
而3D Acceleration:pass.
好像Opengl没有弄好,是不是还要装一个Xlibmesa-glu-dev?(网上看的),不过源里好像没有。。。
minjun
帖子: 47
注册时间: 2005-12-18 17:18
送出感谢: 0
接收感谢: 0

#6

帖子 minjun » 2006-05-09 13:31

我以前的时候也是碰到这个问题,装了cedega,而且以前也装了ATI的驱动程序了。运行的时候很卡。
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#7

帖子 bones7456 » 2006-05-13 9:43

我的是sis的显卡,也很卡,不知是驱动问题还是字体问题。
回复

回到 “游戏和游戏模拟器”