关于XMAME,启动xmame就变黑屏了 (已解决)

游戏讨论
回复
头像
proming
帖子: 52
注册时间: 2006-04-03 10:38
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

关于XMAME,启动xmame就变黑屏了 (已解决)

#1

帖子 proming » 2006-07-28 16:46

RT
xmame安装的是源里的版本
我的显卡是Radeon 9550
以下运行fglrxinfo的信息:

代码: 全选

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 2.0.5814 (8.25.18)


不知道这个是为什么,希望达人能够帮忙解决,谢谢
上次由 proming 在 2006-08-07 14:28,总共编辑 1 次。
Hardware:
Lenovo ThinkPad T400
Processor: Intel Core2 Duo P8700
Memory: 2G
Disk: 320G

Ubuntu
Release 10.10
Kernel Linux 2.6.35-24-generic
GNOME 2.32.0

欢迎访问我的blog
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-07-28 21:45

源的?如果是0.34的就不行。要0.35的。
● 鸣学
头像
proming
帖子: 52
注册时间: 2006-04-03 10:38
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 proming » 2006-07-28 23:15

那个是gxmame的版本吧
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-07-29 0:22

是的。你不要这个啊。
● 鸣学
头像
IdeaLee
帖子: 90
注册时间: 2006-01-29 9:29
送出感谢: 0
接收感谢: 0

#5

帖子 IdeaLee » 2006-08-05 22:48

源里的 xmame 版本太旧了,自己到 xmame 的官方 http://x.mame.net/ 下载最新的 xmame ,现在应该是 0.106 了,下 rpm 包,用 alien 转成 deb 安装比较方便,我就是这样的……
在现实面前,当然是理想错了……
头像
proming
帖子: 52
注册时间: 2006-04-03 10:38
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 proming » 2006-08-07 7:42

谢谢大家热心的帮助,现在游戏终于可以正常玩了
是因为缺少了两个库文件libGL.solibGLU.so
通过链接libGL.so.1libGLU.so.1(两个都是在/usr/lib下)可以解决这个问题
但是每次还是会黑屏,每次都得在控制台之间切换一次才能正常
就是用Ctrl + Alt + F1和F7切换
缺少文件也是这样才发现的
之前都以为是X崩溃了,都直接按Ctrl+Alt + Backspace重启一下X
不知道这个黑屏能否解决,是不是和显卡驱动有关系

代码: 全选

以下运行fglrxinfo的信息:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 2.0.5814 (8.25.18)
Hardware:
Lenovo ThinkPad T400
Processor: Intel Core2 Duo P8700
Memory: 2G
Disk: 320G

Ubuntu
Release 10.10
Kernel Linux 2.6.35-24-generic
GNOME 2.32.0

欢迎访问我的blog
头像
proming
帖子: 52
注册时间: 2006-04-03 10:38
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 proming » 2006-08-07 14:23

问题解决了
参考了wargames兄的xmame goes to black screen then nothing? http://www.ubuntuforums.org/archive/index.php/t-104222.html
说是xmame-x11好像和ATI的fglrx有点问题
换成xmame-sdl变OK了

大家也可以去我的Blog看下
http://blog.tom.com/blog/read.php?bloggerid=784720&blogid=59711
也写了一篇关于XMAME的
Hardware:
Lenovo ThinkPad T400
Processor: Intel Core2 Duo P8700
Memory: 2G
Disk: 320G

Ubuntu
Release 10.10
Kernel Linux 2.6.35-24-generic
GNOME 2.32.0

欢迎访问我的blog
回复

回到 “游戏和游戏模拟器”