当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教,VBA编译错误?
帖子发表于 : 2009-05-30 22:39 
头像

注册: 2009-01-26 20:18
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
系统:8.04 使用的是vbaexpress-1.2

红色字体部分是我安装的过程


按照README.txt说明:

VBA Express.

Author: Achraf cherti, 2005-2006
Website: http://vbaexpress.tuxfamily.org/
Email: achrafcherti@gmail.com

==========================================================
Introduction
==========================================================
VBA Express is a VisualBoyAdvance frontend. It can help you:
* to configure easily the graphics, sounds, controls, paths...
* to run your games without console :-) but with the graphical "Play!" Button

This version has been tested with VisualBoyAdvance version 1.7.1 and 1.7.2.

==========================================================
How to install the emulator, VisualBoyAdvance?
==========================================================
Install the emulator:
---------------------
VBA Express requires the emulator (VisualBoyAdvance). It is used to run your
GameBoy Advance games. You can download it at: http://vba.ngemu.com

For hasty people, you can download the binary archive for Linux directly at:
http://prdownloads.sourceforge.net/vba/ ... z?download
(it's version 1.7.1)

In the archive VisualBoyAdvance-1.7.1-SDL-linux-glibc22.tar.gz you have some
files. You must copy "VisualBoyAdvance" executable in /usr/bin (or in another
path defined in the $PATH variable). 已下载并复制


IMPORTANT: VBA Express searches the VisualBoyAdvance in $PATH

==========================================================
How to install VBA Express (the frontend):
==========================================================
You must copy "vbaexpress" executable in /usr/bin (or in another
path defined in the $PATH variable) 已下载并复制


==========================================================
What's the tools used to create VBA Express?
==========================================================
VBA Express is programmed with C++ language. Compiled with gcc
and make. The source code has been edited with gvim (http://www.gvim.org).
The GUI with fltk (http://www.fltk.org) and FLU.
The OS used is Linux with the distribution: Fedora Core 4

==========================================================
How to compile the source?
==========================================================
To compile the program from sources, you need some requirements:
- SDL (http://www.libsdl.org)
- Fltk (http://www.fltk.org)
- FLU (http://www.osc.edu/~jbryan/FLU/)

In my example. You have the source archive in:
/home/achraf/vbaexpress-1.1-source.tar.gz

Type (the $ is the shell... do not type it):

$ cd /home/achraf
$ tar xvzf vbaexpress-1.1-source.tar.gz

You have how "vbaexpress-1.1" directory. Now, type:

$ cd vbaexpress-1.1

$ make

//进行到此步骤后,开始make,但是最终显示的结果是有错误:
sh ./misc/make_readme.sh
./misc/make_readme.sh: 10: Syntax error: "(" unexpected
make: *** [first] 错误 2


不知是否有朋友遇到这种情况,请问是如何解决?

谢谢您的阅读和回复 :em02



And to install it type "su" to have root priviledges:
$ su
password:

And now, you can install VBA Express with:

$ make install


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译