在aiglx下玩玩WarCraftIII & StarCraft

游戏讨论
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

在aiglx下玩玩WarCraftIII & StarCraft

#1

帖子 Beetle » 2006-08-09 0:43

开始一直以为会没有opengl的加速,没想到跑的比windows还快 :em09
附件
warcraft.png
warcraft1.png
warcraft2.png
starcraft.png
starcraft2.png
dext
帖子: 25
注册时间: 2006-07-11 15:41
送出感谢: 0
接收感谢: 0

#2

帖子 dext » 2006-08-18 22:40

楼主,教程教程啊
chuan1105
帖子: 142
注册时间: 2006-07-17 20:10
送出感谢: 0
接收感谢: 0

#3

帖子 chuan1105 » 2006-08-19 8:54

是用wine跑的吗?
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 Beetle » 2006-08-19 11:50

就是用wine跑的,加个-opengl参数就可以跑的流畅了……
borry
帖子: 24
注册时间: 2006-05-09 13:18
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 borry » 2006-08-20 9:21

有没详细教程啊???????
我试过有很多问题
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#6

帖子 jarryson » 2006-08-20 10:38

天哪 这样都可以?

[lh@Arch ~]$ glxgears
6253 frames in 5.0 seconds = 1245.258 FPS
6360 frames in 5.1 seconds = 1253.989 FPS
6360 frames in 5.1 seconds = 1248.658 FPS
X connection to :1.0 broken (explicit kill or server shutdown).

原来我安装nv卡驱动 只有900左右 可以玩魔兽 可是现在有xgl都有1000多应该可以玩阿
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#7

帖子 jarryson » 2006-08-20 10:41

还有你是不是用wine模拟的?

如果不加opengl会出现这样的情况

不知道cedega怎么样
xieguozhong
帖子: 39
注册时间: 2005-09-26 12:51
来自: 江西南昌
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 xieguozhong » 2006-08-21 19:15

教程,教程,我要教程,我安装了wine和easywine,冰封安装在windows下的D盘,格式为nfts,
D盘挂到ubuntu里面为/media/hda7,
文件路径 为/media/hda7/games/war/***.exe
玩的时候是不是
到/media/hda7/games/war目录下,输入
wine ***.exe -opengl

为什么我这样执行了它只显示一下冰封的启动画面然后就关掉了,为什么,为什么,我的显示是nvidia gefore4 mx440,驱动我装好了,玩3d游戏一点也不卡
热爱一切新技术的新手
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#9

帖子 jarryson » 2006-08-21 21:13

楼上的

直接执行War3.exe 就可以了把

还有很重要的是 wine一点个要配置好了中文 显示中文一定要正常 不然不能玩的
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 Beetle » 2006-08-21 21:35

LS的各位偶真的不知道该怎么写教程……因为偶就装了一个WINE,然后下了一个Easywine配置一下!
执行

代码: 全选

wine Frozen Throne.exe -opengl
就可以的了!
dext
帖子: 25
注册时间: 2006-07-11 15:41
送出感谢: 0
接收感谢: 0

#11

帖子 dext » 2006-08-23 15:18

你用的那个版本的wine,还有你用的那个版本的easywine,我的问题一大堆哦,郁闷
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 Beetle » 2006-08-23 16:10

wine 0.9.17

Easywine3.0Beta1

PS:换成E文的locale显示乱码!但能用!
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#13

帖子 jarryson » 2006-08-23 22:17

按论坛里面的的方法设置xgl的么

我的没有办法打开opengl

真是羡慕楼主哦
hellboys
帖子: 2
注册时间: 2006-01-06 13:44
送出感谢: 0
接收感谢: 0

#14

帖子 hellboys » 2006-08-24 23:31

xieguozhong 写了:教程,教程,我要教程,我安装了wine和easywine,冰封安装在windows下的D盘,格式为nfts,
D盘挂到ubuntu里面为/media/hda7,
文件路径 为/media/hda7/games/war/***.exe
玩的时候是不是
到/media/hda7/games/war目录下,输入
wine ***.exe -opengl

为什么我这样执行了它只显示一下冰封的启动画面然后就关掉了,为什么,为什么,我的显示是nvidia gefore4 mx440,驱动我装好了,玩3d游戏一点也不卡
我的魔兽在fat32分区下面, wine0。9。19版本的。
进入 wine ***.exe 魔兽以后非常卡, wine ***.exe -opengl 显示一下冰封的启动画面然后就关掉了。显卡是nv ti4200.
为什么呢? 是显卡问题马?
请教!
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 Beetle » 2006-08-26 9:45

哈哈……偶终于加入你们的行列了!!!昨天update的wine,今天就不能用了!!! :em27

还是顶起来,让高手来指点……
回复

回到 “游戏和游戏模拟器”