当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 在ubuntu 9.04里安装FlightGear的最新版本
帖子发表于 : 2009-08-12 11:22 

注册: 2008-04-08 13:24
帖子: 225
送出感谢: 0 次
接收感谢: 0 次
源里带的好像是1.0.0版本,官网上看到最新版本已经是1.9.0,但是并没有提供deb 的包,如果要装flightgear的最新版本,必须去这里下载脚本:
http://wiki.flightgear.org/index.php/Sc ... ian/Ubuntu
这个脚本是用来从cvs上下载flightgear最新的源代码,然后负责编译安装。

运行脚本的时候提示:
代码:
下列【新】软件包将被安装:
  autoconf automake autotools-dev build-essential cmake cvs dpkg-dev fluid freeglut3-dev g++ g++-4.3 gawk gettext
  libalut-dev libasound2-dev libboost-date-time-dev libboost-date-time1.34.1 libboost-dev libboost-doc
  libboost-filesystem-dev libboost-filesystem1.34.1 libboost-graph-dev libboost-graph1.34.1 libboost-iostreams-dev
  libboost-iostreams1.34.1 libboost-program-options-dev libboost-program-options1.34.1 libboost-python-dev
  libboost-python1.34.1 libboost-regex-dev libboost-regex1.34.1 libboost-serialization-dev libboost-serialization1.34.1
  libboost-signals-dev libboost-signals1.34.1 libboost-test-dev libboost-test1.34.1 libboost-thread-dev
  libboost-thread1.34.1 libboost-wave-dev libboost-wave1.34.1 libfltk1.1-dev libgl1-mesa-dev libglu1-mesa-dev libglut3-dev
  libicu-dev libilmbase-dev libjasper-dev libjpeg62-dev libopenal-dev libopenexr-dev libpng12-dev libstdc++6-4.3-dev libsvn1
  libtiff4-dev libtiffxx0c2 libwxbase2.8-dev libwxgtk2.8-dev libxext-dev libxi-dev libxmu-dev libxmu-headers m4
  mesa-common-dev patch python-dev python2.6-dev subversion wx2.8-headers x11proto-xext-dev xlibmesa-gl-dev
共升级了 0 个软件包,新安装了 71 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 63.2MB 的软件包。
解压缩后会消耗掉 258MB 的额外空间。


我用一根网通4M的专线下载速度很快,目前正在安装中。。。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 在ubuntu 9.04里安装FlightGear的最新版本
帖子发表于 : 2009-08-12 16:38 

注册: 2008-04-08 13:24
帖子: 225
送出感谢: 0 次
接收感谢: 0 次
大概过了4/5个小时,终于安装完成了。最后提示:
代码:
To start fgfs, run the run_fgfs.sh file
To start terrasync, run the run_terrasync.sh file
To start fgrun, run the run_fgrun.sh file
To start fgcom, run the run_fgcom.sh file
To start atlas, run the run_atlas.sh file
Usage: download_and_compile.sh -h
for help


在download_and_compile.sh同一目录下多了几个子目录和运行flightgear的脚本。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 在ubuntu 9.04里安装FlightGear的最新版本
帖子发表于 : 2009-08-13 9:33 
头像

注册: 2008-06-30 22:32
帖子: 2869
送出感谢: 0 次
接收感谢: 10
不会配置摇杆... :em19


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译