安装unknown-horizons的问题

游戏讨论
回复
头像
yuyangzxw
帖子: 61
注册时间: 2008-03-10 16:28
送出感谢: 0
接收感谢: 1 次
联系:

安装unknown-horizons的问题

#1

帖子 yuyangzxw » 2011-05-08 18:07

看到该帖子的游戏,蛮有兴趣,想安装,发现出现了如下问题,请问这个需要安装什么包呀
viewtopic.php?f=34&t=329776

小弟接触Linux不久,命令行操作不多,以下是个人认为的操作,发现如下问题,请大虾们帮忙解决下哈~

代码: 全选

yyy@Ubuntu:~$ sudo apt-get install unknown-horizons
[sudo] password for yyy: 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 unknown-horizons : 依赖: python-fife (> 2008.1+svn2711) 但是它将不会被安装
E: 破损的软件包
yyy@Ubuntu:~$ sudo apt-get install python-fife
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 python-fife : 依赖: libboost-filesystem1.38.0 (>= 1.38.0-1) 但无法安装它
               依赖: libboost-regex1.38.0 (>= 1.38.0-1) 但无法安装它
               依赖: python2.5 (>= 2.5) 但无法安装它
               依赖: python (< 2.6) 但是 2.6.6-2ubuntu2 正要被安装
E: 破损的软件包
yyy@Ubuntu:~$ sudo apt-get install python
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
python 已经是最新的版本了。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 2 个软件包未被升级。
以下是新德利已经安装的包:
1.png
2.png
2.png (18.64 KiB) 查看 468 次
3.png
在新德利操作提示:
4.png
头像
remeber
论坛版主
帖子: 13005
注册时间: 2009-01-06 15:18
来自: 人间
送出感谢: 1 次
接收感谢: 22 次

Re: 安装unknown-horizons的问题

#2

帖子 remeber » 2011-05-08 21:45

换源试了吗
截图很纠结不清的样子。
“有一种被人抛诸脑后的过去,包含一些不该遗忘的点点滴滴。欢笑之余,我将故旧拾起,才刹见自己的薄情。人世间似乎存在着某种公平,每个人都曾被抛掷在他人的遗忘中;而今你所有哽咽难宣的话语,也正是你曾为人所期盼,却永远听不见的字句。” —赫曼 赫塞
头像
yuyangzxw
帖子: 61
注册时间: 2008-03-10 16:28
送出感谢: 0
接收感谢: 1 次
联系:

Re: 安装unknown-horizons的问题

#3

帖子 yuyangzxw » 2011-05-09 1:09

解决了,直接根据网站提示编译安装就好
http://www.unknown-horizons.org/downloa ... s/s-linux/

按照下面网站直接deb安装就是不行的,即使根据上面方法编译了环境还是这样的,不知道是不是64位的原因.
http://www.unknown-horizons.org/download/linux
回复

回到 “游戏和游戏模拟器”