我。/configure 的时候出现这样的东西?

游戏讨论
回复
laoshu
帖子: 1
注册时间: 2005-10-04 15:01
送出感谢: 0
接收感谢: 0

我。/configure 的时候出现这样的东西?

#1

帖子 laoshu » 2005-10-04 15:04

checking for style of include used by make... GNU
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.


再装一个c compiler ?怎么搞?不是太会,
我是新手,麻烦给俺说的详细一点点,谢谢了。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-10-05 11:19

要安装很多。
简单的在新利得中搜索gcc,选择gcc-3.3的就可以。
yonsan说的全面的是这样
#!/bin/bash
#=============================================================
# 此脚本用于在ubuntu5.04下配置gtk+开发环境
#
apt-get install anjuta
apt-get install anjuta-common
apt-get install apache
apt-get install at-spi-doc
apt-get install autobook
apt-get install autoconf
apt-get install autoconf2.13
apt-get install autoconf-archive
apt-get install autogen
apt-get install automake
apt-get install bison
apt-get install ctags
apt-get install cvs
apt-get install devhelp
apt-get install devhelp-books
apt-get install exuberant-ctags
apt-get install flex
apt-get install g++
apt-get install g77
apt-get install gcc
apt-get install gcj
apt-get install gda2-freetds
apt-get install gda2-mysql
apt-get install gda2-odbc
apt-get install gda2-postgres
apt-get install gda2-sqlite
apt-get install glade-2
apt-get install glade-doc-2
apt-get install glade-gnome-2
apt-get install gnome-devel
apt-get install gnu-standards
apt-get install gnutls-bin

代码: 全选

apt-get install httpd 
apt-get install indent
apt-get install libcompress-zlib-perl
apt-get install libgail-doc
apt-get install libglib2.0-doc
apt-get install libgnome2-dev
apt-get install libgnome2-doc
apt-get install libgnomecanvas2-doc
apt-get install libgnomemm2.0-dev
apt-get install libgnomeui-doc
apt-get install libgtk2.0-dev
apt-get install libgtk2.0-doc
apt-get install libgtkmm2.0-dev
apt-get install libgtkmm2.0-doc
apt-get install libhtml-format-perl
apt-get install libio-socket-ssl-perl
apt-get install libltdl3-dev
apt-get install libmailtools-perl
apt-get install libpango1.0-doc
apt-get install libpcre3
apt-get install libstdc++5-3.3-doc
apt-get install libtool
apt-get install libtool-doc
apt-get install manpages-dev
apt-get install menu
apt-get install orbit2
apt-get install stl-manual
apt-get install shared-mime-info
apt-get install ttf-thryomanes
● 鸣学
jjgod
帖子: 29
注册时间: 2005-08-20 3:56
送出感谢: 0
接收感谢: 0

#3

帖子 jjgod » 2005-10-05 12:48

5.04 下 gcc-3.3 是默认的 C 编译器,你可以
apt-get install gcc 来安装。

你也可以装 gcc-3.4,用
apt-get install gcc-3.4
然后 export CC=gcc-3.4
这样 configure 可以找到你的 C 编译器。

5.10 下 gcc-4.0 是默认的编译器,但仍然保留了 gcc-3.3 和 gcc-3.4 的包,如法炮制即可。

如果是用 C++ 的编译器,就 export CXX=g++-3.4 之类的。
回复

回到 “游戏和游戏模拟器”