当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请高手帮忙解决《重返德军总部》没有声音的问题!
帖子发表于 : 2007-03-13 23:53 

注册: 2006-12-19 10:14
帖子: 107
送出感谢: 0 次
接收感谢: 0 次
在论坛上搜了一下,没有发现解决的方法,倒是看到很多TX出现这种情况。请走过路过的高手们,说说有什么可能的解决办法么?谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-17 8:36 
头像

注册: 2005-10-14 15:56
帖子: 1845
送出感谢: 0 次
接收感谢: 7
同问,望知道的指教


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-17 9:30 
头像

注册: 2005-10-14 15:56
帖子: 1845
送出感谢: 0 次
接收感谢: 7
Sound Issues

There are a few methods you can try if you are having problems with sound:
Method 1

You can try stopping the ESD sound server before running the game by running:

killall esd; et; esd

If this works for you then you can create a script to run it. To do this create a new text file called start-et and add these lines to it:

#!/bin/sh
killall esd
et
esd
exit 0

Now save the file and you will need to run these commands to make it executable and to put it somewhere in your user's $PATH variable (so that it can be executed by just typing it's name):

chmod a+x start-et
sudo cp start-et /usr/local/games

If you don't want to put it in /usr/local/games you don't have to, but remember to specify whatever path you decide to give it whenever you execute it (some paths can use shortcuts, like ./start-et for the current directory, ~/start-et for your Home directory, etc.)
Method 2

If you don't hear any sound and see the following error message in a terminal:

/dev/dsp: Input/output error
Could not mmap /dev/dsp

You will need to do the following in addition to the steps above:

sudo -i
echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
exit

This makes the script slightly more complicated, since parts of it will need to be run with superuser priviledges. To use the above commands in the star-et script described in Method 1 you should make it look like this:

#!/bin/bash
gksudo echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
gksudo echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
killall esd
et
esd
exit 0

Then use the commands to give it execute permissions and to put it in /usr/local/games.


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-03-17 14:35 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
以前才有问题啊。是quake3的问题啊。现在还有?
gnome是禁用esd
kde是禁用art


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-03-18 19:59 

注册: 2006-12-19 10:14
帖子: 107
送出感谢: 0 次
接收感谢: 0 次
谢谢啊!明天我试试!不懂还要问你们哦!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-03-29 13:33 
头像

注册: 2005-12-07 0:17
帖子: 476
地址: 昆明
送出感谢: 0 次
接收感谢: 0 次
谢谢三楼


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-03-31 12:06 

注册: 2006-12-16 13:07
帖子: 53
地址: 浙江
送出感谢: 0 次
接收感谢: 0 次
解决ET无声
2.) Fix sound by adding settings to startup scripts:

To fix the sound problems, add the following three lines to your /etc/init.d/bootmisc.sh file:

#-----------------------
# fix sound for Quake 3 and Enemy Territory
echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
echo "quake3.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
echo "quake3.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
#------------------------


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-10 10:55 

注册: 2006-12-19 10:14
帖子: 107
送出感谢: 0 次
接收感谢: 0 次
报告:按照七楼的方法可以完美的解决问题,其他的方法没有实验过!报告完毕!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译