Ubuntu14.04安装steam失败

游戏讨论
回复
Charles.Lee
帖子: 3
注册时间: 2014-07-07 10:27
系统: ubuntu14.04
送出感谢: 0
接收感谢: 0

Ubuntu14.04安装steam失败

#1

帖子 Charles.Lee » 2015-12-27 21:41

首先感谢各位能过进来回答。
Ubuntu 64位安装steam报如下错误:

代码: 全选

W: 无法下载 http://dl.google.com/linux/chrome/deb/dists/stable/InRelease  

W: 无法下载 http://mirrors.163.com/ubuntu/dists/trusty-updates/main/i18n/Translation-en  Hash 校验和不符

W: 无法下载 http://mirrors.163.com/ubuntu/dists/trusty-security/main/i18n/Translation-en  Hash 校验和不符

W: 无法下载 http://mirrors.163.com/ubuntu/dists/trusty-security/universe/i18n/Translation-en  Hash 校验和不符

W: 无法下载 http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg  无法发起与 dl.google.com:80 (2404:6800:4005:80b::200e) 的连接 - connect (101: 网络不可达) [IP: 2404:6800:4005:80b::200e 80]

W: Some index files failed to download. They have been ignored, or old ones used instead.

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 libgl1-mesa-glx:i386 : 依赖: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.5)
 unity-control-center : 依赖: libcheese-gtk23 (>= 3.4.0) 但是它将不会被安装
                        依赖: libcheese7 (>= 3.0.1) 但是它将不会被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
下载steam还有Google的事情?电脑已经使用shadowsocksQT5翻墙成功,走的是PAC但是貌似只能对浏览器才可以,命令框无法ping同Google。
但是那些32位的库也找不到。不知各位高手是否有总结的博客、笔记之类的,小弟实在绞尽脑汁了。
头像
TeliuTe
论坛版主
帖子: 7434
注册时间: 2007-11-25 13:29
系统: 14/16/18/Fedroa22/w7
来自: 新疆博乐
送出感谢: 29 次
接收感谢: 99 次
联系:

Re: Ubuntu14.04安装steam失败

#2

帖子 TeliuTe » 2015-12-27 21:55

看提示是源错误,换别的源试试,比如sohu的源,
也可以到steam的官网里下载安装包安装试试
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 995 次
联系:

Re: Ubuntu14.04安装steam失败

#3

帖子 vickycq » 2015-12-27 21:56

W: 无法下载 http://dl.google.com/linux/chrome/deb/d ... /InRelease
下载steam还有Google的事情?
电脑已经使用shadowsocksQT5翻墙成功,走的是PAC但是貌似只能对浏览器才可以
安装 Chrome 后自动添加了 Google 官方源,被墙无法连接
apt-get 使用代理方法:apt-get -o Acquire::http::proxy="<address>:<port>" update
但只适用于 http 代理。你的 socks5 代理需转换为 http 代理才能被 apt-get 使用
使用 polipo 转换方法参考 https://github.com/shadowsocks/shadowso ... HTTP-proxy
W: 无法下载 http://mirrors.163.com/ubuntu/dists/tru ... slation-en Hash 校验和不符
一般来讲是运营商缓存问题。换源,挂代理或等几小时再试。
最可能有效的方法:电脑连接手机热点,走移动数据
也可删除 /var/lib/apt/lists/ 和 /var/cache/apt/archives/partial/ 下的所有文件
再执行 apt-get update 再试,不过一般无效果
下列软件包有未满足的依赖关系:
libgl1-mesa-glx:i386 : 依赖: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.5)
unity-control-center : 依赖: libcheese-gtk23 (>= 3.4.0) 但是它将不会被安装
依赖: libcheese7 (>= 3.0.1) 但是它将不会被安装
这个问题很普遍, 先解决上面的 Hash 校验和不符问题,保证 apt-get update 正常运行
再参考
https://bugs.launchpad.net/ubuntu/+sour ... ug/1424263
http://askubuntu.com/questions/588024/s ... untu-64bit
http://askubuntu.com/questions/590331/c ... 4-04-2-hwe
http://ubuntuforums.org/showthread.php?t=2268104
https://steamcommunity.com/discussions/ ... 244887789/
先解决上面的 Hash 校验和不符问题,保证 apt-get update 正常运行
如果是 14.04 + Linux 3.13 可能需要:

代码: 全选

sudo dpkg --add-architecture i386
sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386
如果是 14.04.3 + Linux 3.19 则需要

代码: 全选

sudo dpkg --add-architecture i386
sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid:i386
依此类推。注意先解决上面的 Hash 校验和不符问题,保证 apt-get update 正常运行
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
Charles.Lee
帖子: 3
注册时间: 2014-07-07 10:27
系统: ubuntu14.04
送出感谢: 0
接收感谢: 0

Re: Ubuntu14.04安装steam失败

#4

帖子 Charles.Lee » 2015-12-30 9:29

感谢楼上两位回答,这里我统一回复:
发现使用

代码: 全选

sudo apt-get install steam
既可以成功安装steam,不过是英文版的,下载的游戏也无法设置为中文。
回复

回到 “游戏和游戏模拟器”