当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu14.4无法运行steam[已解决]
帖子发表于 : 2016-02-26 0:47 

注册: 2013-10-25 9:06
帖子: 110
系统: Ubuntu14.10
送出感谢: 11
接收感谢: 0 次
网上查的资料是安装sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386就可以了
运行命令后出现
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
libc6:i386 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
default-jre : 依赖: openjdk-7-jre (>= 7~u3-2.1.1) 但是它将不会被安装
libgl1-mesa-dri-lts-utopic:i386 : 冲突: libgl1-mesa-dri
libgl1-mesa-glx-lts-utopic:i386 : 依赖: libglapi-mesa-lts-utopic:i386 (= 10.3.2-0ubuntu1~trusty2) 但是它将不会被安装
libqt5feedback5 : 依赖: libqt5multimedia5 (>= 5.0.2) 但是它将不会被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。


最后由 烈焰火凤 编辑于 2016-02-29 15:43,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-26 4:54 

注册: 2009-08-04 16:33
帖子: 17760
送出感谢: 21
接收感谢: 1911
引用:
ubuntu14.4

引用:
网上查的资料是安装sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386就可以了

1. 請提供 參考網頁網址
2. 把下面指令 複製 貼進終端機 執行
2-1. uname -a
把結果直接 選取/複製/貼上來


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-26 18:14 

注册: 2013-10-25 9:06
帖子: 110
系统: Ubuntu14.10
送出感谢: 11
接收感谢: 0 次
引用:
1. 請提供 參考網頁網址
2. 把下面指令 複製 貼進終端機 執行
2-1. uname -a
把結果直接 選取/複製/貼上來

参考网址 http://askubuntu.com/questions/588024/s ... untu-64bit
uname -a命令返回结果
Linux Lujb-Ubuntu 3.19.0-51-generic #57~14.04.1-Ubuntu SMP Fri Feb 19 14:36:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-26 20:25 

注册: 2009-08-04 16:33
帖子: 17760
送出感谢: 21
接收感谢: 1911
引用:
uname -a命令返回结果
Linux Lujb-Ubuntu 3.19.0-51-generic #57~14.04.1-Ubuntu SMP Fri Feb 19 14:36:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

1. http://packages.ubuntu.com/search?suite ... 51-generic
套件 linux-image-3.19.0-51-generic
3.19.0-51.57~14.04.1
1-1. 猜測 你的 Ubuntu 是 14.04.1
1-2. 以後提問 請先提供正確版本 因為給你的建議 可能大不同
1-3. 如果是 14.04.1
更新 14.04 / 14.04.1 / 14.2 / 14.3 到 14.04.4
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade # 選項
可以 升級到 14.04.4
引用:
sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386

2. libgl1-mesa-dri-lts-utopic
libgl1-mesa-glx-lts-utopic
是 在 Ubuntu 14.04.1 使用 LTS Hardware Enablement Stack 機制 採用 來自 14.10 的核心(提供的驅動模組)

3. https://wiki.ubuntu.com/Kernel/LTSEnabl ... el_Support
14.04.x Ubuntu Kernel Support
Ubuntu 14.04.4 應該使用
libgl1-mesa-dri-lts-wily
libgl1-mesa-glx-lts-wily
即使用 LTS Hardware Enablement Stack 機制 採用 來自 15.10 的核心(提供的驅動模組)

4. https://wiki.ubuntu.com/TrustyTahr/Rele ... ment_Stack
Only those installing from the 14.04.2 media or newer will automatically receive a newer hardware enablement stack by default.
如果你是從 Ubuntu 14.04.2 / 14.04.3 / 14.04.4 全新安裝 預設就支援 LTS Hardware Enablement Stack
4-1. 意思是 5. 就不必再安裝

5. https://wiki.ubuntu.com/TrustyTahr/Rele ... ment_Stack
LTS Hardware Enablement Stack
Anyone wishing to opt into the hardware enablement stack for Trusty may do so by running following command which will install the linux-generic-lts-wily and xserver-xorg-lts-wily packages:
sudo apt-get install --install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily
If you are on an amd64 system that boots with UEFI, you will also need the matching signed kernel:
sudo apt-get install linux-signed-generic-lts-wily
5-1. 如果你是從 13.10 或 以前版本 或 14.04 14.04.1 全新安裝 再升級到 14.04.4 需要安裝 :
sudo apt-get install --install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily
才會支援 LTS Hardware Enablement Stack
5-2. 如果開機韌體是 UEFI 還需額外安裝
sudo apt-get install linux-signed-generic-lts-wily
引用:
sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386


6. 建議
確認已經支援 LTS Hardware Enablement Stack 再安裝
sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-wily:i386 libgl1-mesa-glx-lts-wily:i386

7. 不要急著動手 先詳細看看 有沒有 不明白之處


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-26 22:03 

注册: 2013-10-25 9:06
帖子: 110
系统: Ubuntu14.10
送出感谢: 11
接收感谢: 0 次
奇怪我明明装的时候用的是14.04.03的啊,怎么就变成14.04.01了呢

那按照你说的是要先升级到14.04.04
sudo apt-get upgrade
sudo apt-get dist-upgrade # 選項
( # 選項 是什么不知道,是sudo apt-get dist-upgrade # 14.04.04吗)

再然后 支援 LTS Hardware Enablement Stack
sudo apt-get install --install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily

最后安装
sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-wily:i386 libgl1-mesa-glx-lts-wily:i386

是这样吗?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-27 7:10 

注册: 2009-08-04 16:33
帖子: 17760
送出感谢: 21
接收感谢: 1911
1. 建議
1-1. 更新到 Ubuntu 14.04.4 以後 先把整個 Ubuntu 備存 (備存 永遠是 好習慣)
1-1-1. sudo cat /etc/os-release | grep VERSION
確定是 14.04.04
1-2. 參考這一篇 安裝跟 Ubuntu 14.04 相容steam 客戶端
http://www.omgubuntu.co.uk/2014/04/stea ... ate-trusty
Steam for Linux Updated with ‘Ubuntu 14.04 Compatibility’
1-2-1. 安裝前 先比較 你目前使用的版本 跟 上述下載版本 哪個比較新 使用比較新的版本
1-3. 如果你是為了執行 Steam 等等 32-bit 遊戲客戶端 請參閱
1-3-1. https://wiki.ubuntu.com/Kernel/LTSEnabl ... ch_Desktop
Multiarch Desktop
If you run a multiarch desktop (for example, i386 and amd64 on amd64, for gaming or Wine), you may find you need a slightly more involved command, like this:
代码:
sudo apt-get install --install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily libgl1-mesa-glx-lts-wily libgl1-mesa-glx-lts-wily:i386 libglapi-mesa-lts-wily:i386

引用:
奇怪我明明装的时候用的是14.04.03的啊,怎么就变成14.04.01了呢

2. 把下面指令 複製 貼進終端機 執行
sudo cat /etc/os-release | grep VERSION
可以看出版本
2-1. 上面說 14.04.01 是根據 uname -r 猜的

3. 補充 上述建議 已經把前面的建議 精簡了
還有問題 歡迎再貼文


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-28 0:09 

注册: 2013-10-25 9:06
帖子: 110
系统: Ubuntu14.10
送出感谢: 11
接收感谢: 0 次
1-1-1. sudo cat /etc/os-release | grep VERSION
VERSION="14.04.4 LTS, Trusty Tahr"
VERSION_ID="14.04"

应该是从14.04.3升级上去的

1-2. 參考這一篇 安裝跟 Ubuntu 14.04 相容的 steam 客戶端
http://www.omgubuntu.co.uk/2014/04/stea ... ate-trusty
Steam for Linux Updated with ‘Ubuntu 14.04 Compatibility’
1-2-1. 安裝前 先比較 你目前使用的版本 跟 上述下載版本 哪個比較新 使用比較新的版本
默认打开软件中心,提示在您当前的软件源中没有名为 “steam”的软件包。
1-3. 如果你是為了執行 Steam 等等 32-bit 遊戲客戶端 請參閱
1-3-1. https://wiki.ubuntu.com/Kernel/LTSEnabl ... ch_Desktop
引用:
sudo apt-get install --install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily libgl1-mesa-glx-lts-wily libgl1-mesa-glx-lts-wily:i386 libglapi-mesa-lts-wily:i386

libgl1-mesa-glx-lts-wily 已经是最新的版本了。
libwayland-egl1-mesa-lts-wily 已经是最新的版本了。
linux-generic-lts-wily 已经是最新的版本了。
xserver-xorg-core-lts-wily 已经是最新的版本了。
xserver-xorg-input-all-lts-wily 已经是最新的版本了。
xserver-xorg-lts-wily 已经是最新的版本了。
xserver-xorg-video-all-lts-wily 已经是最新的版本了。
libgl1-mesa-glx-lts-wily:i386 已经是最新的版本了。
libglapi-mesa-lts-wily:i386 已经是最新的版本了。

最后执行steam,还是无法运行


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-28 7:05 

注册: 2009-08-04 16:33
帖子: 17760
送出感谢: 21
接收感谢: 1911
引用:
默认打开软件中心,提示在您当前的软件源中没有名为 “steam”的软件包。

1. http://packages.ubuntu.com/search?suite ... chon=names
套件 steam
trusty (14.04LTS) (games): Valve's Steam digital software delivery system [multiverse]
1:1.0.0.45-1ubuntu1: i386
1-1. 先把 multiverse 套件庫加入 軟體來源
然後
sudo apt-get update
sudo apt-get install steam
1-2. 安裝 steam 以後 提供 可執行桌面捷徑
/usr/share/applications/steam.desktop
1-3. 解開 / 參閱 下述 manpage
/usr/share/man/man6/steam.6.gz
/usr/share/man/man6/steam.real.6.gz
1-4. 補充 注意 上述是 i386
引用:
最后执行steam,还是无法运行

2. 參閱
https://steamcommunity.com/app/221410/d ... 053170837/
Steam for Ubuntu 14.04 Trusty [Solved]
2-1. 特別是
2-1-1. https://steamcommunity.com/app/221410/d ... 8158697611
(記得比較版本 採用比較新版本)
2-1-2. https://steamcommunity.com/app/221410/d ... 4257311119
如果已經安裝閉源驅動 試試 先移除閉源驅動 使用 開源驅動 安裝 steam
安裝好 steam 再重新安裝閉源驅動 並且把開源驅動 列入黑名單
2-1-3. https://steamcommunity.com/app/221410/d ... 1691736856
移除 steam 安裝 wine 再安裝 steam-launcher
2-1-4. 提醒 2-1-2 / 2-1-3 先試試一種就好


页首
 用户资料  
 
9 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-28 15:05 

注册: 2013-10-25 9:06
帖子: 110
系统: Ubuntu14.10
送出感谢: 11
接收感谢: 0 次
2-1-2 / 2-1-3 都试验了还是不行

系统刚装好的时候是可以用的啊,晕了


页首
 用户资料  
 
10 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-28 20:14 

注册: 2009-08-04 16:33
帖子: 17760
送出感谢: 21
接收感谢: 1911
今晚 我安裝看看 明早 再繼續討論
引用:
系统刚装好的时候是可以用的啊

備存 永遠是好習慣
如果你有備存 回存就解決了



_________________
评价: 3.7% 烈焰火凤
 
页首
 用户资料  
 
11 楼 
 文章标题 : Re: ubuntu14.4无法运行steam
帖子发表于 : 2016-02-28 23:52 

注册: 2013-10-25 9:06
帖子: 110
系统: Ubuntu14.10
送出感谢: 11
接收感谢: 0 次
不用了,谢谢,晚上又试了一下,莫名其妙就可以用了


页首
 用户资料  
 
12 楼 
 文章标题 : Re: ubuntu14.4无法运行steam[已解决]
帖子发表于 : 2016-08-04 14:00 

注册: 2016-08-04 9:46
帖子: 23
送出感谢: 2
接收感谢: 0 次
马克一级


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译