[问题]安装一个类FF游戏-allacrost出错

游戏讨论
回复
头像
levin
帖子: 109
注册时间: 2007-07-26 12:40
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

[问题]安装一个类FF游戏-allacrost出错

#1

帖子 levin » 2007-08-03 8:23

我根据http://www.allacrost.org/?q=node/3 所介绍的办法安装allacrost
先是将deb http://debian.ettin.org/allacrost etch-backports main 加到我的/etc/apt/sources.list中
再apt-get update更新源
再apt-get install allacrost-demo
出现了依赖性问题:
pluto@ubuntu:~/ubuntuway/software$ sudo apt-get install allacrost-demo
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
allacrost-demo: Depends: libc6 (>= 2.3.6-6) but 2.3.6-0ubuntu20.5 is to be ins talled
Depends: libgcc1 (>= 1:4.1.1-12) but 1:4.0.3-1ubuntu5 is to be installed
Depends: liblua50 (>= 5.0.3) but 5.0.2-5ubuntu1 is to be insta lled
Depends: libluabind0 but it is not going to be installed
Depends: liblualib50 (>= 5.0.3) but 5.0.2-5ubuntu1 is to be in stalled
Depends: libpng12-0 (>= 1.2.13-4) but 1.2.8rel-5ubuntu0.2 is t o be installed
Depends: libsdl1.2debian (>= 1.2.10-1) but 1.2.9-0.0ubuntu2 is to be installed
Depends: libstdc++6 (>= 4.1.1-12) but 4.0.3-1ubuntu5 is to be installed
E: Broken packages

然而我的libc6包(其他的包应该也是)已经是最新版本了
pluto@ubuntu:~/ubuntuway/software$ sudo apt-get install libc6
Reading package lists... Done
Building dependency tree... Done
libc6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

这个问题该怎么办?
But for Ubuntu, I will die.
头像
carlos444_444
帖子: 444
注册时间: 2005-06-06 21:35
系统: Debian
来自: 双子星
送出感谢: 3 次
接收感谢: 2 次
联系:

#2

帖子 carlos444_444 » 2007-08-06 19:26

只留下一组官方源和你的游戏源,把其他的源暂时都注释掉。
如果还不行,可能是你的源还存在冲突。
唯一的办法是到www.debian.org搜索游戏需要的几个主要包。
头像
levin
帖子: 109
注册时间: 2007-07-26 12:40
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 levin » 2007-08-06 20:50

谢谢了 我已经没有问题了
解决办法正如2楼的个性签名
我装了7.04
从而一切都解决了
不过那个游戏源下载速度还真不是一般的慢 10K左右
下载包有50M 我放弃了这个游戏
But for Ubuntu, I will die.
回复

回到 “游戏和游戏模拟器”