当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 编译安装xmame出现的问题!
帖子发表于 : 2007-09-22 17:38 

注册: 2007-08-29 22:44
帖子: 320
送出感谢: 0 次
接收感谢: 0 次
错误如下:
Compiling src/xmlfile.c ...
src/xmlfile.c:16:19: 错误: expat.h:No such file or directory
src/xmlfile.c:24: 错误: expected specifier-qualifier-list before ‘XML_Parser’
src/xmlfile.c:178: 警告: 在 ‘XML_Char’ 的声明中,类型默认为 ‘int’
src/xmlfile.c:178: 错误: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
src/xmlfile.c:206: 警告: 在 ‘XML_Char’ 的声明中,类型默认为 ‘int’
src/xmlfile.c:206: 错误: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
src/xmlfile.c:240: 警告: 在 ‘XML_Char’ 的声明中,类型默认为 ‘int’
src/xmlfile.c:240: 错误: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
src/xmlfile.c: 在函数 ‘setup_parser’ 中:
src/xmlfile.c:314: 错误: ‘xml_parse_info’ 没有名为 ‘flags’ 的成员
src/xmlfile.c:324: 错误: ‘xml_parse_info’ 没有名为 ‘rootnode’ 的成员
src/xmlfile.c:325: 错误: ‘xml_parse_info’ 没有名为 ‘rootnode’ 的成员
src/xmlfile.c:327: 错误: ‘xml_parse_info’ 没有名为 ‘curnode’ 的成员
src/xmlfile.c:327: 错误: ‘xml_parse_info’ 没有名为 ‘rootnode’ 的成员
src/xmlfile.c:330: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:330: 警告: 隐式声明函数 ‘XML_ParserCreate’
src/xmlfile.c:331: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:333: 错误: ‘xml_parse_info’ 没有名为 ‘rootnode’ 的成员
src/xmlfile.c:338: 警告: 隐式声明函数 ‘XML_SetElementHandler’
src/xmlfile.c:338: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:338: 错误: ‘xml_element_start’ 未声明 (在此函数内第一次使用)
src/xmlfile.c:338: 错误: (即使在一个函数内多次出现,每个未声明的标识符在其
src/xmlfile.c:338: 错误: 所在的函数内只报告一次。)
src/xmlfile.c:338: 错误: ‘xml_element_end’ 未声明 (在此函数内第一次使用)
src/xmlfile.c:339: 警告: 隐式声明函数 ‘XML_SetCharacterDataHandler’
src/xmlfile.c:339: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:339: 错误: ‘xml_data’ 未声明 (在此函数内第一次使用)
src/xmlfile.c:340: 警告: 隐式声明函数 ‘XML_SetUserData’
src/xmlfile.c:340: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:344: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c: 在函数 ‘xml_file_read’ 中:
src/xmlfile.c:375: 警告: 隐式声明函数 ‘XML_Parse’
src/xmlfile.c:375: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:375: 错误: ‘XML_STATUS_ERROR’ 未声明 (在此函数内第一次使用)
src/xmlfile.c:379: 警告: 隐式声明函数 ‘XML_ErrorString’
src/xmlfile.c:379: 警告: 隐式声明函数 ‘XML_GetErrorCode’
src/xmlfile.c:379: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:379: 警告: 赋值时将整数赋给指针,未作类型转换
src/xmlfile.c:380: 警告: 隐式声明函数 ‘XML_GetCurrentLineNumber’
src/xmlfile.c:380: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:381: 警告: 隐式声明函数 ‘XML_GetCurrentColumnNumber’
src/xmlfile.c:381: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:384: 错误: ‘xml_parse_info’ 没有名为 ‘rootnode’ 的成员
src/xmlfile.c:385: 警告: 隐式声明函数 ‘XML_ParserFree’
src/xmlfile.c:385: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:392: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:395: 错误: ‘xml_parse_info’ 没有名为 ‘rootnode’ 的成员
src/xmlfile.c: 在函数 ‘xml_string_read’ 中:
src/xmlfile.c:416: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:416: 错误: ‘XML_STATUS_ERROR’ 未声明 (在此函数内第一次使用)
src/xmlfile.c:420: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:420: 警告: 赋值时将整数赋给指针,未作类型转换
src/xmlfile.c:421: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:422: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:425: 错误: ‘xml_parse_info’ 没有名为 ‘rootnode’ 的成员
src/xmlfile.c:426: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:431: 错误: ‘xml_parse_info’ 没有名为 ‘parser’ 的成员
src/xmlfile.c:434: 错误: ‘xml_parse_info’ 没有名为 ‘rootnode’ 的成员
make: *** [xmame.obj/xmlfile.o] 错误 1


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-25 15:58 
头像

注册: 2007-03-24 23:45
帖子: 2357
送出感谢: 0 次
接收感谢: 9
缺少某些库文件,你自己猜一下缺少什么装上后再编译


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-28 19:00 

注册: 2007-09-18 22:31
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
楼上的你这样的回答等于没说...

to 楼主:
sudo aptitude install libexpat1-dev 后就可以了


P。S。
Expat by James Clark 已经不包含在以前的 expat了, aptitude install expat 解决不了问题


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-01 20:43 

注册: 2007-08-29 22:44
帖子: 320
送出感谢: 0 次
接收感谢: 0 次
还是不行,还是老样子的错误提示。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-01 21:45 
头像

注册: 2006-09-30 0:32
帖子: 2717
地址: 巴拉特星系第四行星──海尼森
送出感谢: 0 次
接收感谢: 0 次
没用的 , 那软件没有提供 config

根本不可能知道缺啥 , 安装所有版本所有类型开发编译环境 ?


_________________
头可断,血可流,靓女不可不追求
相艾唔好口,够姜就只抽

BARTON 2500+/1536MDDR400
EP8RDA3G/MX4000 128M64bit 8X
DiamondPlus9-6Y080L0-ATA133
Samsung743DF
HiweedDesktop-1.0


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-02 17:35 

注册: 2007-09-18 22:31
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
expat.h 是在我所说的包里阿。。
如果我不是亲自编译安装了, 我还不敢如此100%肯定
我当初也卡在这里,然后get了这个包后才继续的
如果搂住还是不行,俺也米办法了,你自己google多try几个包吧

俺是ubuntu7.04, 编译的时候手动装了3次包, build-essential 是第一个,这个是第2个,最后还有一个,我也是google到的。

没有CONFIG是麻烦了点... 但是根据顶层的报错去找相关的包还是容易搞定的


myst_tt 写道:
楼上的你这样的回答等于没说...

to 楼主:
sudo aptitude install libexpat1-dev 后就可以了


P。S。
Expat by James Clark 已经不包含在以前的 expat了, aptitude install expat 解决不了问题


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译