当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 为何我的Open Arena无法运行
帖子发表于 : 2007-12-08 0:34 

注册: 2007-10-21 16:15
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我是通过新立得从源里装的0.60版的Open Arena,安装好后在应用程序菜单里运行,但只是弹出一个黑色窗口,一闪就没有了。
我考虑可能是我开启Compiz的原因,就在外观里把特效关闭了。但运行结果仍然是一闪而过。
于是我又安装了自己编译的ATI的7.11的dev包,仍然不能解决。

我是新手,望哪位给个指导。
9550显卡


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-08 0:38 

注册: 2007-10-21 16:15
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
duetg@duetg-desktop:~$ openarena -e
ioQ3 1.33+oa linux-i386 Jul 5 2007
----- FS_Startup -----
Current search path:
/home/duetg/.openarena/baseoa
/usr/share/games/openarena/baseoa/pak6-misc.pk3 (96 files)
/usr/share/games/openarena/baseoa/pak5-TA.pk3 (7 files)
/usr/share/games/openarena/baseoa/pak4-textures.pk3 (932 files)
/usr/share/games/openarena/baseoa/pak2-players.pk3 (187 files)
/usr/share/games/openarena/baseoa/pak1-maps.pk3 (25 files)
/usr/share/games/openarena/baseoa/pak0.pk3 (748 files)
/usr/share/games/openarena/baseoa
/usr/lib/games/openarena/baseoa

----------------------
1995 files in pk3 files
execing default.cfg
couldn't exec q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----

------- Input Initialization -------
Joystick is not active.
------------------------------------
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
Initializing OpenGL display
...setting mode 3: 640 480
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect


***********************************************************
You are using software Mesa (no hardware acceleration)!
Driver DLL used: libGL.so.1
If this is intentional, add
"+set r_allowSoftwareGL 1"
to the command line when starting the game.
***********************************************************
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

duetg@duetg-desktop:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon 9550 / X1050 Series
OpenGL version string: 2.1.7059 Release

我的特效可以打开,但为何Open Arena还是说我用的是软加速呢?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-08 1:01 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
fglrxinfo|grep render
render有Yes吗?

Sys_Error: GLimp_Init() - could not load OpenGL subsystem


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-08 8:46 
头像

注册: 2006-12-22 18:53
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
同样的问题。好像Opengl打不开。不知道怎么回事。
上次用cedega测试一下,也是opengl打不开。其他compiz正常。
好像只要全屏的游戏都不可以运行。只有声音,没有视频输出。LZ是不是也是这样?
不知道如何解决


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-08 20:17 

注册: 2007-10-21 16:15
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
找出原因了,是安装了xgl的缘故。卸载了xgl就可以运行了。
只是为何游戏特别暗,无论在setting里怎么调都没用呢?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 为何我的Open Arena无法运行
帖子发表于 : 2008-11-30 12:19 

注册: 2007-09-22 1:11
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
将视觉效果关闭,选择无就行了!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译