draftsight 2017或者draftsight 2018中不能输入中文问题及解决办法

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
ws94501564
帖子: 22
注册时间: 2011-01-15 23:30
送出感谢: 0
接收感谢: 1 次

draftsight 2017或者draftsight 2018中不能输入中文问题及解决办法

#1

帖子 ws94501564 » 2017-06-12 13:26

2017-04-27 draftsight 输入法问题
最近为了搞定 draftsight 2017 1 版,在网上查了好几周的资料也没有解决了。但是我
http://www.fcitx-im.org 找到了原因,因为 draftsight 绑定的是 draftsight 自己的 qt 库。
同时也提供了解决办法的线索,但是因为自己的智商问题,没能解决。

今天我翻墙去 google 查看到了解决加法。

———
Ok it’s an app bundle with its own qt, so it’s not surprise it doesn’t work with
systems fcitx qt5 plugin.

I tried to analyze the path and library it used, seems it can work with xenial’s
fcitx-qt5.

You can try to get two required files from libfcitx-qt5-1 and fcitx-frontend-qt5
and put them under :
/opt/dassault-systemes/DraftSight/Libraries/libFcitxQt5DBusAddons.so.1
/opt/dassault-systemes/DraftSight/QtPlugIns/platforminputcontexts/libfcitxplatforminputcontextplugin.so

I can use fcitx in draftsight on my system.

It works. Thank you very much.
———

我将上面的方法给修改了一点, 首先安装libfcitx-qt5-1 and fcitx-frontend-qt5 . 然后通过find找到上面提到的两个文件, 然后通过ln -s 做软连接到上面文件所提到的内容. 这样做的好处是, 如果上面提到的两个文件包作了更新, 我们也能使用新的文件.
http://www.supermew.top/?p=1010

经过多日来的努力, 现在已经解决了draftsight 2018
真对draftsight 2018的解决办法:

1)安装完成 draftsight 2018后,
2)到 https://packages.ubuntu.com/ 上去下载 xenial(也就是ubuntu 16.04)的 libfcitx-qt5-1 和 fcitx-frontend-qt5 两个包, 记住一定要用xenial的包, 因为draftsight 2018所使用的qt库的版本比较低不与qt最新库兼容。目前最新的qt库是5.9, 但是draftsight 2018使用的还是5.5的老库。
3)然后抽取这两个包中的libFcitxQt5DBusAddons.so.1 和 libfcitxplatforminputcontextplugin.so 放到上面提到的相应位置。
4)到 http://www.baidu.com/link?url=AFKUpJrR0 ... 055a5201ce 去下载 jasPer-2。4, 并编译将其中的libjasper.so.4.0.0 复制到 /opt/dassault-systemes/DraftSight/Libraries/ 目录下, 并且生成连接为 libjasper.so.1采用如下命令

代码: 全选

ln -s libjasper.so.4.0.0 libjasper.so.1
5) 还有几个修改我记不清楚了, 不过都是一些连接没有, 因此只需要在opt/dassault-systemes/DraftSight/Libraries/ 目录生成相应的连接就行了。用如下命令可以知道哪些库需要做。

代码: 全选

export QT_DEBUG_PLUGINS=1 
export QT_LOGGING_RULES="*.debug=true"
cd /opt/dassault-systemes/DraftSight/Linux/
Draftsight&& 2>~/1.txt
cd ~
vim 1.txt 
然后就可以在1.txt找没有加载成功的库, 相应错误的括号中有提到某个库没有, 加载不成功比如xxxx.so.xx.xx 找不到, 你就需要到/opt/dassault-systemes/DraftSight/Libraries/查找ls xxxx.so*, 就可以看到应相的库了, 这时你需要根据提示的库名做相应的连接。
6) 当所有的库都加载成功后, 重启电脑, 然后进行draftsight 2018就能使用fcitx输入法了。
上次由 ws94501564 在 2018-02-14 7:24,总共编辑 3 次。
wswzc001
帖子: 1
注册时间: 2016-05-07 20:28
系统: ubuntu kylin 16.01
送出感谢: 0
接收感谢: 0

Re: draftsight2017中不能输入中文问题及解决办法

#2

帖子 wswzc001 » 2017-07-18 9:39

能再具体点吗,初学者不是很明白 :Sad
ws94501564
帖子: 22
注册时间: 2011-01-15 23:30
送出感谢: 0
接收感谢: 1 次

Re: draftsight2017中不能输入中文问题及解决办法

#3

帖子 ws94501564 » 2017-12-28 1:14

该方法已经不能解决 ubuntu 17.10 中的 draftsight 2018 的输入法问题了。
头像
Ping-Wu
帖子: 879
注册时间: 2012-11-14 9:34
系统: Ubuntu 18.04.1
送出感谢: 2 次
接收感谢: 45 次

Re: draftsight2017中不能输入中文问题及解决办法

#4

帖子 Ping-Wu » 2017-12-28 4:29

ws94501564 写了:该方法已经不能解决 ubuntu 17.10 中的 draftsight 2018 的输入法问题了。
我对 draftSight 完全不懂(但很有兴趣)也没碰过。但刚刚随便装了一下 draftSight 2018 SPU 免费版(Ubuntu 16.04.3, IBus/(pinyin + libpinyin)),好像没有什么问题???
draftsight.jpg
ws94501564
帖子: 22
注册时间: 2011-01-15 23:30
送出感谢: 0
接收感谢: 1 次

Re: draftsight2017中不能输入中文问题及解决办法

#5

帖子 ws94501564 » 2017-12-29 14:33

Ping-Wu 写了:
ws94501564 写了:该方法已经不能解决 ubuntu 17.10 中的 draftsight 2018 的输入法问题了。
我对 draftSight 完全不懂(但很有兴趣)也没碰过。但刚刚随便装了一下 draftSight 2018 SPU 免费版(Ubuntu 16.04.3, IBus/(pinyin + libpinyin)),好像没有什么问题???
draftsight.jpg
这应该是ubuntu 17.10的原因, 因为17.10将原有的unity换成了gnome shell
头像
eagle5678
帖子: 1820
注册时间: 2006-07-08 14:07
送出感谢: 14 次
接收感谢: 1 次

Re: draftsight2017中不能输入中文问题及解决办法

#6

帖子 eagle5678 » 2018-01-12 8:00

Ping-Wu 写了:
ws94501564 写了:该方法已经不能解决 ubuntu 17.10 中的 draftsight 2018 的输入法问题了。
我对 draftSight 完全不懂(但很有兴趣)也没碰过。但刚刚随便装了一下 draftSight 2018 SPU 免费版(Ubuntu 16.04.3, IBus/(pinyin + libpinyin)),好像没有什么问题???
draftsight.jpg
老吴用的是IBus

draftisight强制升级……
ws94501564
帖子: 22
注册时间: 2011-01-15 23:30
送出感谢: 0
接收感谢: 1 次

Re: draftsight 2017或者draftsight 2018中不能输入中文问题及解决办法

#7

帖子 ws94501564 » 2018-02-08 10:08

该方法已经得到修改, 能够修复 draftsight 2018 了.
头像
careone
帖子: 804
注册时间: 2007-12-17 21:41
送出感谢: 71 次
接收感谢: 24 次

Re: draftsight 2017或者draftsight 2018中不能输入中文问题及解决办法

#8

帖子 careone » 2018-02-18 15:42

我按深度论坛上的帖子,打了个 amd64 的 DEB 补丁包。


https://bbs.deepin.org/forum.php?mod=vi ... tid=152385
› 社区支持 › 系统相关 › 关于draftsight不能输入中文的完美解决方法
见5楼回复

----
DEB 补丁包 下载地址:
https://sourceforge.net/projects/emacsl ... tch-zh-cn/
魁拔不死,天下不宁。
魁拔既死,天下不平。
--------------
Careone <emacslocale^126.com>
https://sourceforge.net/projects/emacslocale/files/
风软农夫
帖子: 27
注册时间: 2010-08-16 16:56
送出感谢: 0
接收感谢: 0

Re: draftsight 2017或者draftsight 2018中不能输入中文问题及解决办法

#9

帖子 风软农夫 » 2018-03-24 21:38

我是直接用ibus
江富桥
帖子: 25
注册时间: 2009-11-27 18:16
送出感谢: 0
接收感谢: 0

Re: draftsight 2017或者draftsight 2018中不能输入中文问题及解决办法

#10

帖子 江富桥 » 2018-03-26 21:24

直接用系统自带的ibus就可以用中文输入了 最好不要用搜狗拼音阿
shimingzhou
帖子: 256
注册时间: 2008-06-28 6:14
送出感谢: 1 次
接收感谢: 6 次

Re: draftsight 2017或者draftsight 2018中不能输入中文问题及解决办法

#11

帖子 shimingzhou » 2018-04-13 20:30

用fcitx的话,请在终端尝试:env GTK_IM_MODULE=xim env QT_IM_MODULE=xim draftsight。因为通常都会支持xim,而且qt和gtk都支持xim输入
回复

回到 “办公、图像、机械电子设计等”