当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装了一些java包后出了问题
帖子发表于 : 2005-06-26 19:46 
头像

注册: 2005-06-25 21:57
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
我用新立得软件包管理器安装了free-java-sdk,java2-common,java-common后在终端启动lumaqq后出现错误。
出错提示如下:
jasmin@jasminwang:~$ java.lang.UnsatisfiedLinkError: Could not load library /usr/lib/sablevm-classpath/libswt-pi-gtk-3062
at java.lang.Runtime.load (Runtime.java:647)
at java.lang.Runtime.loadLibrary (Runtime.java:733)
at java.lang.System.loadLibrary (System.java:510)
at org.eclipse.swt.internal.Library.loadLibrary (Library.java:100)
at org.eclipse.swt.internal.gtk.OS.static{} (OS.java:19)
at java.lang.VMClass.step8 (VMClass.java)
at java.lang.Class.initialize (Class.java:145)
at org.eclipse.swt.internal.Converter.wcsToMbcs (Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs (Converter.java:54)
at org.eclipse.swt.widgets.Display.static{} (Display.java:118)
at java.lang.VMClass.step8 (VMClass.java)
at java.lang.Class.initialize (Class.java:145)
at edu.tsinghua.lumaqq.shells.MainShell.MainShell (Unknown Source)
at edu.tsinghua.lumaqq.LumaQQ.main (Unknown Source)
at java.lang.VirtualMachine.invokeMain (VirtualMachine.java)
at java.lang.VirtualMachine.main (VirtualMachine.java:92)

我在新立得软件包管理器里找了一下,没有发现它所说的那个/usr/lib/sablevm-classpath/libswt-pi-gtk-3062


另外在终端输入java -version 后显示:SableVM version 1.1.8
- compile date and time: 2005-01-01 19:42:24 UTC
- gcc version: 3.3.5 (Debian 1:3.3.5-5)
- 'real life brokenness' features enabled
- signal based exception detection
- copying garbage collection
- bidirectional object layout
- inline-threaded interpreter
不知该如何解决这个问题。


大家能帮忙看看么。谢谢了。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-06-26 21:56 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
http://www.ubuntu.org.cn/first_install/document_view

中的安装java


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-06-26 22:17 
头像

注册: 2005-06-25 21:57
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
一开始我是按照那篇文章作的阿。上面所说的那些包是我之后安装的。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-06-26 23:30 
头像

注册: 2005-06-25 21:57
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
解决了。我发现是java-sablevm在作怪。我在新立得软件包里面把libsablevm之类的包该删除了。结果好了。但不知道java-sablevm是干嘛用的。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译