sudo apt-get install 不能用

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
flycanfly
帖子: 11
注册时间: 2005-06-25 8:50
送出感谢: 0
接收感谢: 0
联系:

sudo apt-get install 不能用

#1

帖子 flycanfly » 2005-07-02 10:07

sources.list已经按“快速设置”里更改过,apt-get update也做过,之后无论安装什么软件都是这样

代码: 全选

sky@sky:~$ sudo apt-get install fcitx
Password:
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  mozilla-firefox-gnome-support: Depends: firefox-gnome-support but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
sky@sky:~$
头像
max0000
帖子: 310
注册时间: 2005-04-08 14:54
送出感谢: 0
接收感谢: 0

Re: sudo apt-get install 不能用

#2

帖子 max0000 » 2005-07-02 10:12

flycanfly 写了:sources.list已经按“快速设置”里更改过,apt-get update也做过,之后无论安装什么软件都是这样

代码: 全选

sky@sky:~$ sudo apt-get install fcitx
Password:
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  mozilla-firefox-gnome-support: Depends: firefox-gnome-support but it is not going to be installed
E: Unmet dependencies. Try '[color=red]apt-get -f install[/color]' with no packages (or specify a solution).
sky@sky:~$

按提示作一下看看
flycanfly
帖子: 11
注册时间: 2005-06-25 8:50
送出感谢: 0
接收感谢: 0
联系:

the same

#3

帖子 flycanfly » 2005-07-02 10:51

代码: 全选

sky@sky:~$ sudo apt-get -f install fcitx
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  mozilla-firefox-gnome-support: Depends: firefox-gnome-support but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
sky@sky:~$

yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 yongyi » 2005-07-02 10:54

先试试把mozilla-firefox-gnome-support装上:

代码: 全选

sudo apt-get install mozilla-firefox-gnome-support


应该是dist-upgrade时那个包没装上,造成所有下载的包都还没安装和设置
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
flycanfly
帖子: 11
注册时间: 2005-06-25 8:50
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 flycanfly » 2005-07-03 8:37

代码: 全选

sky@sky:~$ [color=red]sudo apt-get install mozilla-firefox-gnome-support[/color]
Reading package lists... Done
Building dependency tree... Done
mozilla-firefox-gnome-support is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  mozilla-firefox-gnome-support: Depends: firefox-gnome-support but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


sky@sky:~$ [color=red]sudo apt-get install -f mozilla-firefox-gnome-support[/color]
Reading package lists... Done
Building dependency tree... Done
mozilla-firefox-gnome-support is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  mozilla-firefox-gnome-support: Depends: firefox-gnome-support but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
sky@sky:~$
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 yongyi » 2005-07-03 9:17

so sorry
应该是 firefox-gnome-support 没安装吧?
试试
sudo apt-get install firefox-gnome-support
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
flycanfly
帖子: 11
注册时间: 2005-06-25 8:50
送出感谢: 0
接收感谢: 0
联系:

搞定了

#7

帖子 flycanfly » 2005-07-04 16:06

谢谢,现在可以安装了。
fatalerr
帖子: 49
注册时间: 2007-09-06 17:54
送出感谢: 0
接收感谢: 0

Re: 搞定了

#8

帖子 fatalerr » 2007-11-28 9:15

flycanfly 写了:谢谢,现在可以安装了。


请问您是如何解决你的问题的?能分享一下吗?
snoopywang
帖子: 6
注册时间: 2007-12-04 0:56
来自: Xi'an, China
送出感谢: 0
接收感谢: 0
联系:

Re: 搞定了

#9

帖子 snoopywang » 2007-12-06 20:44

fatalerr 写了:
flycanfly 写了:谢谢,现在可以安装了。


请问您是如何解决你的问题的?能分享一下吗?


应该是
sudo apt-get install -f
修复一下用的吧
回复

回到 “办公、图像、机械电子设计等”