当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Linux 下 abaqus6.7 安装成功
帖子发表于 : 2008-05-06 14:41 

注册: 2008-04-01 14:15
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
这里转载了china_qiu大部分内容,特别表示感谢china_qiu,非常赞赏他的奉献精神,本人作了一点修改,请大家参阅
http://forum.ubuntu.org.cn/viewtopic.php?t=82543
[原创]在ubuntu7.10上成功安装和使用abaqus v6.7 linux版本,经验共享


1、下载abaqusv6.7.bin是bin文件,在linux中需转化为iso
1.1 从http://mange.dynup.net/linux/bin2iso/bin2iso-0.4.c下载
1.2 用gcc -o bin2iso-0.4 bin2iso-0.4.c编译(如不能编译,可能需重装gcc,我装了gfortran后即可编译)
1.3 在bin2iso路径下,输入 ./bin2iso-0.4 /.../file.bin /.../file.iso完成转换
2、安装Document
2.1 需要libtermcap.so.2,下载三个文件:libtermcap.so.2.deb,libc5_5.4.46-15_i386.deb,termcap-compat_1.2.3_i386.deb
按上面顺序安装即可
下载地址:http://packages.debian.org/sarge/ldso
http://packages.debian.org/sarge/libc5
http://packages.debian.org/oldstable/ol ... cap-compat
2.2 输入sudo mount -o loop /.../file.iso /mnt 将iso加载至/mnt中,现在可以在/mnt目录中看到加载的文件,其中有一个setup文件
2.3 setup是个c shell 文件,需要执行sudo apt-get install csh,然后在终端下将自己的目录切换到根目录即cd /home/yourname,
执行 /mnt/./setup(可能需要加sudo),
出现提示:
*****************************************
A scratch directory is required to extract the java runtime
environment that is required to execute the installer.

$TMPDIR is not defined on this system. Provide the full path
to the scratch directory.

Scratch directory is:
****************************************
在Scratch directory is: 后面输入一个temp文件夹完整路径,如/home/yourname/temp,作为临时目录,
你可以在你的根目录下建立一个文件夹temp(mkdir /home/yourname/temp)
此时出现安装界面,按默认安装即可,安装位置自己可以修改
2.4 sudo mkdir /usr/tmp,创建这个文件夹是用来放flexm的,否则安装license server完后,./lmgrd -c license.dat会报错的
2.5 Document安装结束提供的链接: http://cheng-desktop:2080/v6.7/,在浏览器中输入http://cheng-desktop:2080/v6.7/或者
输入http://localhost:2080/v6.7/即可打开abaqus帮助文档
3 安装abaqus的主程序
3.1 使用sudo mount -o loop /.../file.iso /mnt挂载cd1的iso文件
3.2 在/mnt/SHooTERS/license中将license.dat拷贝到根目录
cp /mnt/SHooTERS/license/license.dat /home/cheng,并将其改为读写权限
双击打开license.dat后,将<pc-name>替换为你的计算机名,在这里即是http://cheng-desktop:2080/v6.7/中的
cheng-desktop,保存退出
3.3 切换到根目录即cd ~,执行 /mnt/./setup -nosystemchecks (可能需要加sudo)
出现提示:
*****************************************
A scratch directory is required to extract the java runtime
environment that is required to execute the installer.

$TMPDIR is not defined on this system. Provide the full path
to the scratch directory.

Scratch directory is:
****************************************
在Scratch directory is: 后面输入一个temp文件夹完整路径,如/home/yourname/temp,作为临时目录
此时出现安装界面,默认安装,一直到选择选择License或Prodcut时,选择安装License,在后面选择No,an Abaqus License Server not exists
********************************************************************
10:42:10 (lmgrd) -----------------------------------------------
10:42:10 (lmgrd) Please Note:
10:42:10 (lmgrd)
10:42:10 (lmgrd) This log is intended for debug purposes only.
10:42:10 (lmgrd) In order to capture accurate license
********************************************************************
运行./lmutil lmstat #可以查看license server 是否正常启动
********************************************************************
lmutil - Copyright (c) 1989-2005 Macrovision Europe Ltd. and/or Macrovision Corporation. All Rights Reserved.
********************************************************************
至此license server 安装结束。接下来回到安装界面,我们继续开始安装Product,这个过程的安装目录/opt/abaqus,输入的license server 的
名称,可以通过./lmutil lmstat 查看到你的,形式:2700X@xxxxx,具体看下你的机器显示。

然后是next……一直往下走就可以了。
3.4 将/mnt/SHooTERS/exec目录下的文件拷贝到安装目录下的 exec文件夹下,粘贴替换,完成安装
4 启动abaqus CAE
4.1 找到安装后的Command目录,cd Command
4.2 ./abaqus cae
标准的启动方式是abaqus cae -mesa,因为没有设置好主目录的原因,故无法这样启动。只能用./abaqus cae的方式启动
个人感觉:./abaqus cae -mesa启动后的界面的刷新速度有问题的,很慢的,显示效果不是很好。而通过./abaqus cae 启动时,刷新速度提高,显示效果
好点。建议关掉3d桌面,不然的话,可能CAE显示时是透明的。哈哈
abaqus cae 这个命令是默认启用显卡的,而abaqus cae -mesa则是关闭显卡功能的。因为abaqus在某些显卡上不能运行。当执行这个命令时,abaqus界
面的刷新会很慢的。
5 abaqus verify
我装的是abaqus6.7 的
执行abq671 verify -all -log提示系统要求不满足(ubuntu不包含在它的要求之内,无奈)


最后由 liucheng83 编辑于 2008-08-17 15:51,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 : 解决Can't open /usr/tmp/.flexlm/lmgrdl.5955, errno: 2的办法
帖子发表于 : 2008-05-23 9:49 

注册: 2008-04-01 14:15
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
在运行./lmgrd -c license.dat的时候,会出现Can't open /usr/tmp/.flexlm/lmgrdl.5955, errno: 2类似错误,解决办法分两步:
首先要建立一个文件夹 sudo mkdir /usr/tmp,创建这个文件夹是用来放flexm的,否则安装license server完后,./lmgrd -c license.dat会报错的
第二步,第一次运行./lmgrd -c license.dat的时候需要在前面加sudo,即运行sudo ./lmgrd -c license.dat,错误消失了

作为替代方法,更改文件夹权限,将/usr/tmp权限设为当前用户的,也应该可以解决问题。


页首
 用户资料  
 
3 楼 
 文章标题 : 对于子程序安装的办法的解决
帖子发表于 : 2008-05-23 10:00 

注册: 2008-04-01 14:15
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
需要安装Intel fortran 9.1,不是其它版本号


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Linux 下 abaqus6.7 安装成功
帖子发表于 : 2008-11-14 12:14 

注册: 2008-10-25 16:10
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
下载地址:http://packages.debian.org/sarge/ldso
http://packages.debian.org/sarge/libc5
http://packages.debian.org/oldstable/ol ... cap-compat
这三个文件已经找不到了,是不是改名了?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Linux 下 abaqus6.7 安装成功
帖子发表于 : 2008-11-18 21:29 

注册: 2008-09-30 10:35
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我的系统ubuntu7.10(64位),安装abaqus6.7
编译器:intel fortran 9.1 intel C++ 9.1
没有装document的CD2,直接装的CD1,license正常启动,在安装product到verifiction的时候出现问题如下,但能完成安装。
***********************************************************************************************************************
Traceback (most recent call last):
File "Python/driver/driverEnvERROR: No FLEXnet license servers are specified in the Abaqus environment
file. Please see the Abaqus Site Guide for more information. Exiting
verification process.
***********************************************************************************************************************
覆盖掉exec下的文件后,启动abaqus,有如下如下错误出现:
***********************************************************************************************************************
Traceback (most recent call last):
File "Python/driver/driverEnv.py", line 241, in envRunFile
File "/home/dd/6.7-1/site/abaqus_v6.env", line 153, in ?
del pci
NameError: name 'pci' is not defined
Abaqus Error: Error when reading environment file <type 'file'>
***********************************************************************************************************************

折腾了好几天也没有搞定,兄弟姐妹们该怎么解决啊?焦急中。。。。。。。。。。。。。。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Linux 下 abaqus6.7 安装成功
帖子发表于 : 2012-11-27 18:40 
头像

注册: 2012-11-27 18:24
帖子: 8
系统: Debian GNU/Linux
送出感谢: 0 次
接收感谢: 0 次
dujun6334 写道:
我的系统ubuntu7.10(64位),安装abaqus6.7
编译器:intel fortran 9.1 intel C++ 9.1
没有装document的CD2,直接装的CD1,license正常启动,在安装product到verifiction的时候出现问题如下,但能完成安装。
***********************************************************************************************************************
Traceback (most recent call last):
File "Python/driver/driverEnvERROR: No FLEXnet license servers are specified in the Abaqus environment
file. Please see the Abaqus Site Guide for more information. Exiting
verification process.
***********************************************************************************************************************
覆盖掉exec下的文件后,启动abaqus,有如下如下错误出现:
***********************************************************************************************************************
Traceback (most recent call last):
File "Python/driver/driverEnv.py", line 241, in envRunFile
File "/home/dd/6.7-1/site/abaqus_v6.env", line 153, in ?
del pci
NameError: name 'pci' is not defined
Abaqus Error: Error when reading environment file <type 'file'>
***********************************************************************************************************************

折腾了好几天也没有搞定,兄弟姐妹们该怎么解决啊?焦急中。。。。。。。。。。。。。。



不知道你现在怎么样?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译