ubuntu 8.04下安装NS2出现问题求救高手相助

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
ixuemei
帖子: 4
注册时间: 2008-05-31 22:58
送出感谢: 0
接收感谢: 0

ubuntu 8.04下安装NS2出现问题求救高手相助

#1

帖子 ixuemei » 2008-05-31 23:10

作毕业设计要用NS2模拟,现在遇到问题,请高手指点:
机子配置:AMD 64位
系统:ubuntu8.04
NS2版本:ns-allinone-2.33
软件包 已安装:build-essential,tcl8.4 tcl8.4-dev tk8.4 tk8.4-dev,libxmu-dev libxmu-headers
在./install遇到问题:
============================================================
* Testing for Darwin (OS X) environment
============================================================
============================================================
* Testing for Cygwin environment
============================================================
Cygwin not detected, proceeding with regular install.
============================================================
* Testing for FreeBSD environment
============================================================
FreeBSD not detected
============================================================
* Build XGraph-12.1
============================================================
cd: 292: can't cd to ./xgraph-12.1
./install: 293: ./configure: not found
make: *** No targets specified and no makefile found. Stop.
Can not create xgraph; But xgraph is an optional package, continuing...
============================================================
* Build CWeb
============================================================
cd: 312: can't cd to ./cweb
ns-allinone unable to install cweb for you. Please install it manually. cweb is used by sgb to create sgblibrary needed by scenario-generator. But this will not affect the use of ns as such, so continue..
============================================================
* Build Stanford GraphBase
============================================================
cd: 343: can't cd to ./sgb
Unable to create sgb library. This library is used by gt-itm and so for scenario generators. If you already have sgblib (possible if you are on solaris,sunos or freebsd platforms) you may still be able to run gt-itm. so continuing..
============================================================
* Build GT-ITM
============================================================
sgb lib not found. gt-itm & sgb2ns could not be installed. Continuing..
============================================================
* Build zlib
============================================================
cd: 402: can't cd to ./zlib-1.2.3
./install: 414: ./configure: not found
Zlib-1.2.3 configuration failed, but it's optional, so continuing ...
============================================================
* Build tcl8.4.18
============================================================
cd: 424: can't cd to ./tcl8.4.18/unix
autoconf: no input file
./install: 432: ./configure: not found
tcl8.4.18 configuration failed! Exiting ...
Tcl is not part of the ns project. Please see www.Scriptics.com
to see if they have a fix for your platform.

请问这是怎么回事,下一步该怎么处理。谢谢帮助!
ixuemei
帖子: 4
注册时间: 2008-05-31 22:58
送出感谢: 0
接收感谢: 0

#2

帖子 ixuemei » 2008-06-14 23:14

已经解决
头像
caesarhao
帖子: 14
注册时间: 2008-02-23 12:39
送出感谢: 0
接收感谢: 0
联系:

请问你是怎么解决的?

#3

帖子 caesarhao » 2008-07-10 22:33

RT,谢谢!
vim007
帖子: 23
注册时间: 2007-04-24 19:23
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 vim007 » 2008-08-05 21:35

如何解决的?
pengkuny
帖子: 231
注册时间: 2007-11-20 12:45
来自: Hefei
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 pengkuny » 2008-09-11 14:11

ixuemei 写了:已经解决
如何解决的也不说一说,真是
pengkuny
帖子: 231
注册时间: 2007-11-20 12:45
来自: Hefei
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 pengkuny » 2008-09-11 14:53

我也解决了,原来是少装了一个包:
sudo apt-get install build-essential

较低的ns版本出现上述问题,可能的解决办法:
http://ns-2.blogspot.com/2006/05/proble ... inone.html
lvziru
帖子: 1
注册时间: 2009-08-03 14:39
送出感谢: 0
接收感谢: 0

Re: ubuntu 8.04下安装NS2出现问题求救高手相助

#7

帖子 lvziru » 2009-08-03 14:43

我安装了build-essential了,可是还是出现如上问题。。。。。。
回复

回到 “办公、图像、机械电子设计等”