当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]OOo和中文环境冲突
帖子发表于 : 2008-06-01 17:56 

注册: 2007-06-08 22:43
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
我是8.04的系统,今天进系统时提示有更新,看了一下部分是gnome的包,还有一些OOo的包,没什么问题,就根据提示执行升级,升级管理器提示只能执行部分升级,OOo部分无法升级有冲突,部分升级就部分升级吧,执行升级提示有损坏的包,用apt-get check查没找到,就是不能升级;使用sudo apt-get dist-upgrade手动升级,提示需要安装OOo的升级包,同时会卸载一些包,没仔细看就执行了,执行完毕重新引导后问题来了,所有中文支持都被卸载了,执行安装系统提示以上包不会被安装,没办法,肯定是OOo搞的鬼,只能把OOo卸载了,重新安装中文支持包这次恢复原本的模样了,现在的问题是,不管是我以前的OOo(2.4.0)还是升级后的OOo(2.4.1rc1)都不能安装,安装的前提是卸载中文支持,这不是逼我嘛,想看看各位兄弟有没有碰到我这个问题,我这系统是从7.10升级的,前面一个月了都没问题,不知道安装2.3的行不行?

下面是sudo的信息:
sudo apt-get install openoffice.org
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
已经不需要下列自动安装的软件包:
classpath-gtkpeer classpath-common cacao classpath
使用 'apt-get autoremove' 来删除它们。
将会安装下列额外的软件包:
openoffice.org-base openoffice.org-calc openoffice.org-common
openoffice.org-core openoffice.org-draw openoffice.org-filter-binfilter
openoffice.org-filter-mobiledev openoffice.org-impress
openoffice.org-java-common openoffice.org-math openoffice.org-officebean
openoffice.org-style-human openoffice.org-writer openoffice.org-writer2latex
python-uno
建议安装的软件包:
graphicsmagick-imagemagick-compat imagemagick hunspell-dictionary menu
openclipart-openoffice.org openoffice.org-gnome openoffice.org-kde
openoffice.org2-thesaurus pstoedit libmyodbc odbc-postgresql libsqliteodbc
tdsodbc mdbtools libmysql-java libpg-java openoffice.org-gcj
openoffice.org-report-builder openoffice.org-style-hicontrast
openoffice.org-style-industrial
下列软件包将被【卸载】:
language-support-translations-zh language-support-zh
openoffice.org-help-zh-cn openoffice.org-help-zh-tw
openoffice.org-l10n-zh-cn openoffice.org-l10n-zh-tw

下列【新】软件包将被安装:
openoffice.org openoffice.org-base openoffice.org-calc openoffice.org-common
openoffice.org-core openoffice.org-draw openoffice.org-filter-binfilter
openoffice.org-filter-mobiledev openoffice.org-impress
openoffice.org-java-common openoffice.org-math openoffice.org-officebean
openoffice.org-style-human openoffice.org-writer openoffice.org-writer2latex
python-uno

这个是不是和中文输入法有关系?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-01 18:12 

注册: 2007-02-17 12:24
帖子: 192
送出感谢: 0 次
接收感谢: 0 次
language-support-translations-zh language-support-zh 类似于“虚拟包”,只负责处理依赖关系,方便一次性安装中文支持,在安装过中文支持后卸载这两个包不会丢失中文支持(前提是把实际的中文支持包设为“手动安装”)。
这两个包被卸载的原因是openoffice.org-help-zh-cn openoffice.org-help-zh-tw openoffice.org-l10n-zh-cn openoffice.org-l10n-zh-tw这四个包没有升级到rc1,与rc1版本的openoffice.org产生冲突。可以选择不升级openoffice.org或直接删除这四个help包,然后等有了rc1版本的再安装。


_________________
梦.:如此短暂 http://d.ream.at


页首
 用户资料  
 
3 楼 
 文章标题 : 升级了后好像没有系统栏快速启动选项。
帖子发表于 : 2008-06-01 22:15 
头像

注册: 2007-10-21 10:11
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
升级了后好像没有系统栏快速启动选项。怎么恢复到升级前啊?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-06-01 23:10 

注册: 2007-10-24 11:02
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
呵呵 今天我的也是这样 不管他


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-06-02 10:35 

注册: 2007-10-29 9:18
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
我的也一样了,看来语言包更新速度没有提上来


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-06-02 10:38 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
现在官方源已经好了.


_________________
关注我的blog: ε==3


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-06-02 13:48 
头像

注册: 2008-01-23 14:02
帖子: 884
地址: 吉林大学
送出感谢: 0 次
接收感谢: 0 次
bones7456 写道:
现在官方源已经好了.



是的,官方源是正常了,可是我的ooo现在变的很难看,界面跟98似的。


_________________
立柱博客:书写生活,记录时间-哲学|互联网|文艺|英语


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-03 9:05 

注册: 2008-05-18 17:25
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
31晚升的oo, 至今oo英文界面.

手动
sudo apt-get install language-support-zh

装了中文包 ,o了:)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译