当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Boot without X
帖子发表于 : 2005-07-17 9:25 
头像

注册: 2005-07-01 18:56
帖子: 887
地址: 广州市
送出感谢: 0 次
接收感谢: 3
用了一天的电脑,其间装过软件及删除过软件,重启后就没法由普通用户进入X!
进入gnome安全模式提示无法加载xscreensaver进程!
在切换到终端下用rm -Rdvf /tmp/.X0-lock命令后再用root登录就可以正常使用!
贴一下我的.xseesion-error文件内容:
/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "zhong"
/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: line 73: ls: command not found
/etc/gdm/Xsession: Executing default failed, will try to run x-terminal-emulator
/etc/gdm/Xsession: line 217: exec: x-terminal-emulator: not found

上次也是遇到过这个情况而搞了一天多时间了,删了gdm后重装gdm不能解决问题!!


_________________
I will be back!


最后由 yonsan 编辑于 2005-07-19 13:45,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-07-17 13:20 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
重装
xutils
xbase-clients
xlibmesa-dri
xlibmesa-gl
xlibmesa-glu
xserver-xorg
X-window-system-core
试试!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-07-17 16:40 
头像

注册: 2005-07-01 18:56
帖子: 887
地址: 广州市
送出感谢: 0 次
接收感谢: 3
唉,还是不行,现在只能以root方式进入X ,用其它用户方式不能进入X!!
firehare兄还有其它的办法吗?
我可不想重装系统了!
一个星期之内,这已经是第二次是这样的了!


附件:
文件注释: 准备以其它用户登录!
Screenshot.png [304.08 KiB]
被下载 2222 次
文件注释: 以其它用户登录10秒后出现如下图所示!
Screenshot-1.png [186.22 KiB]
被下载 173 次


_________________
I will be back!
页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-07-17 16:48 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
删除用户目录下的配置文件,试过吗??


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-07-17 16:56 
头像

注册: 2005-07-01 18:56
帖子: 887
地址: 广州市
送出感谢: 0 次
接收感谢: 3
that is ok now!!
-------------------------------------------------------------------------------------
Boot Without X method:

method one.
$ sudo update-rc.d -f gdm remove

method two:
Use the first command to disable GDM and get a console prompt instead.
$ sudo mv /etc/rc2.d/S13gdm /etc/rc2.d/s13gdm

Use the second command to enable GDM again.
$ sudo mv /etc/rc2.d/s13gdm /etc/rc2.d/S13gdm
-------------------------------------------------------------------------------------


_________________
I will be back!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-11-02 22:14 

注册: 2005-10-23 17:43
帖子: 69
地址: 地狱
送出感谢: 0 次
接收感谢: 0 次
我也试过相同的情况,按楼主的方法也不行。
最后查了资料,说是设置了/etc/environment里的JAVA_HOME/CLASS_PATH之类的路径造成的,把他们禁用了,果然能进Gnome了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-11-02 23:30 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
怎么改名字就可以了,还是个链接的名字?之前难道链接的权限被修改了?


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-11-03 18:13 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
停GDM了
但如果再想用GDM登陆呢?


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-11-03 18:35 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10110
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 127
/etc/init.d/gdm start


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-11-03 22:05 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
我说的那个,都没人去研究哦。其实这样的问题,论坛以前看到2次了,还不如也搞个“日常错误集锦及解决”出来。


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译