[问题]一个装在/usr/local/bin下的程序无法使用。(OK,已搞定)

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

[问题]一个装在/usr/local/bin下的程序无法使用。(OK,已搞定)

#1

帖子 Tenyears » 2005-07-20 15:46

一个学术研究用的软件,VMD,想来Ubuntu的源里面不可能有。直接从source make,install在/usr/local/bin,装好后能看到,但却无法使用。报错
bash: /usr/local/bin/vmd: /bin/csh: bad interpreter: 没有那个文件或目录
真是郁闷。以前在redhat、suse下装过,没有问题的。
可能是什么原因?
上次由 Tenyears 在 2005-07-20 16:15,总共编辑 1 次。
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#2

帖子 Tenyears » 2005-07-20 15:56

郁闷。
改装到home下面,仍报同样错误。怎么回事?
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 yongyi » 2005-07-20 16:00

不清楚。
我想也不会是权限的问题吧?
你是在终端运行:
/usr/local/bin/vmd
的吗?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#4

帖子 Tenyears » 2005-07-20 16:14

谢谢。
搞定了。查了点资料,
“bad interpreter”一般是指shell 解释器错误,我这里应该是指csh没有安装。
apt-get install csh
一切OK,搞定
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
回复

回到 “办公、图像、机械电子设计等”