[问题] 使用LyX+XeTeX时出现的问题

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
aldous
帖子: 16
注册时间: 2008-05-19 10:53
送出感谢: 0
接收感谢: 0
联系:

[问题] 使用LyX+XeTeX时出现的问题

#1

帖子 aldous » 2008-08-23 8:45

今天我从源里安装了LyX1.5.1,它所建议和推荐的附件我也一一装上了。至于XeTeX,由于以前安装了TeXlive,所以只是: sudo apt-get install texlive-XeTeX lmodern
然后按照网上的帖子一步步配置。最后测验时却发现不能转化为PDF。如图:
[/img]/home/aldous/桌面/Screenshot.png[/img]
上面似乎是说字体选择出了问题,但作为一个菜鸟,我检查了几遍仍不明所以。请教各位,一个怎么解决啊?

附:我的配置步骤:
1)让Lyx 支持 XeTeX 编译。在 ~/.lyx/lyxrc.defaults文件的最后添加:
\format "pdf4" "pdf" "PDF(XeTeX)" "p" "" "" "document,vector"
\converter "pdflatex" "pdf4" "xelatex $$i" "latex"
然后保存关闭。
2)打开LyX,创建一个新文件,选择文档(D)-->首选项,在语言标签表里,语言选择“简体中文”,这里选择“英语”也可以。
编码选择"utf8-plain"。然后选择LaTeX序标签,增加
\usepackage{fontspec}
\usepackage{xunicode}
\usepackage{xltxtra}
\setmainfont{WenQuanYi Zen Hei}
然后选择保存为文档缺省设置。

请教各位,到底是哪里有问题呢?
bian222
帖子: 78
注册时间: 2006-05-18 21:13
送出感谢: 0
接收感谢: 0

#2

帖子 bian222 » 2008-08-23 11:21

\format "pdf4" "pdf" "PDF(XeTeX)" "p" "" "" "document,vector"
\converter "pdflatex" "pdf4" "xelatex $$i" "latex"

是加在.lyx/preference文件里的吧。

看不到你出错的图,呵呵。
aldous
帖子: 16
注册时间: 2008-05-19 10:53
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 aldous » 2008-08-23 13:28

对,网上帖子里也说是写进~/.lyx/preferences文件里。但我在~/.lyx文件夹里找不到preference这么个文件,看了下,文件lyxrc.defaults似乎也相仿佛,就加进去了。后来一试,点击“视图”,里面也多了“PDF(XeTeX)”的条目,就以为是了。那正确的一个怎么做呢?
我不会发图,补在这里。
附件
Screenshot.png
出现错误的截图
bian222
帖子: 78
注册时间: 2006-05-18 21:13
送出感谢: 0
接收感谢: 0

#4

帖子 bian222 » 2008-08-23 17:30

在工具-->选项里面随便改个参数(比如字体),就会在.lyx目录里生成preference文件了,然后再把
\format "pdf4" "pdf" "PDF(XeTeX)" "p" "" "" "document,vector"
\converter "pdflatex" "pdf4" "xelatex $$i" "latex"
添加进去。


还有你是怎么编绎的?直接点的工具栏上的图标?正确的应该是点视图选项,再点PDF(XeTeX)。
aldous
帖子: 16
注册时间: 2008-05-19 10:53
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 aldous » 2008-08-24 8:26

谢谢ls,按照你的方法在.lyx目录里生成preference文件了。但最后编译时还是出现同样的问题。连说明都一模一样,就不附图了。实在摸不着头脑:(。我编译时也是先点视图选项,再点PDF(XeTeX)的啊!
bian222
帖子: 78
注册时间: 2006-05-18 21:13
送出感谢: 0
接收感谢: 0

#6

帖子 bian222 » 2008-08-24 9:27

写一个新文档,简单输入几个字就行,编译下看看能否成功。
如果不行,仔细检查下设置里的导言区,是不是书写有错误。

把导言区截图出来看一下,呵呵。
aldous
帖子: 16
注册时间: 2008-05-19 10:53
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 aldous » 2008-08-24 9:48

重新编译了一次,还是不行。导言区贴图如下:
附件
LyX导言区.png
bian222
帖子: 78
注册时间: 2006-05-18 21:13
送出感谢: 0
接收感谢: 0

#8

帖子 bian222 » 2008-08-24 9:56

晕,开头少了个反斜杠呀,呵呵。
应该写成

\usepackage{fontspec}
\setmainfont
\XeTeXlinebreaklocale "zh"
\XeTeXlinebreakskip = 0pt plus 1pt
上次由 bian222 在 2008-08-24 10:04,总共编辑 1 次。
aldous
帖子: 16
注册时间: 2008-05-19 10:53
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 aldous » 2008-08-24 10:03

…………抱头泣去
谢谢大大!
aldous
帖子: 16
注册时间: 2008-05-19 10:53
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 aldous » 2008-08-24 12:08

谢谢ls能忍受我这么白的问题:)。经过修改,现在能够编译了。但中文显示却是乱码。我用Evince和KPDF都不行。为什么呢?是LyX的问题还是PDF显示器的原因呢?这次我把可能相关的配置都截了图,希望大家能够帮忙看看。谢谢!
附件
.png
这是出错时的情况
.png
这是修改后的导言区
.png
.png
.png
.png
Class.png
.png
LaTeX.png
LaTeX.png
bian222
帖子: 78
注册时间: 2006-05-18 21:13
送出感谢: 0
接收感谢: 0

#11

帖子 bian222 » 2008-08-26 9:58

出现这个问题,最好是你自己编一个tex文件,用 xelatex编译一下看看,看中文是不是还是乱码。
aldous
帖子: 16
注册时间: 2008-05-19 10:53
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 aldous » 2008-08-26 13:53

我用XeLaTeX编译了,中文仍然是乱码。
aldous@aldous-laptop:~/桌面$ xelatex test.tex
This is XeTeXk, Version 3.141592-2.2-0.996-patch1 (Web2C 7.5.6)
%&-line parsing enabled.
entering extended mode
(./test.tex
LaTeX2e <2005/12/01>
Babel <v3.8h> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, pinyin, loaded.
(/usr/share/texmf-texlive/tex/latex/base/article.cls
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
(/usr/share/texmf-texlive/tex/latex/base/size12.clo))
(/usr/share/texmf-texlive/tex/xelatex/fontspec/fontspec.sty
(/usr/share/texmf-texlive/tex/generic/ifxetex/ifxetex.sty)
(/usr/share/texmf-texlive/tex/latex/tools/calc.sty)
(/usr/share/texmf-texlive/tex/latex/xkeyval/xkeyval.sty
(/usr/share/texmf-texlive/tex/latex/xkeyval/xkeyval.tex
(/usr/share/texmf-texlive/tex/latex/xkeyval/keyval.tex)))
(/usr/share/texmf/tex/latex/lm/lmodern.sty)
(/usr/share/texmf-texlive/tex/latex/base/fontenc.sty
(/usr/share/texmf-texlive/tex/xelatex/euenc/eu1enc.def)
(/usr/share/texmf-texlive/tex/xelatex/euenc/lm/eu1lmr.fd))
fontspec.cfg loaded.
(/usr/share/texmf-texlive/tex/xelatex/fontspec/fontspec.cfg))
(/usr/share/texmf-texlive/tex/xelatex/xunicode/xunicode.sty)
(/usr/share/texmf-texlive/tex/xelatex/xltxtra/xltxtra.sty
(/usr/share/texmf-texlive/tex/latex/graphics/graphicx.sty
(/usr/share/texmf-texlive/tex/latex/graphics/graphics.sty
(/usr/share/texmf-texlive/tex/latex/graphics/trig.sty)
(/etc/texmf/tex/latex/config/graphics.cfg)
(/usr/share/texmf-texlive/tex/xelatex/graphics/xetex.def)))
(/usr/share/texmf-texlive/tex/latex/etex/etex.sty)
(/usr/share/texmf-texlive/tex/latex/base/fixltx2e.sty))
No file test.aux.
[1] (./test.aux) )
(see the transcript file for additional information)
Output written on test.pdf (1 page).
Transcript written on test.log.


请问能帮忙看看是什么问题吗?谢谢了!
附件
tex文件内容.png
tex文件内容
pdf显示中文乱码.png
PDF显示中文乱码
bian222
帖子: 78
注册时间: 2006-05-18 21:13
送出感谢: 0
接收感谢: 0

#13

帖子 bian222 » 2008-08-26 14:28

看你截的图没看出有什么问题呀。
在终端打locale命令看是什么输出,以及看一下/usr/share/fonts/下面的字体文件夹里面字体属性是不是644。
aldous
帖子: 16
注册时间: 2008-05-19 10:53
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 aldous » 2008-08-26 22:16

请问字体属性怎么看啊?644是什么意思?
bian222
帖子: 78
注册时间: 2006-05-18 21:13
送出感谢: 0
接收感谢: 0

#15

帖子 bian222 » 2008-08-26 22:46

ls -l
字体属性应该是rw-r--r--这样的。
回复

回到 “办公、图像、机械电子设计等”