当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教vim+latex-suite+xdvi的若干问题
帖子发表于 : 2008-09-01 14:48 

注册: 2008-08-30 23:24
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
大家好,我正在使用vim + latex-suite +xdvi,有三个问题请教大家,多谢了。
第一个是关于字体的
我在我的机器上装了一个叫Lucida的字体,但是当我对某个tex文件进行编译产生dvi的时候,受到如下警告
[QUOTE]/usr/local/texlive/2007/texmf-dist/tex/latex/psnfssx/lucidabr.sty [RO] 1,1 Top
2 /usr/local/texlive/2007/texmf-dist/tex/latex/psnfssx/lucidabr.sty|| LaTeX Font Warning: Encoding `OT1' has changed 'T1' for symbol font
3 /usr/local/texlive/2007/texmf-dist/tex/latex/psnfssx/lucidabr.sty|| LaTeX Font Warning: Encoding `OT1' has changed 'T1' for symbol font
4 || [\QUOTE]
按了q之后就退出了,能够产生dvi文件正常浏览。只是我比较讨厌这个warning,不希望看到它。请问有人知道如何
对付它么?多谢

第二个问题是关于xdvi反向搜索的。网上只有个KDE环境下的文章,请问谁知道在gnome,比如ubuntu下如何设置么?
正向搜索倒是好办

第三个问题是每次我xdvi某文件时,弹出的窗口都比较小,能不能使得打开的页面默认是全屏的,
并且宽度而不是高度自动fit到window.这样看起来方便一些。如果有手型工具可以拖动页面就最好了^_^

多谢多谢


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-09-01 17:50 

注册: 2008-08-30 23:24
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
第二个和第三个问题找了俩无奈的解决方案。

第三个看起来只能放弃反向搜索了,反正vim搜索很方便。。。大不了一边写一边检查好了T_T

第二个问题:

在/.vim/ftplugin/latex-suite/texrc里面,找到这么句话:
TexLet g:Tex_ViewRule_dvi = 'xdvi'
把它改成
TexLet g:Tex_ViewRule_dvi = 'xdvi -s 4'
对于我的屏幕来说,4就非常好了,如果不喜欢可以试着改成别的。
这个只能使得在vim下使用\ls浏览自己的文件时起作用,平时如果运行xdvi是不可以的。
不过考虑到实际需要,我一般也只会在写文章时一边写一边检查错误的情况下才会频繁
调用xdvi,所以也比较实用了。。。。

根据网上一些说法,说更改~/.xdvirc或者~/.Xdefaults也可以实现改变xdvi启动时
default参数的功能。但是我试了好多次都没有成功,有谁试成功了请告诉我,多谢。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-09-10 18:27 
头像

注册: 2008-08-15 14:38
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
反向搜索设置:

在$VIMFILES/ftplugin/tex/texrc 中找到如下代码:(如果没有这个文件,把$VIMFILES/ftplugin/latex-suite/texrc copy 过来)

" the option below specifies an editor for the dvi viewer while starting
" up the dvi viewer according to Dimitri Antoniou's tip on vim.sf.net (tip
" #225)
TexLet g:Tex_UseEditorSettingInDVIViewer = 0

把值设为1。如下:
TexLet g:Tex_UseEditorSettingInDVIViewer = 1

同时把dvi 编译选项设为

TexLet g:Tex_CompileRule_dvi = 'latex -src-specials -interaction=nonstopmode $*'

也可以在.vimrc 里修改,但是相应的TexLet 就要写为 let了。

我用的是 Ubuntu8.04+gvim 7.1.138+xdvi。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-09-11 22:20 
头像

注册: 2008-08-15 14:38
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
shallpion 写道:
在/.vim/ftplugin/latex-suite/texrc里面,找到这么句话:
TexLet g:Tex_ViewRule_dvi = 'xdvi'
把它改成
TexLet g:Tex_ViewRule_dvi = 'xdvi -s 4'
对于我的屏幕来说,4就非常好了,如果不喜欢可以试着改成别的。
这个只能使得在vim下使用\ls浏览自己的文件时起作用,平时如果运行xdvi是不可以的。
不过考虑到实际需要,我一般也只会在写文章时一边写一边检查错误的情况下才会频繁
调用xdvi,所以也比较实用了。。。。


貌似.xdvirc是不能随便改的,会随着运行被自动覆盖。
如果要平时运行也起作用可以考虑修改.bashrc, 添加一个alias 把'xdvi -s 4 -fullscreen' 绑定成喜欢的命令。
另外,前面提到的正向反向配置会和楼主的设置冲突,所以建议保持viewrule_dvi 不变,然后修改$VIMFILES/ftplugin/latex-suite/complier.vim (这个有点风险,最好先备份)。 找到Tex_ViewLaTeX() 和 Tex_ForwardSearchLaTeX()这两个函数, 把 ' -s 4 ' 这个参数加到对应的位置就行了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译