egroupware+ubuntu8.04.2+成功

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
长河落日
帖子: 8
注册时间: 2008-04-13 9:38
来自: 兰州
送出感谢: 0
接收感谢: 0
联系:

egroupware+ubuntu8.04.2+成功

#1

帖子 长河落日 » 2008-10-18 11:30

egroupware 本论坛上有相关的介绍 自己找一下 相关的图文安装wiki中也有 不过有些bug

下面是我成功安装的过程
sudo apt-get install mysql-server
sudo apt-get install apache2
sudo apt-get install php5
sudo apt-get install php5-mysql
(用mysql库)
sudo apt-get install php5-pgsql(用postgresql库)
(要是用其他的ORACLE Ms-SQL的话自己把插件找到就行了如果这些扩展也安装的话将都是绿色对勾)
sudo apt-get install libapache2-mod-php5
sudo apt-get install php5-imap
(邮件服务)
(有些扩展应该是在安装egroupware时候安装了但是为了清晰一点还是在这儿安装吧)

mysql -u root -p
密码
grant all on *.* to root@localhost identified by '密码';
create database egroupware
grant all on egroupware.* to egroupware@localhost identified by 'egroupware'


sudo apt-get install egroupware

切记!!
切记!!在进入网页配置前要执行

sudo /etc/init.d/apache2 force-reload

如果在检验安装时候提示有某库没有被支持 往往是上面的库没有安装或者没有执行上面这条命令
原因是安装顺序不同时候有些动态库是在apache设置后才安装的,一些后来安装的库不会被reload具体原因见下面

If you install egroupware on a server with the following command:
apt-get install egroupware
Make sure to also do a:
/etc/init.d/apache2 force-reload
as the php5-imap is installed after the apache2 server is restarted and will not be loaded. The installation should be change so that the server is reloaded at the end of install.
This corrects the problem:
"Warning Checking extension imap is loaded or loadable: False
The imap extension is needed by the two email apps (even if you use email with pop3 as protocoll)."

(来自http://ph.ubuntuforums.com/showthread.p ... 0&t=807270


其他按照WIKI安装


END


如果想具体配置相关的文件位置见下面
sudo /etc/init.d/apache2 restart (重启 apache)

sudo gedit /etc/php5/apache2/php.ini (配置 php)

sudo gedit /etc/apache2/apache2.conf (配置 apache2)

/var/www/(主目录位置)
回复

回到 “办公、图像、机械电子设计等”