cheese无法使用摄像头webcam

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
头像
pllion
帖子: 216
注册时间: 2008-11-09 9:06
送出感谢: 0
接收感谢: 0

cheese无法使用摄像头webcam

#1

帖子 pllion » 2008-12-02 22:13

刚装上开启发现摄像头指示灯不亮,紧接着茄子就弹出screens_1.png,怀疑是权限问题,编辑/etc/fstab,在最后面加上了none /proc/bus/usb usbfs devgid=1000,devmode=664 0 0还是不行。不过此时再启动茄子摄像头灯亮了,仍然弹出screens_1.png.
在终端运行cheese,报错如screesns.png. 请高手解决下!谢谢了!本人机器是dell xps1530, 本子自带摄像头!

刚刚打开cheese时就是screenshot-茄子.png,正常情况下应该是摄像头捕捉到的画面呀!

我一直在尝试解决,但是徒劳,补充些信息,还请高手搭救!dmesg信息如下:
[ 10.521873] Linux video capture interface: v2.00
[ 10.629846] uvcvideo: Found UVC 1.00 device Laptop Integrated Webcam (05a9:2640)
[ 10.630230] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
[ 10.677640] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 10.677663] HDA Intel 0000:00:1b.0: setting latency timer to 64
[ 10.688172] input: Laptop Integrated Webcam as /devices/pci0000:00/0000:00:1a.7/usb3/3-1/3-1:1.0/input/input9
[ 10.708516] usbcore: registered new interface driver uvcvideo
[ 10.708520] USB Video Class driver (v0.1.0)


另外图1.png
Bus 003 Device 002: ID 05a9:2640 OmniVision Technologies, Inc. 是我的webcam,这算没有识别出来还是识别出来了?

内核加载模块
v4l1_compat 22404 2 uvcvideo,videodev 为什么不是v4l2_compat??
附件
1.png
Screenshot-茄子.png
Screens.png
Screens_1.png
Screens_1.png (15.49 KiB) 查看 3327 次
上次由 pllion 在 2008-12-04 0:57,总共编辑 5 次。
viewtopic.php?f=33&t=172235
Sometimes I wonder will God ever forgive us for what we've done to each other? Then I look around and I realize,God left this place a long time ago.
头像
xiooli
帖子: 6956
注册时间: 2007-11-19 21:51
来自: 成都
送出感谢: 0
接收感谢: 3 次
联系:

Re: cheese无法使用

#2

帖子 xiooli » 2008-12-02 22:16

没用过,我中过一个山寨摄像头,不能驱动,扔了。。
头像
百草谷居士
帖子: 3034
注册时间: 2006-02-10 16:36
系统: ubuntu18.04/Win10
送出感谢: 20 次
接收感谢: 33 次
联系:

Re: cheese无法使用摄像头webcam

#3

帖子 百草谷居士 » 2008-12-06 8:43

我的两个摄像头都可以使用,没有发现什么不对劲的地方。
是8.10
友帮拓,真难听。有没有接触官方的老大?给改了吧!
一直想找一个在linux下的Visual FoxPro/access桌面数据库。MUIBase还算是最相近的。
头像
pllion
帖子: 216
注册时间: 2008-11-09 9:06
送出感谢: 0
接收感谢: 0

Re: cheese无法使用摄像头webcam

#4

帖子 pllion » 2008-12-06 9:21

楼上版本多少?什么机器?内核版本多少?
viewtopic.php?f=33&t=172235
Sometimes I wonder will God ever forgive us for what we've done to each other? Then I look around and I realize,God left this place a long time ago.
wholelife
帖子: 7
注册时间: 2008-04-01 18:13
送出感谢: 0
接收感谢: 0

Re: cheese无法使用摄像头webcam

#5

帖子 wholelife » 2008-12-09 18:58

和楼主一样的问题,没人解答么
wholelife
帖子: 7
注册时间: 2008-04-01 18:13
送出感谢: 0
接收感谢: 0

Re: cheese无法使用摄像头webcam

#6

帖子 wholelife » 2008-12-09 19:02

附说明:以前用8.04的时候是可以用的,后来一直将摄像头给别人在用,昨天拿回来发现打开cheese是全白的,看不到图像,也不能截图,但是cheese的首选项里面已经识别了摄像头
使用Ekiga可以使用摄像头
头像
pllion
帖子: 216
注册时间: 2008-11-09 9:06
送出感谢: 0
接收感谢: 0

Re: cheese无法使用摄像头webcam

#7

帖子 pllion » 2008-12-14 16:39

这个是个bug,大概一周前在linux.com看到了,不要再查了。
viewtopic.php?f=33&t=172235
Sometimes I wonder will God ever forgive us for what we've done to each other? Then I look around and I realize,God left this place a long time ago.
myubunt_720
帖子: 232
注册时间: 2008-06-04 11:24
送出感谢: 0
接收感谢: 0

Re: cheese无法使用摄像头webcam

#8

帖子 myubunt_720 » 2009-01-27 14:12

耐心点,我的一个山寨摄像头,装上后大约要等待50秒才能出现画面……
而且要在插摄像头之后再开cheeze才能认出来。而且图像和3D桌面效果冲突……闪啊,闪啊……
回复

回到 “办公、图像、机械电子设计等”