当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 新手菜鸟关于g++配置的问题
帖子发表于 : 2005-08-03 3:30 

注册: 2005-08-01 0:20
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
为了安装我的猫的驱动,我必须安装下列的包
build-essential
linux-headers-2.6-ARCH
fakeroot
我在http://packages.ubuntu.com/处按照倚赖关系下了所有的包(我的Ubuntu是别人给我安装的,我也不懂...但是现在我只能用猫上网,所以这些东西都是在windows下下来的)
在安装时出现了如下问题



hash@ubuntu:~/Desktop/step by step$ sudo dpkg -i build-essential_10.1ubuntu1_i386.deb
选中了曾被取消选择的软件包 build-essential。
(正在读取数据库 ... 系统当前总共安装有 80203 个文件和目录。)
正在解压缩 build-essential (从 build-essential_10.1ubuntu1_i386.deb) ...
dpkg:依赖关系问题使得 build-essential 的配置工作不能继续:
build-essential 依赖于 g++ (>= 3:3.3);然而:
软件包 g++还没有被配置。
dpkg:处理 build-essential (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
build-essential


可是我用dpkg -s g++ 得到的status是install or unpacked,Version: 4:3.3.5-1
请问各位大侠,该怎么配置才能解决这个问题阿?
求您了...


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-08-03 15:35 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
sudo dpkg-reconfigure g++
sudo dpkg -i build-essential_10.1ubuntu1_i386.deb


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译