matlab使用时的一个问题

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
prince_9036
帖子: 7
注册时间: 2008-09-26 16:20
送出感谢: 0
接收感谢: 0

matlab使用时的一个问题

#1

帖子 prince_9036 » 2009-01-08 22:46

为什么我每次运行matlab 2008b时,命令框里都要显示下面的文字,是什么原因造成的?怎么解决啊
Cannot write to preference file "matlab.prf" in "/home/light/.matlab/R2008b".
Check file permissions.
The desktop configuration was not saved successfully
头像
xc1427
帖子: 276
注册时间: 2008-10-11 4:11
来自: 瑞金无线电学校
送出感谢: 0
接收感谢: 0
联系:

Re: matlab使用时的一个问题

#2

帖子 xc1427 » 2009-01-09 15:58

代码: 全选

$ sudo chomd 666 /home/light/.matlab/R2008b
You never know if you don't try
prince_9036
帖子: 7
注册时间: 2008-09-26 16:20
送出感谢: 0
接收感谢: 0

Re: matlab使用时的一个问题

#3

帖子 prince_9036 » 2009-01-10 10:46

好像不行,依然有问题,好像是权限修改之后,Matlab2008b无法识别那些文件夹了
头像
xc1427
帖子: 276
注册时间: 2008-10-11 4:11
来自: 瑞金无线电学校
送出感谢: 0
接收感谢: 0
联系:

Re: matlab使用时的一个问题

#4

帖子 xc1427 » 2009-01-10 13:17

那文件夹权限改回来,只改动文件权限。

代码: 全选

$ sudo chomd 666 /home/light/.matlab/R2008b/matlab.prf
You never know if you don't try
hsh2003hu
帖子: 27
注册时间: 2009-02-06 15:51
来自: Harbin
送出感谢: 0
接收感谢: 0

Re: matlab使用时的一个问题

#5

帖子 hsh2003hu » 2009-02-08 9:41

我也遇到这个问题,运行上面的命令之后,没有chomd这个命令
“sudo: chomd: command not found”
hsh2003hu
帖子: 27
注册时间: 2009-02-06 15:51
来自: Harbin
送出感谢: 0
接收感谢: 0

Re: matlab使用时的一个问题

#6

帖子 hsh2003hu » 2009-02-08 10:12

呵呵,应该是chmod
xuqiang_sdu
帖子: 1
注册时间: 2008-09-06 16:16
送出感谢: 0
接收感谢: 0

Re: matlab使用时的一个问题

#7

帖子 xuqiang_sdu » 2009-02-08 11:10

我也遇到了这样的情况,用下面的命令可以解决这个问题
$ sudo chmod 777 /home/username/.matlab
peacekeep
帖子: 46
注册时间: 2008-01-13 12:23
送出感谢: 0
接收感谢: 0

Re: matlab使用时的一个问题

#8

帖子 peacekeep » 2009-04-17 15:42

将./matalb及该文件夹下的文件夹、文件所属用户修改为你自己的用户。
用chown命令。
wktian
帖子: 34
注册时间: 2010-04-28 13:44
送出感谢: 0
接收感谢: 0

Re: matlab使用时的一个问题

#9

帖子 wktian » 2010-05-21 23:12

我也是这个问题,揪心阿
wklxd
帖子: 38
注册时间: 2010-05-16 13:36
送出感谢: 0
接收感谢: 0

Re: matlab使用时的一个问题

#10

帖子 wklxd » 2010-05-24 23:21

DO NOT START MATLAB AT THE END OF THE INSTALLATION

Starting MATLAB at the end of Product Activation creates a permissions problem for storing MATLAB preferences, since the directory and files inside of ~/.matlab will be created for the root user. However this inconvenience can be easily fixed running the following command:

sudo chown -R ${USER}:${USER} ~/.matlab


试一下吧 ,呵呵呵
waymsy
帖子: 1
注册时间: 2010-12-23 18:52
送出感谢: 0
接收感谢: 0

Re: matlab使用时的一个问题

#11

帖子 waymsy » 2011-03-16 19:45

我的用户名为li, sudo chown -hR li /home/li/.matlab/解决了这个问题
blues_cc
帖子: 1
注册时间: 2011-04-26 11:38
送出感谢: 0
接收感谢: 0

Re: matlab使用时的一个问题

#12

帖子 blues_cc » 2011-04-26 11:42

ls这个代码可以解决问题
头像
nmsfan
帖子: 18958
注册时间: 2009-10-16 22:46
来自: finland
送出感谢: 16 次
接收感谢: 36 次

Re: matlab使用时的一个问题

#13

帖子 nmsfan » 2011-04-26 12:28

不是chmod,是chown :em11 :em11
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum
回复

回到 “办公、图像、机械电子设计等”