解决安装 kile 的依赖关系的 dummy 包 (可以直接用 Texlive 2008 了)

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
头像
runpin
帖子: 647
注册时间: 2005-09-29 11:13
来自: Boston, MA
送出感谢: 0
接收感谢: 0

解决安装 kile 的依赖关系的 dummy 包 (可以直接用 Texlive 2008 了)

#1

帖子 runpin » 2009-01-19 8:21

本来想追加到置顶的帖子后面,不过好些人似乎不看置顶,所以干脆开个新帖。

LaTeX 的最好、最强大的 IDE 无可辩驳的是 kile,所以废话不多说。唯一有点儿那什么的是:它是 KDE 家族的。Ubuntu 上安装 kile 有两个办法,要么编译、要么用源里现成的(废话)。不过后者因为依赖关系,一定要安装它自带的 Texlive 2007,问题是很多人要使用 XeTeX,而且只有 0.997 以上版本才支持 zhspacing 和 xeCJK 这两个宏包。当然可以编译最新版的 XeTeX,不过那又是另一场噩梦的开始,我从没搞定过,即使看着教程来。

装 dummy 包的办法很简单了,过程如下:

代码: 全选

sudo apt-get install equivs
它要装不少东西,好在不是很大,另外有我本来就需要的 MySQL。

在桌面上新建一 .ctl 个文件,比如:texlive-dummy.ctl 。

然后添加如下内容:

代码: 全选

Section: tex
Package: texlive-dummy
Provides: texlive, texlive-base-bin, texlive-base-bin-doc,texlive-bibtex-extra, texlive-common, texlive-doc-base, texlive-doc-bg,texlive-doc-cs+sk, texlive-doc-de, texlive-doc-el, texlive-doc-en,texlive-doc-es, texlive-doc-fi, texlive-doc-fr, texlive-doc-it,texlive-doc-ko, texlive-doc-mn, texlive-doc-nl, texlive-doc-pl,texlive-doc-pt, texlive-doc-ru, texlive-doc-th, texlive-doc-tr,texlive-doc-uk, texlive-doc-vi, texlive-doc-zh, texlive-extra-utils,texlive-font-utils, texlive-fonts-extra, texlive-fonts-extra-doc,texlive-fonts-recommended, texlive-fonts-recommended-doc,texlive-formats-extra, texlive-full, texlive-games,texlive-generic-extra, texlive-generic-recommended, texlive-humanities,texlive-humanities-doc, texlive-lang-african, texlive-lang-all,texlive-lang-arab, texlive-lang-armenian, texlive-lang-cyrillic,texlive-lang-czechslovak, texlive-lang-danish, texlive-lang-dutch,texlive-lang-finnish, texlive-lang-french, texlive-lang-german,texlive-lang-greek, texlive-lang-hebrew, texlive-lang-hungarian,texlive-lang-indic, texlive-lang-italian, texlive-lang-latin,texlive-lang-manju, texlive-lang-mongolian, texlive-lang-norwegian,texlive-lang-polish, texlive-lang-portuguese, texlive-lang-spanish,texlive-lang-swedish, texlive-lang-tibetan, texlive-lang-ukenglish,texlive-lang-vietnamese, texlive-latex-base, texlive-latex-base-doc,texlive-latex-extra, texlive-latex-extra-doc, texlive-latex-recommended,texlive-latex-recommended-doc, texlive-latex3, texlive-math-extra,texlive-metapost, texlive-metapost-doc, texlive-music, texlive-omega,texlive-pictures, texlive-pictures-doc, texlive-plain-extra,texlive-pstricks, texlive-pstricks-doc, texlive-publishers,texlive-publishers-doc, texlive-science, texlive-science-doc,texlive-xetex, texlive-lang-other, texlive-lang-croatian, texlive-base,texlive-doc-ja, cm-super, lmodern, latex-xcolor, latex-beamer, pgf,preview-latex-style
Description: TeXlive dummy package
 This package provides dpkg with the information that
 there is a local TeXlive version installed. 
保存后开始打包:

代码: 全选

sudo equivs-build texlive-dummy.ctl
然后可以看见一个 deb 文件,名为:texlive-dummy_1.0_all.deb

现在就可以安装它了:

代码: 全选

sudo dpkg -i texlive-dummy_1.0_all.deb
行了,下面就不用多说了,打开新立德,找到 kile 安装就是了,效果如下:
Screenshot.png
顺便把这两个文件也一并打包附上:
texlive-dummy.tar.bz2
(4.25 KiB) 下载 65 次
上次由 runpin 在 2009-01-19 23:29,总共编辑 3 次。
头像
runpin
帖子: 647
注册时间: 2005-09-29 11:13
来自: Boston, MA
送出感谢: 0
接收感谢: 0

Re: 解决安装 kile 的依赖关系的 dummy 包 (可以直接用 Texlive 2008 了)

#2

帖子 runpin » 2009-01-19 8:30

我已经追加到置顶帖子里了,如果版主觉着重复,删了就是了 :em02
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

Re: 解决安装 kile 的依赖关系的 dummy 包 (可以直接用 Texlive 2008 了)

#3

帖子 sunzhaoyu2000 » 2009-01-20 10:05

kile比起lyx来。。。

我以前写第一个论文使用kile的
现在写第二个用的是lyx,并且再不用kile了
头像
runpin
帖子: 647
注册时间: 2005-09-29 11:13
来自: Boston, MA
送出感谢: 0
接收感谢: 0

Re: 解决安装 kile 的依赖关系的 dummy 包 (可以直接用 Texlive 2008 了)

#4

帖子 runpin » 2009-01-21 0:04

这个没有 pk 的意义吧,两个 IDE 面向的用户不同。
头像
eagle5678
帖子: 1820
注册时间: 2006-07-08 14:07
送出感谢: 14 次
接收感谢: 1 次

Re: 解决安装 kile 的依赖关系的 dummy 包 (可以直接用 Texlive 2008 了)

#5

帖子 eagle5678 » 2009-01-30 20:39

这个家伙是KDE3的吧
shaokn
帖子: 14
注册时间: 2007-01-11 9:35
送出感谢: 0
接收感谢: 0

Re: 解决安装 kile 的依赖关系的 dummy 包 (可以直接用 Texlive 2008 了)

#6

帖子 shaokn » 2009-11-01 16:05

没有用阿, (Kubuntu 9.10)

代码: 全选

lazybird@lazybird-laptop:~$ sudo dpkg -i texlive-dummy_1.0_all.deb 
选中了曾被取消选择的软件包 texlive-dummy。                         
(正在读取数据库 ... 系统当前总共安装有 153328 个文件和目录。)      
正在解压缩 texlive-dummy (从 texlive-dummy_1.0_all.deb) ...        
正在设置 texlive-dummy (1.0) ...                                   
lazybird@lazybird-laptop:~$ sudo apt-get install kile
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
  asymptote asymptote-doc blt context dblatex dvipdfmx dvipng feynmf freeglut3
  guile-1.8 kbibtex konqueror konqueror-nsplugins lacheck latex-beamer
  latex-xcolor latex2html libkonqsidebarplugin4 libnetpbm10 libsigsegv0
  libt1-5 lilypond lilypond-data lilypond-doc lmodern luatex netpbm perl-doc
  pgf prosper psutils python-imaging-tk python-tk tcl8.5 tex-common tex4ht
  tex4ht-common texinfo texlive texlive-base texlive-base-bin texlive-common
  texlive-doc-base texlive-extra-utils texlive-fonts-recommended
  texlive-latex-base texlive-latex-extra texlive-latex-recommended
  texlive-math-extra texlive-metapost texlive-pictures tipa tk8.5
建议安装的软件包:
  gv xpdf blt-demo context-doc-nonfree context-nonfree fontforge docbook
  latex-cjk-all opensp transfig guile-1.8-doc bibtex2html latex2rtf kile-doc
  konq-plugins auctex groff python-imaging-doc python-imaging-tk-dbg tix
  python-tk-dbg tclreadline texinfo-doc-nonfree dvi2tty dvidvi texpower
下列【新】软件包将被安装:
  asymptote asymptote-doc blt context dblatex dvipdfmx dvipng feynmf freeglut3
  guile-1.8 kbibtex kile konqueror konqueror-nsplugins lacheck latex-beamer
  latex-xcolor latex2html libkonqsidebarplugin4 libnetpbm10 libsigsegv0
  libt1-5 lilypond lilypond-data lilypond-doc lmodern luatex netpbm perl-doc
  pgf prosper psutils python-imaging-tk python-tk tcl8.5 tex-common tex4ht
  tex4ht-common texinfo texlive texlive-base texlive-base-bin texlive-common
  texlive-doc-base texlive-extra-utils texlive-fonts-recommended
  texlive-latex-base texlive-latex-extra texlive-latex-recommended
  texlive-math-extra texlive-metapost texlive-pictures tipa tk8.5
共升级了 0 个软件包,新安装了 54 个软件包,要卸载 0 个软件包,有 4 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 203MB/204MB 的软件包。
解压缩后会消耗掉 584MB 的额外空间。
您希望继续执行吗?[Y/n]n
中止执行。
lazybird@lazybird-laptop:~$
google了以下,换成以下这个就可以了

代码: 全选

Section: tex
Package: texlive-dummy
Provides: texlive-latex-base, asymptote, asymptote-doc, context, dblatex, dvipdfmx, dvipng, feynmf, guile-1.8, lacheck, latex-beamer, latex-xcolor, latex2html, libsigsegv0, lilypond, lilypond-data, lilypond-doc, lmodern, luatex, pgf, preview-latex-style, prosper, ps2eps,tex4ht, tex4ht-common, texlive, texlive-base, texlive-base-bin, texlive-base-bin-doc, texlive-common, texlive-doc-base, texlive-extra-utils, texlive-font-utils, texlive-fonts-recommended, texlive-fonts-recommended-doc, texlive-generic-extra, texlive-generic-recommended, texlive-humanities, texlive-humanities-doc, texlive-lang-cyrillic, texlive-latex-base, texlive-latex-base-doc, texlive-latex-extra, texlive-latex-extra-doc, texlive-latex-recommended, texlive-latex-recommended-doc, texlive-math-extra, texlive-metapost, texlive-metapost-doc, texlive-pictures, texlive-pictures-doc, texlive-pstricks, texlive-pstricks-doc, texlive-xetex, tipa
Description: texlive dummy package This package provides dpkg with the information that there is the package texlive-latex-base installed.
回复

回到 “办公、图像、机械电子设计等”