当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : l求助:lyx中文输出出错
帖子发表于 : 2009-05-16 13:43 
头像

注册: 2007-10-29 13:29
帖子: 98
送出感谢: 0 次
接收感谢: 0 次
按这篇文章http://forum.ubuntu.org.cn/viewtopic.php?f=35&t=185264&start=0
[Document] => [Settings]->LaTeX Preamble 中添加的代码如下:
\usepackage[cm-default]{fontspec}
\usepackage{xunicode}
\usepackage{xltxtra}
\XeTeXlinebreaklocale "zh"
\XeTeXlinebreakskip = 0pt plus 1pt
出错信息如附件

请问是什么问题?


附件:
Screenshot-latex Errors (-home-roach-newfile1.lyx).png
Screenshot-latex Errors (-home-roach-newfile1.lyx).png [ 46.32 KiB | 被浏览 1275 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2009-05-16 15:30 

注册: 2006-11-08 6:16
帖子: 417
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
错误提示里不是说了吗,缺少\begin {document}


页首
 用户资料  
 
3 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2009-05-16 16:08 
头像

注册: 2007-10-29 13:29
帖子: 98
送出感谢: 0 次
接收感谢: 0 次
在哪里添加,不是设置好就能直接输入了吗


页首
 用户资料  
 
4 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2009-05-21 13:20 

注册: 2008-09-20 14:25
帖子: 5
送出感谢: 0 次
接收感谢: 1
我也遇到这个问题,望高手给予帮助。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2011-12-25 15:54 
头像

注册: 2009-01-01 4:35
帖子: 161
地址: 重庆医科大学
送出感谢: 2
接收感谢: 0 次
请参照http://hi.baidu.com/lcl0201/blog/item/198fce1bcfd075e3ae513324.html



How to write Chinese with LyX ?

Ubuntu Linux/TexLive

Required packages:
latex-cjk-all (does this require to run 'fc-cache -fv' ?)
代码:
sudo apt-get install  latex-cjk-all


LyX Document Settings:
文档 -> 首选项 -> 语言 -> 编码 -> Other:UTF8:

"Unicode (CJK) utf8"

文档 -> 首选项 -> 字体 -> CJK:

"bsmi" (AR PL Mingti2L Big5 font)

or"bkai" (AR PL KaitiM Big5 font).

安装了latex-cjk-all这个包再设置一下就可以了。

值得一提的是字体按照上面的设置的话,输出的pdf会少一些字,这个不能忍啊。

还是设置成gbsn或者gkai吧,如那页面的例子所说的。

那个作者用的LyX版本是1.6.7,我本人用的是2.0.1,都得以解决!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2011-12-25 17:41 
头像

注册: 2008-04-26 12:41
帖子: 10971
送出感谢: 11
接收感谢: 38
:em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
7 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2011-12-25 20:04 
头像

注册: 2008-12-28 16:01
帖子: 728
送出感谢: 2
接收感谢: 15
gula 写道:

看出错提示,这是因为你转换的时候没有使用xelatex的方式编译所致。


_________________
爱因斯坦会弹钢琴
爱因斯坦会拉小提琴
爱因斯坦会骑自行车


页首
 用户资料  
 
8 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2011-12-25 20:11 
头像

注册: 2008-12-28 16:01
帖子: 728
送出感谢: 2
接收感谢: 15
5skyboy 写道:

这个方法过时了,现在推荐使用xetex来处理中文。


_________________
爱因斯坦会弹钢琴
爱因斯坦会拉小提琴
爱因斯坦会骑自行车


页首
 用户资料  
 
9 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2011-12-28 21:30 
头像

注册: 2005-10-01 21:38
帖子: 964
地址: 湖南邵东流光岭
送出感谢: 0 次
接收感谢: 0 次
lyx用汉语实在是太差了,建议今后版本默认就支持汉语!


_________________
小江恩的博客
http://gann.blog.ifeng.com/


页首
 用户资料  
 
10 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2011-12-29 6:25 

注册: 2008-10-31 16:22
帖子: 75
系统: Ubuntu 12.10
送出感谢: 0 次
接收感谢: 0 次
5楼的步骤有效,v2.0.2路过


页首
 用户资料  
 
11 楼 
 文章标题 : Re: l求助:lyx中文输出出错
帖子发表于 : 2012-12-28 14:03 
头像

注册: 2009-08-21 9:53
帖子: 305
地址: 深圳市
送出感谢: 0 次
接收感谢: 3
5skyboy 写道:
请参照http://hi.baidu.com/lcl0201/blog/item/198fce1bcfd075e3ae513324.html



How to write Chinese with LyX ?

Ubuntu Linux/TexLive

Required packages:
latex-cjk-all (does this require to run 'fc-cache -fv' ?)
代码:
sudo apt-get install  latex-cjk-all


LyX Document Settings:
文档 -> 首选项 -> 语言 -> 编码 -> Other:UTF8:

"Unicode (CJK) utf8"

文档 -> 首选项 -> 字体 -> CJK:

"bsmi" (AR PL Mingti2L Big5 font)

or"bkai" (AR PL KaitiM Big5 font).

安装了latex-cjk-all这个包再设置一下就可以了。

值得一提的是字体按照上面的设置的话,输出的pdf会少一些字,这个不能忍啊。

还是设置成gbsn或者gkai吧,如那页面的例子所说的。

那个作者用的LyX版本是1.6.7,我本人用的是2.0.1,都得以解决!


good!


_________________
成功不是赢在起点,而是赢在转折点。不再折腾,不再追求时尚美观,不再装B,实实在在做点东西……


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译