安装升级后,系统又变成英文的了。(正在玩狠的。大家等结果。)交叉升级安装成功。依赖

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

安装升级后,系统又变成英文的了。(正在玩狠的。大家等结果。)交叉升级安装成功。依赖

#1

帖子 eexpress » 2005-08-21 16:22

# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "zh_CN:zh:en_US:en",
LC_ALL = "zh_CN.UTF-8",
LANG = "zh_CN.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/sbin/dpkg-reconfigure: locales is broken or not fully installed
上次由 eexpress 在 2005-08-21 23:33,总共编辑 3 次。
● 鸣学
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#2

帖子 lyreopera » 2005-08-21 16:26

似乎是改了 locales

设置本地local环境:

sudo dpkg-reconfigure locales

确保 zh_CN.UTF-8 被选择,同时也默认local为 zh_CN.UTF-8
……
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2005-08-21 16:28

上面不是有执行结果吗?
麻烦看下为什么。
● 鸣学
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2005-08-21 16:30

新力德的那个管理器这样了。
附件
Screenshot-Error.png
● 鸣学
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#5

帖子 lyreopera » 2005-08-21 16:32

这样啊,我没仔细看,

似乎是你的locales损坏了,

重装locales看看?
……
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2005-08-21 16:34

系统管理中的东西,每次点击后,先不要密码的执行一次,然后,“changing user"要求输入密码,又执行一次。
● 鸣学
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#7

帖子 eexpress » 2005-08-21 16:35

lyreopera 写了:这样啊,我没仔细看,

似乎是你的locales损坏了,

重装locales看看?

请问如何转locales?
● 鸣学
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

想重新安装中文包。又这样。

#8

帖子 eexpress » 2005-08-21 16:44

# apt-get install language-pack-zh language-pack-zh-base language-support-zh
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
language-pack-zh-base: Depends: locales (>= 2.3.2.ds1-20ubuntu3) but it is not going to be installed
E: Broken packages

以前是独立安装过中文的。
● 鸣学
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2005-08-21 16:46

# apt-get install locales
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
locales: Depends: glibc-2.3.2.ds1-20ubuntu14

E: Broken packages
● 鸣学
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#10

帖子 lyreopera » 2005-08-21 17:02

你跟我上次遇到的问题一样,依赖包损坏了,

apt一个libc6_2.3.2.ds1-20ubuntu13_i386.deb


安装盘上也有,
/media/cdrom0/ubuntu/pool/main/g/glibc/libc6_2.3.2.ds1-20ubuntu13_i386.deb
……
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#11

帖子 lyreopera » 2005-08-21 17:04

不过,你还装了什么?

我上次为了弄好这东西,删了一堆软件包。
……
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#12

帖子 eexpress » 2005-08-21 17:16

我以为系统的pppoe不行,为了安装新版本的rp-pppoe,把libc6的所有的一套如dev等都升级了的。
● 鸣学
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#13

帖子 lyreopera » 2005-08-21 17:19

那么你现在好了没?

我上次是用debian的软件包,也是什了libc6 :D
……
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#14

帖子 eexpress » 2005-08-21 17:21

libc6_2.3.2.ds1-20ubuntu13_i386.deb下了一个
http://de2.vlsm.org/dists/stable/de2ui/ ... 6/&e=10342
dpkg-reconfigure locales
还是不行。
● 鸣学
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#15

帖子 eexpress » 2005-08-21 17:22

如果不升级libc6,我的usb-adsl驱动就安装不了。也就上网不行。
● 鸣学
回复

回到 “办公、图像、机械电子设计等”