当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]如何完全卸载latex--搞了一天了
帖子发表于 : 2006-10-01 22:14 

注册: 2006-03-06 19:16
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
今天照着 http://forum.ubuntu.org.cn/viewtopic.php?t=20925 安装latex+CJk,本来都搞定了。后来好奇,强行安装了texmf-zh后就坏了。
引用:
This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
kpathsea: Running mktexfmt latex.fmt
mktexfmt: no info for format `latex'.
I can't find the format file `latex.fmt'!

总出现上面的提示,后来把texmf-zh卸载了,结果还是不对。
后来就把装上的全部卸掉,再重装。结果还是不对。
后来就胡乱把/etc 及/use/share下的一些和tex相关的目录全删了,结果就成了不能卸载也不能安装了。
找了半天资料,终于修复了这个问题,可是重新装上后还是相同的问题。
我现在就是想,如果才能恢复到未安装过这些软件的状态呢(恢复到了再安装肯定能成功的)?

下面是一些错误提示
引用:
mkdir: cannot create directory `/etc/texmf/oldstuff_unused': No such file or directory
dpkg: error processing /var/cache/apt/archives/tetex-base_3.0-15ubuntu1_all.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Selecting previously deselected package tetex-bin.
Unpacking tetex-bin (from .../tetex-bin_3.0-13ubuntu6_i386.deb) ...
Selecting previously deselected package tetex-extra.
Unpacking tetex-extra (from .../tetex-extra_3.0-15ubuntu1_all.deb) ...
Selecting previously deselected package cjk-latex.
Unpacking cjk-latex (from .../cjk-latex_4.5.1-4.1_i386.deb) ...
Selecting previously deselected package dvipdfmx.
Unpacking dvipdfmx (from .../dvipdfmx_1%3a20050831-0.1_i386.deb) ...
Selecting previously deselected package dvipdfm-cjk.
Unpacking dvipdfm-cjk (from .../dvipdfm-cjk_1%3a20021231-1_i386.deb) ...
Errors were encountered while processing:
/var/cache/apt/archives/tetex-base_3.0-15ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



引用:
sudo apt-get install tetex-base tetex-bin tetex-extra cjk-latex dvipdfm dvipdfm-cjk dvipdfmx
Reading package lists... Done
Building dependency tree... Done
tetex-base is already the newest version.
tetex-bin is already the newest version.
tetex-extra is already the newest version.
cjk-latex is already the newest version.
Note, selecting tetex-bin instead of dvipdfm
tetex-bin is already the newest version.
dvipdfm-cjk is already the newest version.
dvipdfmx is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
5 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up tetex-base (3.0-15ubuntu1) ...
done
update-language: cannot read /etc/texmf/language.d/00tex.cnf
dpkg: error processing tetex-base (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of tetex-bin:
tetex-bin depends on tetex-base (>= 3.0-4); however:
Package tetex-base is not configured yet.
dpkg: error processing tetex-bin (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of tetex-extra:
tetex-extra depends on tetex-base (>= 3.0-11); however:
Package tetex-base is not configured yet.
tetex-extra depends on tetex-bin (>= 2.99); however:
Package tetex-bin is not configured yet.
dpkg: error processing tetex-extra (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dvipdfmx:
dvipdfmx depends on tetex-bin; however:
Package tetex-bin is not configured yet.
dvipdfmx depends on tetex-base; however:
Package tetex-base is not configured yet.
dvipdfmx depends on dvipdfm; however:
Package dvipdfm is not installed.
Package tetex-bin which provides dvipdfm is not configured yet.
dpkg: error processing dvipdfmx (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dvipdfm-cjk:
dvipdfm-cjk depends on dvipdfmx (>= 20030313-1); however:
Package dvipdfmx is not configured yet.
dpkg: error processing dvipdfm-cjk (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
tetex-base
tetex-bin
tetex-extra
dvipdfmx
dvipdfm-cjk
E: Sub-process /usr/bin/dpkg returned an error code (1)
引用:


_________________
http://www.herofit.cn


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译