当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请问安装完vim后,如何安装latex-suite?
帖子发表于 : 2006-10-20 2:32 

注册: 2006-10-20 1:23
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我以前是mandrake用户,刚刚转到ubuntu来,有个问题搞不定。

请问安装完vim后,如何安装latex-suite? 我怎么无论如何都装不 上呢?

tex 的菜单根本出不来,但使语法高亮可以。


如果可以,请说详细点。对ubuntu不熟悉。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-20 2:36 

注册: 2006-10-20 1:23
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我的问题别人也问过来,可惜没有人回答,ubuntu不会把这么常用的东西搞的很麻烦吧?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-20 9:50 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
记得在vim.org上面看到过,我没用latex,对这个只能提供点信息,网站上面都有说明,vim文件里面也主要是操作说明。 :lol:


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-22 13:59 

注册: 2006-10-22 13:39
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
mkdir ~/.vim
cd ~/.vim
wget http://vim-latex.sourceforge.net/downlo ... 325.tar.gz
tar xzvf latexSuite20060325.tar.gz

vim ~/.vimrc
add:

代码:
filetype plugin on
filetype indent on
set shellslash
set grepprg=grep\ -nH\ $*
let g:tex_flavor = "latex"


vim ~/.vim/ftplugin/tex.vim
add:

代码:
se  fenc=cp936
let g:Tex_ViewRule_dvi = 'kdvi'
let g:Tex_ViewRule_pdf = 'evince'
let g:Tex_ViewRule_ps  = 'evince'

let g:Tex_compileRule_ps  = 'dvips -o $*.ps $*.dvi'
let g:Tex_CompileRule_pdf = 'dvipdfmx $*.dvi'

as you wish

vim
:helptags ~/.vim/doc


最后由 kliz 编辑于 2006-10-23 10:45,总共编辑了 2 次

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-10-23 1:51 

注册: 2006-01-18 15:01
帖子: 1074
送出感谢: 0 次
接收感谢: 1
sudo aptitude install vim-latexsuite


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-10-23 9:13 

注册: 2006-10-20 1:23
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
谢谢大家的热心回复。 四楼说的是正途。但我觉得ubuntu把这么重要的国际通用的软件都没做好,有点失望。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-10-23 10:44 

注册: 2006-10-22 13:39
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
木糖醇 写道:
谢谢大家的热心回复。 四楼说的是正途。但我觉得ubuntu把这么重要的国际通用的软件都没做好,有点失望。

:shock: 自己动手 丰衣足食


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-10-24 1:31 

注册: 2006-08-06 14:49
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
这个是latex-suite的通用安装方法,你肯定没有仔细看人家的说明,就在主页上面清清楚楚写的.其实就是拷贝到目录,加点东西到vimrc里面.这个可是和ubuntu没有什么关系...


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-10-26 17:28 

注册: 2006-10-22 13:39
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
源里的latex-suite的确有问题
不能和vim7配合工作

自己安装较新的就ok了


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-10-30 12:41 

注册: 2006-01-18 15:01
帖子: 1074
送出感谢: 0 次
接收感谢: 1
我的是用源里面的,没有问题。
都是3月25号的版本,安装就是拷贝而已,怎么会有问题?
vimrc当然要自己编辑。
但是help和ftpplugin都是设置好了的


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-12-18 19:18 
头像

注册: 2007-11-14 15:36
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
顶一个4楼的,我也是latex-suite搞了好几天了,没一点进展,现在一下子全好了!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-06-02 16:51 

注册: 2008-06-02 16:49
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
请参考
http://forum.ubuntu.org.cn/viewtopic.ph ... 1b4a2cf96d


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译