当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu 10.04 64Bit 下安装 Ansys.Fluent.6.3.Linux.x64失败
帖子发表于 : 2010-09-22 12:53 

注册: 2009-12-09 18:56
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我按照网上的方法在Ubuntu 10.04 64上安装Ansys.Fluent.6.3.Linux.x64和Gambit_install-lnx86-2.3.16,安装目录/opt/
在bash.bashrc上添加了:

代码:
# Fluent
export FLUENT_ARCH=lnamd64
PATH=$PATH:/opt/Fluent.Inc/bin
export PATH LM_LICENSE_FILE=/opt/Fluent.Inc/license/license.dat


然后

代码:
vigilant@vigilant-laptop:~$ sudo '/opt/Fluent.Inc/bin/fluent'


显示

代码:
/opt/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26
/opt/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3 -f fluent (fluent "  -r6.3.26 -path/opt/Fluent.Inc")
/opt/Fluent.Inc/fluent6.3.26/cortex/lnamd64/cortex.3.7.3: error while loading shared libraries: libstdc++.so.5: wrong ELF class: ELFCLASS32


无法启动
网上能找到的方法也不多,大多都试过了,没用,所以又改回最初安装的状态了,求高人详解


_________________
生死去来
蓬头傀儡
一线断时
落落磊磊


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu 10.04 64Bit 下安装 Ansys.Fluent.6.3.Linux.x64失败
帖子发表于 : 2010-09-22 17:45 
头像

注册: 2009-11-02 7:42
帖子: 40
送出感谢: 0 次
接收感谢: 3
不是提示libstdc++.so.5有问题了吗,找一个装上不就结了。


_________________
生前何必久睡
死后自会长眠


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu 10.04 64Bit 下安装 Ansys.Fluent.6.3.Linux.x64失败
帖子发表于 : 2010-09-22 21:23 
头像

注册: 2008-09-13 19:17
帖子: 7598
系统: Arch Linux (x86_64)
送出感谢: 9
接收感谢: 60
从Debian或者旧版本的Ubuntu软件库里下载libstdc++5


_________________
[Ubuntu桌面指南]-[10.04新手入门—笨兔兔的故事 ]-[加入#ubuntu-cn IRC聊天]
博客:http://www.lainme.com


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu 10.04 64Bit 下安装 Ansys.Fluent.6.3.Linux.x64失败
帖子发表于 : 2010-09-23 15:03 

注册: 2009-12-09 18:56
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
foxman997 写道:
不是提示libstdc++.so.5有问题了吗,找一个装上不就结了。

lainme 写道:
从Debian或者旧版本的Ubuntu软件库里下载libstdc++5

虽然接触了很久,但还是没有在ubuntu上的敏感性。
感谢楼上二位指点,fluent启动成功

为了方便后面的朋友,下面是这个问题的详细解答:
在Ubuntu 10.04下按顺序安装
http://mirrors.kernel.org/ubuntu/pool/universe/g/gcc-3.3/gcc-3.3-base_3.3.6-15ubuntu4_amd64.deb
http://mirrors.kernel.org/ubuntu/pool/universe/g/gcc-3.3/cpp-3.3_3.3.6-15ubuntu4_amd64.deb
http://mirrors.kernel.org/ubuntu/pool/universe/g/gcc-3.3/gcc-3.3_3.3.6-15ubuntu4_amd64.deb
附件:
文件注释: 这个就是提示缺少的文件,之前三个文件是本文件依赖包
libstdc++5_3.3.6-15ubuntu4_amd64.deb [284.88 KiB]
被下载 389 次


单击fluent即可正常启动了。


_________________
生死去来
蓬头傀儡
一线断时
落落磊磊


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu 10.04 64Bit 下安装 Ansys.Fluent.6.3.Linux.x64失败
帖子发表于 : 2011-11-28 17:29 

注册: 2011-11-28 17:24
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
however, we will meet a problem:

fluentlm-helper 91 no such file.

I solved this problem by typing "apt-get install lib32gccl" in terminal


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 8 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译