[分享]ubuntu6.06使用texlive和kile而避免安装tetex的方法。

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
zhangsong023
帖子: 768
注册时间: 2006-09-20 19:56
送出感谢: 0
接收感谢: 1 次

[分享]ubuntu6.06使用texlive和kile而避免安装tetex的方法。

#1

帖子 zhangsong023 » 2006-10-31 19:55

本贴主要参考http://ubuntuforums.org/showthread.php?t=148954&page=2,原贴为英文,针对6.10的,我针对6.06做了一下整理。

一 问题描述
使用置顶中的TeX Live 2005 with Chinese Support for GNU/Linux Operating S非常棒,不用配置中文,且支持UTF8和GBK,kile则是最强大的tex编辑环境,但两者一起使用,会遇到一点小问题:
从源里安装kile,必须附带安装tetex,浪费硬盘空间,且配置文件杂乱,如何在不安装tetex的情况下安装kile呢。

二 解决方案
1 删除tetex
2 下载kile的deb包http://packages.ubuntu.com/dapper/tex/kile
3 执行

代码: 全选

dpkg-deb -x kile_1.8.1-3.2ubuntu1_i386.deb kile_1.8.1-3.2ubuntu1_i386
dpkg-deb -e kile_1.8.1-3.2ubuntu1_i386.deb kile_1.8.1-3.2ubuntu1_i386/DEBIAN
cd kile_1.8.1-3.2ubuntu1_i386/DEBIAN/
vim control
4 删除依赖项和推荐项中和tetex相关的包,保存退出
5 执行

代码: 全选

cd ../..
dpkg-deb -b kile_1.8.1-3.2ubuntu1_i386 kile_1.8.1-3.2ubuntu1_i386.deb
6 安装新产生的包
7 将texlive的命令所在目录,就是latex, pdflatex所在的目录加入PATH环境变量,否则kile在system check时会报错。
大功告成。
Happy TeXing!

另外,安装完毕后,系统可能提示你升级,不要升,否则又会装上tetex了。我锁定了版本,还让我升级,于是我把kile包版本号改高了(其实这个包和源里的版本是一致的),省得升级来烦我,修改版本方法和去掉tetex依赖的方法相同,不再详述。如果谁有更好的方法,请告知。
头像
rhfcaesar
帖子: 2996
注册时间: 2005-11-17 15:45
来自: 湖北
送出感谢: 0
接收感谢: 1 次

#2

帖子 rhfcaesar » 2006-10-31 21:11

问一下,怎么加入PATH环境变量啊,谢谢
zhangsong023
帖子: 768
注册时间: 2006-09-20 19:56
送出感谢: 0
接收感谢: 1 次

#3

帖子 zhangsong023 » 2006-10-31 21:52

rhfcaesar 写了:问一下,怎么加入PATH环境变量啊,谢谢
搜索论坛。
quantumfang
帖子: 74
注册时间: 2006-11-14 10:44
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 quantumfang » 2006-11-16 8:55

帅呆了!

顶!
回复

回到 “办公、图像、机械电子设计等”