安装libreoffice3.3遇到的小问题(不知道是不是BUG)

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
0o永远的菜鸟o0
帖子: 218
注册时间: 2010-12-08 17:10
来自: 宇宙中的某个角落.....
送出感谢: 0
接收感谢: 2 次

安装libreoffice3.3遇到的小问题(不知道是不是BUG)

#1

帖子 0o永远的菜鸟o0 » 2011-01-27 17:26

如果用命令安装就没问题,如果自己一个一个的点deb安装就会出现兼容错误!
:em06
我看了下,是语言包的第一个包有问题,那两个包的名字是以en-us和zh-zn结尾的。但是下面的依赖包却是依赖的以en-US和zh-ZN结尾的同名包!所以自己点击deb安装是安装不了的!会报兼容错误!

但是用

代码: 全选

sudo dpkg -i *.deb
命令安装又可以安装!
不知道是为什么!求解答!
:em20

另,安装java的时候在ubuntu软件中心里发现一个叫:ubuntu额外的版权受限程序
的软件。可以自动安装java和设置工作环境,很好用!
我是个完全追求运行速度的人,特效神马的都是浮云...

Ubuntu10.04LTS
坚持单系统,坚持LTS!

PS:有时候我的帖子会没排版,那说明我在用手机上论坛!
头像
supercatexpert
帖子: 403
注册时间: 2010-01-17 15:39
系统: Debian Wheezy AMD64
送出感谢: 0
接收感谢: 6 次
联系:

Re: 安装libreoffice3.3遇到的小问题(不知道是不是BUG)

#2

帖子 supercatexpert » 2011-01-27 20:48

因为依赖关系的问题,你必须按照依赖的顺序装,或者干脆一堆包全丢给dpkg,让它自动处理依赖关系。
OS: Debian Wheezy (Testing) for AMD64~~~
Mobile Phone: Nokia N900, OS: Maemo 5.0 (Base on Debian)~~~
本人的项目: RhythmCat(Linux下的音乐播放器.....支持歌词等功能...)
http://code.google.com/p/rhythmcat

RhythmCat 2进行中 (https://github.com/supercatexpert/RhythmCat2/)
0o永远的菜鸟o0
帖子: 218
注册时间: 2010-12-08 17:10
来自: 宇宙中的某个角落.....
送出感谢: 0
接收感谢: 2 次

Re: 安装libreoffice3.3遇到的小问题(不知道是不是BUG)

#3

帖子 0o永远的菜鸟o0 » 2011-01-28 13:33

依赖关系我知道,但是那个被依赖的包的名字是错的。也就是依赖上写的是依赖那个叫XXXen-US.deb的包和另一个叫XXXzh-ZN.deb的包。但实际上那两个包的名字是XXXen-us.deb和XXXzh-zn.deb。
我现在想知道的是那个sudo dpkg -i *.deb命令是怎么解决依赖问题的。
我是个完全追求运行速度的人,特效神马的都是浮云...

Ubuntu10.04LTS
坚持单系统,坚持LTS!

PS:有时候我的帖子会没排版,那说明我在用手机上论坛!
0o永远的菜鸟o0
帖子: 218
注册时间: 2010-12-08 17:10
来自: 宇宙中的某个角落.....
送出感谢: 0
接收感谢: 2 次

Re: 安装libreoffice3.3遇到的小问题(不知道是不是BUG)

#4

帖子 0o永远的菜鸟o0 » 2011-01-28 13:57

好吧,我不得不承认命令行比图形强大。dpkg居然解决了依赖问题。现在新立得里的libreoffice包全都依赖了XXXen-us.deb和XXXzh-cn.deb。 :em06
我是个完全追求运行速度的人,特效神马的都是浮云...

Ubuntu10.04LTS
坚持单系统,坚持LTS!

PS:有时候我的帖子会没排版,那说明我在用手机上论坛!
wykzly
帖子: 224
注册时间: 2010-05-20 13:45
送出感谢: 0
接收感谢: 0

Re: 安装libreoffice3.3遇到的小问题(不知道是不是BUG)

#5

帖子 wykzly » 2011-01-28 15:39

累不累啊 直接ppa安装就结了,libreoffice 已经支持ppa源了
回复

回到 “办公、图像、机械电子设计等”