openoffice 不能用,哪位仁兄帮一下

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
kfqyz
帖子: 16
注册时间: 2006-05-31 15:14
送出感谢: 0
接收感谢: 0

openoffice 不能用,哪位仁兄帮一下

#1

帖子 kfqyz » 2006-11-16 23:36

错误提示如下:
$ openoffice
Gtk-Message: Failed to load module "gail": libgail.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "atk-bridge": libspi.so.0: cannot open shared object file: No such file or directory
/usr/lib/openoffice/program/soffice: line 236: 10660 段错误 "$sd_prog/$sd_binary" "$@"

** (process:10648): WARNING **: Unknown error forking main binary / abnormal early exit ...
AMD Phenom 9600 Quad-Core
七彩虹 MCP78S
4G ( 威刚 DDR2 800MHz )
西数 WDC WD3200AAJS-00B4A0 ( 320 GB )
Nvidia GeForce 9500 GT ( 256 MB / Nvidia )
建兴 ATAPI DVD A DH20A3S ( DVD-RAM/DVD+-RW )
asgames
帖子: 283
注册时间: 2005-08-16 14:59
送出感谢: 0
接收感谢: 0

#2

帖子 asgames » 2006-11-20 9:07

我也遇上类似问题,问一下你,是不是装了ATI的驱动,刚才GOOGLE了下,似乎和ATI有什么关系,但是详细的说明还没看到,国外的网页好难打开。
悲哀在于,所有硬件都主动去追求WINDOWS,而遗憾的是,LINUX要主动去追求所有硬件.
ATI+AMD=AIDsTM
16驱动还没开始弄呢,15又罢工了,呜呼,决定怀疑一切可怀疑的,下载A CD,准备重装,残念中……
asgames
帖子: 283
注册时间: 2005-08-16 14:59
送出感谢: 0
接收感谢: 0

#3

帖子 asgames » 2006-11-20 9:28

it seems that the update broke the xorg.conf file, symptom is when xdpyinfo reports false screen dimensions:
Code:

<user>@<machine>:~$ xdpyinfo |grep dimensions
dimensions: 1600x1200 pixels (0x0 millimeters)

a simple
Code:

sudo dpkg-reconfigure xserver-xorg

will put things in place again:
Code:

<user>@<machine>:~$ xdpyinfo |grep dimensions
dimensions: 1600x1200 pixels (542x406 millimeters)

oo runs fine again.

http://ubuntuforums.org/showthread.php?p=1751381原文出于这里,但是我还没试过,看不懂,依照他的说法,是不是重新配置一下XORG就行?奇怪。
悲哀在于,所有硬件都主动去追求WINDOWS,而遗憾的是,LINUX要主动去追求所有硬件.
ATI+AMD=AIDsTM
16驱动还没开始弄呢,15又罢工了,呜呼,决定怀疑一切可怀疑的,下载A CD,准备重装,残念中……
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

#4

帖子 donny » 2006-11-24 20:13

回复

回到 “办公、图像、机械电子设计等”