当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [其它]求助,硬盘满,进不了Ubuntu了!
帖子发表于 : 2005-09-26 9:40 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
昨天试着做ubuntu的系统备份,就是压出来一个backup.tar的文件,结果硬盘满了,然后重启,就进不去ubuntu了。在图形登陆界面上输入用户名密码,告诉我好像是无法导入用户设置,然后就不让我登陆进去,退回登陆界面。我试着用RECOVER MODE,结果问我要ROOT的密码,我试着用SUDO的密码,不行。
然后又试着用LIVECD,但是在文件浏览器里看不到我的硬盘和文件,不知道该怎么办?
我打算用软件增加LINUX的EX2分区,不过又花时间,风险又大,哪位高手知道有没有什么快捷简单的方法啊?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-09-26 9:44 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
LIVECD,但是在文件浏览器里看不到我的硬盘和文件?
当然是能恢复最好。命令行可以看不。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-09-26 9:50 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
看了,不清楚该怎么弄,看文件系统,里面/HOME里没有我的目录。不知道LIVECD里的文件系统是哪里的,但不是我之前装得LINUX的文件系统。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-09-26 9:53 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
我是希望能用LIVECD里面删掉我的那个巨大无比的BACKUP文件,但livecd里面不知道怎么才能看到/操作我的以前安装的LINUX的文件系统。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-09-26 10:12 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
知道自己的盘就可以。比如系统在/dev/hda1,mount后,用df看下
~$ df
Filesystem 1K-块 已用 可用 已用% 挂载点
/dev/hda3 16385732 4298948 12086784 27% /
tmpfs 258180 0 258180 0% /dev/shm
第一个就是/。如果/home没有安装到其他盘,就应该在/dev/hda3(具体的看自己的信息),可以mount它,然后修改。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-09-26 10:16 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
好的,谢谢了,我再看一下。我刚才也在想,是不是该先mount它?有问题我再过来。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-09-26 15:20 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
还是搞不定阿!好像我的Ubuntu live找不出我的本地硬盘。
FDISK -L可以看到,不过DF里面看不到,反正我看不懂。
我试着用/dev/hdb3 /media/linux ext2 default 00 11(default 后面的我不太确定)加在fstab里面,报错?
怎么可以再live cd 界面下mount我的本地linux分区并且可以读写啊?
正常情况下,live cd应该可以自动mount本地linux分区么?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-09-26 15:21 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
还有一个问题,我想再recover mode里面直接删掉多余的文件,但是它不停的找我要root密码,怎么办啊,我试过sudo的密码了,不行啊?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-09-26 15:23 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
直接mount看看那。
mount /dev/hdb3 /media/linux_1 -t ext2 -o user,rw,umask=0,iocharset=utf8

-L label
Mount the partition that has the specified label.
使用卷标的方式也可以。


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-09-26 15:46 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
直接mount看看那。
mount /dev/hdb3 /media/linux_1 -t ext2 -o user,rw,umask=0,iocharset=utf8

-L label
Mount the partition that has the specified label.
使用卷标的方式也可以。


不行,不知道为什么,我用
mount /dev/hdb3 /media/linux_1 -t ext2 -o user,rw,umask=0,iocharset=utf8
返回的是,wrong fs ype, bad option, bad superblcok on /dev/hdb3

你说的卷标方式是什么,对不起,我也不知道啊。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-09-26 15:49 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
我用fdisk-l 有这样一行显示:
/dev/hdb3 11729 14593 23013112+ 83 Linux
说明我的hdb3是linux 分区?


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-09-26 15:56 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
iocharset=utf8去掉列。多实验,看看man mount。慢慢调试。


_________________
● 鸣学


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-09-26 16:12 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
哈,搞定了!
我再faq里看了看,用mount -t ext3 /dev/hdb3 /media/Linux 试了一下,搞定了,现在我又回到我的Ubuntu里面了,谢谢eexpress!
刚才你可能被我误导了,也用ext2了,赫赫,都怨我,太新手了。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-09-26 16:55 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
我都想问的。想来你不会搞错。 :lol:


_________________
● 鸣学


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-09-27 6:03 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
这个问题从我装Ubuntu就一直没弄清楚,我知道现在一般linux都是ext3的,不过不知道是什么软件,好像是PartitionMagic告诉我ext2,我就一直以为是ext2的,结果这下有机会把它弄清楚了,也不错。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译