当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 不能上网!如何配置DHCP客户端?
帖子发表于 : 2005-10-04 23:35 

注册: 2005-10-04 22:49
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
先说一下过程,我是通过硬盘安装的ubuntu5.04,安装过程中说“找不到网卡”,装完之后不能上网。
我的机器是IBM T22,网卡是3Com 10/100 Mini PCI,型号是3C556。

以下是ifconfig -a 的内容:
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5387 errors:0 dropped:0 overruns:0 frame:0
TX packets:5387 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:479320 (468.0 KiB) TX bytes:479320 (468.0 KiB)
sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)


以下是interface里面的内容:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

问题:
1.右上角有网络图标,可是我还是不能连接上。
2.打开[device manager],看起来是识别的了网卡。(看图片)
我觉得网卡驱动可能是装上了,只是没有配置好,想知道怎么配置。
谢谢


最后由 xishui 编辑于 2005-10-05 18:12,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-10-04 23:43 

注册: 2005-09-28 19:18
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
你在局域网一般就是192.168.0.1的网关,192.168.0.x(你的ip,自己写)。255.255.255.0(掩码)
这是最简单的。如果是单机上adsl,那就要配置其他的了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-10-05 11:12 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
只有lo,网卡的设备就没用上。看lo的配置有什么意义。
还是要先搜索一下你的那种网卡是不是要驱动,或者ubuntu缺省不支持。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-10-05 12:25 

注册: 2005-10-04 22:49
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
那看了是不认这个网卡卡了。驱动?


最后由 xishui 编辑于 2005-10-05 18:09,总共编辑了 1 次

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-10-05 13:06 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
还是贴错误提示吧。要不谁知道哪里错了。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-10-05 13:17 
头像

注册: 2005-05-08 21:28
帖子: 264
送出感谢: 0 次
接收感谢: 0 次
“系统”菜单 -> 系统管理 -> 联网 -> 选择你的网卡,点击属性,选择DHCP,然后激活。
:lol:


_________________
Ubuntu 5.10 Breezy Badger


页首
 用户资料  
 
7 楼 
 文章标题 : 是驱动没有装上
帖子发表于 : 2005-10-05 18:05 

注册: 2005-10-04 22:49
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我的编译有问题,我是直接用GCC编译的,呵呵,看来不对。
好像是要用make在内核里面编译,但是一个目录和文件没有找到,请问,为什么?
/etc/rc.d/rc.modules文件没有找到,只有rc0.d,rc1.d,rc2.d等等,就是没有rc.d,而且那些目录里面都没有rc.modules这个文件


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:MSNbot Media 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译