当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : meld@breezy
帖子发表于 : 2005-10-12 13:09 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
选择目录或者文件,确定就死掉。是1.0的。hoary的没没事,但那是0.8的。


_________________
● 鸣学


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-10-19 16:19 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
下了hoary的meld_0.9.4.1-1ubuntu1_all.deb,也一样,看来是breezy的问题了。

$ meld
/usr/lib/meld/undo.py:186: DeprecationWarning: Class UndoSequence is already GObject-registered; Please note that classes containing any of the attributes __gtype_name__, __gproperties__, or __gsignals__ are now automatically registered.
gobject.type_register(UndoSequence)
/usr/lib/meld/melddoc.py:126: DeprecationWarning: Class MeldDoc is already GObject-registered; Please note that classes containing any of the attributes __gtype_name__, __gproperties__, or __gsignals__ are now automatically registered.
gobject.type_register(MeldDoc)
/usr/lib/meld/dirdiff.py:164: DeprecationWarning: Class EmblemCellRenderer is already GObject-registered; Please note that classes containing any of the attributes __gtype_name__, __gproperties__, or __gsignals__ are now automatically registered.
gobject.type_register(EmblemCellRenderer)
*** glibc detected *** free(): invalid pointer: 0xb78b7580 ***
已杀死


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-10-19 16:41 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
下了2.3。ln了。


附件:
python.png
python.png [ 185.66 KiB | 被浏览 1132 次 ]



_________________
● 鸣学
页首
 用户资料  
 
4 楼 
 文章标题 : 再使用tar的。需要pygtk。找不到
帖子发表于 : 2005-10-19 16:47 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
$ make
make -C po
make[1]: Entering directory `/home/exp/安装/meld-1.0.0/po'
mkdir -m 755 -p it/LC_MESSAGES/ && msgfmt -c -o it/LC_MESSAGES/meld.mo it.po
mkdir -m 755 -p ja/LC_MESSAGES/ && msgfmt -c -o ja/LC_MESSAGES/meld.mo ja.po
mkdir -m 755 -p ko/LC_MESSAGES/ && msgfmt -c -o ko/LC_MESSAGES/meld.mo ko.po
mkdir -m 755 -p nl/LC_MESSAGES/ && msgfmt -c -o nl/LC_MESSAGES/meld.mo nl.po
mkdir -m 755 -p pt_BR/LC_MESSAGES/ && msgfmt -c -o pt_BR/LC_MESSAGES/meld.mo pt_BR.po
mkdir -m 755 -p pt/LC_MESSAGES/ && msgfmt -c -o pt/LC_MESSAGES/meld.mo pt.po
mkdir -m 755 -p ru/LC_MESSAGES/ && msgfmt -c -o ru/LC_MESSAGES/meld.mo ru.po
mkdir -m 755 -p sr@Latn/LC_MESSAGES/ && msgfmt -c -o sr@Latn/LC_MESSAGES/meld.mo sr@Latn.po
mkdir -m 755 -p sr/LC_MESSAGES/ && msgfmt -c -o sr/LC_MESSAGES/meld.mo sr.po
mkdir -m 755 -p sv/LC_MESSAGES/ && msgfmt -c -o sv/LC_MESSAGES/meld.mo sv.po
mkdir -m 755 -p zh_CN/LC_MESSAGES/ && msgfmt -c -o zh_CN/LC_MESSAGES/meld.mo zh_CN.po
mkdir -m 755 -p zh_TW/LC_MESSAGES/ && msgfmt -c -o zh_TW/LC_MESSAGES/meld.mo zh_TW.po
make[1]: Leaving directory `/home/exp/安装/meld-1.0.0/po'
make -C help
make[1]: Entering directory `/home/exp/安装/meld-1.0.0/help'
for lang in "C"; do \
make -C $lang all ; \
done
make[2]: Entering directory `/home/exp/安装/meld-1.0.0/help/C'
scrollkeeper-preinstall /usr/local/share/gnome/help/meld/C/meld.xml meld-C.omf.in meld-C.omf
make[2]: Leaving directory `/home/exp/安装/meld-1.0.0/help/C'
make[1]: Leaving directory `/home/exp/安装/meld-1.0.0/help'

$ ./meld
No module named pygtk
Meld requires pygtk1.99.15 or higher.


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-10-23 16:46 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
再装个pygtk不就搞定了?


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-10-23 17:10 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
晕,看4楼你自己的帖子,最下面,不是有提示?


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-10-23 17:15 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
呵呵,但是是编译的版本,又正是着急的时候。也没想去找包的依赖。
代码:
exp@exp-off:/usr/bin$ ls -l python*
lrwxrwxrwx  1 root root      9 2005-10-24 09:45 python -> python2.4
-rwxr-xr-x  1 root root 925996 2005-09-06 00:51 python2.3
-rwxr-xr-x  1 root root 986924 2005-10-01 05:30 python2.4
//*****************************
hoary [color=blue]工作正常[/color]
//*****************************
exp@exp-off:~$ dpkg -s meld
Package: meld
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 1100
Maintainer: Ross Burton <ross@debian.org>
Architecture: all
Version: 0.9.4.1-1ubuntu1
Depends: python (<< 2.5), python (>= 2.4), python-gtk2 (>= 1.99.14-1), python-glade2, python-gnome2
Description: Graphical tool to diff and merge files
 Meld is a tool which allows the user to see the changes in, and merge
 between, either two files or two files with a common ancestor.
//=====================
exp@exp-off:~$ dpkg -s python|grep Version
Version: 2.4.1-0ubuntu2
exp@exp-off:~$ dpkg -s python-gtk2|grep Version
Version: 2.6.1-0ubuntu2
exp@exp-off:~$ dpkg -s python-glade2|grep Version
Version: 2.6.1-0ubuntu2
exp@exp-off:~$ dpkg -s python-gnome2|grep Version
Version: 2.10.0-0ubuntu1

//*****************************
breezy [color=blue]不能工作[/color]
//*****************************
exp@exp-off:~$ dpkg -s meld
Package: meld
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 1536
Maintainer: Ross Burton <ross@debian.org>
Architecture: all
Version: 1.0.0-1
Depends: [color=blue]python (<< 2.5), python (>= 2.4), python-gtk2 (>= 2.4), python-glade2 (>= 2.4), python-gnome2[/color]
Recommends: [color=blue]python-gnome2-extras[/color]
Description: graphical tool to diff and merge files
 Meld is a tool which allows the user to see the changes in, and merge between,
 either two files, two directories, or two files with a common ancestor.
//=====================
exp@exp-off:~$ dpkg -s python|grep Version
Version: 2.4.2-0ubuntu2
exp@exp-off:~$ dpkg -s python-gtk2|grep Version
Version: 2.8.1-0ubuntu2
exp@exp-off:~$ dpkg -s python-glade2|grep Version
Version: 2.8.1-0ubuntu2
exp@exp-off:~$ dpkg -s python-gnome2|grep Version
Version: 2.12.1-0ubuntu1
exp@exp-off:~$ dpkg -s python-gnome2-extras|grep Version
Version: 2.12.0-0ubuntu1
//*****************************


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 : pygtk就没有找到。和pythone及gtk相关的应该都装了
帖子发表于 : 2005-10-24 13:22 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
就直接说那个的可以吧。

$ dpkg -l|grep libgtk2
ii libgtk2-perl 1.100-1 Perl interface to the 2.x series of the Gimp
ii libgtk2.0-0 2.8.6-0ubuntu2 The GTK+ graphical user interface library
ii libgtk2.0-bin 2.8.6-0ubuntu2 The programs for the GTK+ graphical user int
ii libgtk2.0-common 2.8.6-0ubuntu2 Common files for the GTK+ graphical user int
ii libgtk2.0-dev 2.8.6-0ubuntu2 Development files for the GTK+ library


_________________
● 鸣学


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-10-24 13:42 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
需要pygtk,gtk的python绑定,那个meld不是python写的么
就如上面第一个的libgtk2-perl 那是gtk的perl绑定


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-10-24 13:43 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
我已经装了好多,麻烦直接说库名字吧。


_________________
● 鸣学


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-10-24 13:44 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
python-gtk2
python-gtk2-dev 包


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
12 楼 
 文章标题 : 你说的早有了
帖子发表于 : 2005-10-24 13:47 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
代码:
~$ dpkg -l python-gtk*
期望状态=未知(u)/安装(i)/删除(r)/清除(p)/保持(h)
| 当前状态=未(n)/已安装(i)/仅存配置(c)/仅解压缩(U)/配置失败(F)/不完全安装(H)
|/ 错误?=(无)/保持(?)/须重装(R)/两者兼有(#) (状态,错误:大写=故障)
||/ 名称         版本         简介
+++-==============-==============-============================================
un  python-gtk     <无>          (无相关介绍)
ii  python-gtk-1.2 0.6.12-2ubuntu GTK support module for Python
ii  python-gtk2    2.8.1-0ubuntu2 Python bindings for the GTK+ widget set
ii  python-gtk2-de 2.8.1-0ubuntu2 GTK+ bindings: devel files
ii  python-gtkextr 0.22-6ubuntu1  Python module for the GtkExtra widget set ex
ii  python-gtkmvc  0.9.1-1ubuntu1 Model-View-Controller (MVC) implementation f
exp@exp-off:~$ sudo apt-get install python-gtk
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
现在没有可用的软件包 python-gtk,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
可是下列的软件包取代了它:
  python-gtk-1.2 python-glade-1.2
E: 软件包 python-gtk 还没有可供安装的候选者


_________________
● 鸣学


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-10-24 13:51 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
leal
可能你想偏了。程序是可以启动运行的。就是选择文件或者目录后,确认,还没有退出选择文件框,死掉。麻烦想下有什么可能的问题。


附件:
Screenshot.png
Screenshot.png [ 121.47 KiB | 被浏览 1116 次 ]



_________________
● 鸣学
页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-10-24 14:11 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
我这儿也有问题

你再按它主页的说明做做看
http://meld.sourceforge.net/install.html
http://packages.debian.org/unstable/pyt ... hon-gnome2

Generic Install
Install the gnome-python modules

If your platform does not supply the gnome-python packages, you can install them from source. It is assumed that you have gnome2 and python2.2 development packages installed.

Download and install pyorbit pygtk gnome-python from your favourite gnome mirror.

You will need to both build and install them to the same $prefix and in that order. This is a gnome-python limitation.

Be careful to watch for messages like 'libfoo-2.0.pc not found' when running configure - you may need to install extra gnome development packages to correctly build.
Install intltool (optional)

Meld uses intltool to generate translations. You can skip this step if you always want to run meld in english.
Install meld

Untar meld.tgz, run "make" to build the translations (optional) and run "./meld"


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-10-24 16:40 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
反正输入文件及路径可以,就是不能选文件或者目录。应该是gtk2的配合问题


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译