当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装maya for linux 报错
帖子发表于 : 2013-03-28 20:53 

注册: 2012-06-09 15:40
帖子: 993
送出感谢: 0 次
接收感谢: 7
E: composite-2011: 子进程 已安装 post-installation 脚本 返回了错误号 2
无视他
进行到这步
sudo ln -s /usr/lib/libaudiofile.so.0 /usr/lib/libtiff/libaudiofile.so
ln: 无法创建符号链接"/usr/lib/libtiff/libaudiofile.so": 没有那个文件或目录
原文:

How to install Autodesk Maya 2011 on Debian / Ubuntu
27th April 2010 |


Last update: 10.08.16 – Minor typo correction

This tutorial have been made for Debian Sid but it should work on Debian-based distributions like Ubuntu.If you encounter any problems, please, contact me with a description of the problem and I will see if I can find a solution (and update this tutorial for the others who may encounter the same problem).

In this tutorial the commands that are required to be launched as root are prefixed by sudo, if you aren’t in the sudoers or don’t have a sudoers group, just launch them as root without the sudo prefix. I will use exempleuser as the user name, just substitute exempleuser with your user name.
Preparation
1.Copy installation files

首先,所有的Linux安装文件复制到临时文件夹在您的家中(在此为例,这将是/的家庭/ exempleuser / MayaInstall)。

mkdir /home/exempleuser/MayaInstall
cp -R /InsertPathToMayaInstallationFiles/* /home/exempleuser/MayaInstall

If you have priviledges problems when you copy them (I encounter the problem in previous Maya versions when I wanted to copy the installation files from the DVD-Rom to a directory as a non-root user), Use the same command but as root :

sudo cp -R /InsertPathToMayaInstallationFiles/* /home/exempleuser/MayaInstall

Here is a list of the installation files (note that the versions may be different for you, don’t worry it will work the same way) :

EULA = Directory with the License in different languages
adlmapps-1.3.34-0.x86_64.rpm = NEEDED in order to activate Maya and the other softwares bundled with it
adlmflexnetclient-1.3.34-0.x86_64.rpm = NEEDED in order to activate Maya and the other softwares bundled with it
adlmflexnetserver-1.3.34-0.x86_64.rpm = NEEDED in order to activate Maya and the other softwares bundled with it
autodesk.backburner.monitor-2011-377.i386.rpm = Web-based Monitoring software for Backburner, not needed to install Backburner
backburner.sw.base-2011-1470.i386.rpm = The actual Backburner, install this if you want to have backburner
backburner_webmonitor.sw.base-2011-1470.i386.rpm = Web-based Monitoring software for Backburner, not needed to install Backburner
Composite2011-2011.0-2459.x86_64.rpm = Install this if you want Toxic
INSTALL = Backburner install shell script
MatchMover2011_0_64-2011.0-177.x86_64.rpm = Install this if you want Matchmover
Maya2011_0_64-2011.0-271.x86_64.rpm = NEEDED, It’s the actual Maya package
Maya2011_0-docs_en_US_64-2011-88.x86_64.rpm = Install this if you want the Maya documentation
MID.txt = Some informations about the Maya version
setup = NEEDED, Maya setup
setup.xml = NEEDED in order to activate Maya and the other softwares bundled with it
setupbar.png = NEEDED, part of the Maya setup

2.Install required packages

Next, you need to install the following packages :
sudo apt-get install alien tcsh fam libxp6 libxpm4 libxprintapputil1 libxprintutil1 cpio rpm ia32-libs

If you don’t find the libxp6, libxpm4, libxprintapputil1 and libxprintutil1 packages, use this command instead :
sudo apt-get install alien tcsh fam libxp libxpm libxprintapputil libxprintutil cpio rpm ia32-libs
3.Symlink Tcsh to Csh

Now, symlink Tcsh to Csh :
sudo ln -s /usr/bin/tcsh /bin/csh
Convert/Extract and install RPMs

有两种方法 to install Maya from the RPMs on a debian based Linux system.You can convert the packages to .deb or you can extract them and install them manually, I personnaly use the later method.

Before converting or extracting the RPMs, you need to go to the directory who contains the Maya installations files:
cd /home/exempleuser/MayaInstall
1.Deb Method :

Using Alien, convert the RPMs to DEBs (see the list above to known what you need to convert and install) with this command:
for i in *.rpm; do sudo alien -cv $i; done

Install the deb you want either by double-cliking on them or with:
sudo dpkg -i nameOfThePackage.deb
2.Extracting Method:

使用cpio包,我们将提取的differents的RPM (again, see the list above to known what you need to extract and install) :
rpm2cpio nameOfThePackage.rpm | cpio -idmvu

当你提取所需的软件包,提取的内容复制到相应的目录 (like /usr, /var, …) with the sudo cp -R command :

sudo cp -R /home/exempleuser/MayaInstall/etc/init.d/* /etc/init.d
sudo cp -R /home/exempleuser/MayaInstall/opt/* /opt
sudo cp -R /home/exempleuser/MayaInstall/usr/* /usr
sudo cp -R /home/exempleuser/MayaInstall/var/* /var
Post-Installation

There is a few things you need to do before launching and activate Maya.
1.Symlink Maya binaries

Symlinks the Maya binaries in /usr/local/bin to launch them with a simple command (like Render to do batch renders).Go to the /usr/local/bin directory and make symlinks to fcheck, imgcvt, Render and maya2011

cd /usr/local/bin
sudo ln -s /usr/autodesk/maya2011-x64/bin/fcheck fcheck
sudo ln -s /usr/autodesk/maya2011-x64/bin/maya2011 maya
sudo ln -s /usr/autodesk/maya2011-x64/bin/imgcvt imgcvt
sudo ln -s /usr/autodesk/maya2011-x64/bin/Render Render

请注意,你可以改变一个人下创建的,如果你想有多个玛雅人版本或不想重做这些符号链接的麻烦,如果你安装另一个玛雅版本的maya2011 64。
2.Symlink maya2011-x64 directory to maya directory

Symlink a maya dir in /usr/autodesk to the maya2011-x64 one

cd /usr/autodesk
sudo ln -s maya2011-x64 maya
3.Get an icon

Now make some symlinks to have an icon
sudo ln -sf /usr/autodesk/maya2011-x64/desktop/Autodesk-Maya.desktop /usr/share/applications/Autodesk-Maya.desktop
sudo ln -sf /usr/autodesk/maya2011-x64/desktop/Autodesk-Maya.directory /usr/share/desktop-directories/Autodesk-Maya.directory
sudo ln -sf /usr/autodesk/maya2011-x64/desktop/Maya.png /usr/share/icons/hicolor/48x48/apps/Maya.png
5.Create a temporary directory for Mental Ray

Create a temporary directory for Mental Ray
sudo mkdir /usr/tmp
sudo chmod 777 /usr/tmp
6.Fix Maya UI launching bug

Here is the part that is specific to Maya 2011 (I have encountered it on the Betas versions and it’s still here).It may be a bug with non-US Debian installations (French in my case).If you don’t do it, a bug with one of the startup mel prevent the Maya UI to be launched.We will had a variable in the maya launcher to avoid that.Using nano (or your favorite editor), insert this : setenv LC_ALL en_US.UTF-8 In this file /usr/autodesk/maya2011-x64/bin/maya2011
You can also use this command:

sudo sh -c "echo 'setenv LC_ALL en_US.UTF-8' >> /usr/autodesk/maya2011-x64/bin/maya2011"
7.Export MAYA_LOCATION

And finally, export the MAYA_LOCATION variable
sudo export MAYA_LOCATION=/usr/autodesk/maya2011-x64

There is one more thing to do (symlinks the differents librairies), but we will do it after the next step in order to know wich librairies are needed
4.Install License

Here is the trickiest and most interesting part of this tutorial.In order to properly activate Maya, we will write and compile a fake rpm binary to launch the Maya Setup UI and have a proper license file to use during the activation.
1.Create a fake binary

Go to /home/exempleuser/MayaInstall and make a file called mayaInstall.c (the name of the file is not important) and put this code in it
int main (void) {return 0; }

You can also use theses commands:
cd /home/exempleuser/MayaInstall
sh -c "echo 'int main (void) {return 0; }' >> /home/exempleuser/MayaInstall/mayaInstall.c"

Now compile the file using gcc
cd /home/exempleuser/MayaInstall
gcc mayaInstall.c
2.Backup and replace the rpm binary

You should get a compiled binary called a.out.Backup you rpm binary in /usr/bin and replace it by the a.out file
sudo cp /usr/bin/rpm /usr/bin/rpm_backup
cd /home/exempleuser/MayaInstall
sudo cp a.out /usr/bin/rpm
3.Launch Maya setup

You can now launch the Maya supplied setup as if you were on a Red-Hat based system :
cd /home/exempleuser/MayaInstall
sudo ./setup
4.enter Serial and Product Key

Enter your serial (000-0000000 in this exemple) and product key and follow the rest of the UI.

5还原转二进制。

Revert the change made to the rpm binary in /usr/bin
sudo cp /usr/bin/rpm_backup /usr/bin/rpm
5.Symlink librairies

打开一个终端,推出玛雅Maya命令,你可能会遇到像这样的错误:
/usr/autodesk/maya2011-x64/bin/maya.bin: error while loading shared libraries: libtiff.so.3: cannot open shared object file: No such file or directory

This happen because Maya is looking for very a specific version of a librairy.You can fix it by making a symlink between your version of the library located in /usr/lib with the version required by Maya.Here is some of the symlinks I had to make :

sudo ln -s /usr/lib/libtiff.so.4 /usr/lib/libtiff.so.3
sudo ln -s /usr/lib/libaudiofile.so.0 /usr/lib/libtiff/libaudiofile.so

Theses two ones are for PyMel :
sudo ln -s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.3
sudo ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.3

Do this for each librairy Maya is asking for.
6.Activate Maya

You can now launch Maya to activate it with the maya command.
7.Enjoy !

You can now use Maya 2011 on Debian.Stay tuned for a post on how to fix the different bugs between Maya and Linux.


Maya2012安装在ubuntu11.10上的案例,转载下,中文的,感谢原作者

http://www.maya09.cn/thread-18283-1-1.html

64位ubuntu11.10安装maya2012的过程

最近试玩ubuntu11.10,发现maya2012有64位的,就决定在ubuntu上安装试试,费了一整天时间,终于装上了,所以想把自己在安装过程说出来,让别人少走弯路,我是菜鸟,安装过程参照了很多人的帖子,在此表示感谢。

系统:64位桌面版ubuntu11.10

软件:Autodesk_Mudbox_2012_EFGJ_Linux_64bit.tgz

要以ROOT用户登陆进行安装,系统默认禁用了root, 通过以下命令
sudo passwd root
按提示输入密码,成功后,注销系统,点其它用户,输入root用户名,再输入刚才的密码。

将以上压缩包解压到主目录下Mudbox,由于安装包是使用rpm包的形式发行的,而ubuntu需要alien这个软件才能支持rpm包,直接到ubuntu软件中心下载安装就可以了。
安装好后,通过Ctrl+Alt+t调出终端窗口,输入以下命令:
cd Mudbox
进入解压目录
sudo alien *.rpm
命令把里面的所有rpm转成deb,在这儿要等一段时间,文件执行完会回到提示符,文件夹里会生成一个相近名字的deb文件,这个时候可以分别双击安装,也可以用命令sudo dpkg来安装

但远还没到可以打开MAYA的时候,这个时候要在解压文件夹内新建一个空白文档,文件名为dummy.c。
编辑dummy.c里的内容,拷贝以下内容进去:
int main (void) {

return 0;

}

然后保存,关闭。
运行命令gcc dummy.c 会在目录里生成一个a.out文件
复制a.out到/usr/bin/rpm
命令:sudo cp a.out /usr/bin/rpm
运行解压文件夹里的setup
或执行命令./setup
弹出图形安装界面出来安装序列号要填serial:666-42943644 key:498D1
安装时不要选择FLEXnet Client,授权选standalone license,按照提示直到安装完成
执行完后先,把crack2012复制在解压文件夹内,然后执行命令./crack2012
如果没有产生错误就顺利完成。
在安装时如果提示没有权限,用的chmod a+x crack2012附权限
接着给maya搞个临时文件夹附权限:
sudo mkdir /usr/tmp
sudo chmod 777 /usr/tmp

在windows下用maya的crack工具获得一个aw.dat文件。这个就不用我讲了,玩过maya的人都知道。然后回到linux下,将刚才得到 的aw.dat文件复制到/var/flexlm目录下。跟着要修改/usr/tmp的权限,否则mental ray渲染会失败。

sudo chmod 777 /usr/tmp

如果想用maya的热键,还要修改gnome里的默认alt键功能。

gconf-editor /apps/metacity/general/mouse_button_modifier

把<alt>换成空就可以了



这时,maya已经安装完成了,双击打开可能会没有反应,
如果没有反应,输入以下命令:
/usr/autodesk/maya/bin/maya 看一下到底出什么问题了,
会提示error while loading shared libraries: libtiff.so.3: cannot open shared objec等类似,主要是看差什么文件,如我的差libtiff.so.3,,需要将libtiff.so.3库文件链接到共享库上,通过apt- cache search libtiff | grep TIFF查看自己的版本,我的版本是libtiff4,再通过搜索,发现我的库文件是libtiff.so.4.3.4。
输入以下命令:
sudo ln -s usr/lib/x86_64-linux-gnu/libtiff.so.4.3.4 /usr/lib/libtiff.so.3
同理解决其它库文件问题,解决完全部库问题后应该可以打开maya了,真是不容易,我走了好多弯路。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装maya for linux 报错
帖子发表于 : 2013-03-28 20:54 

注册: 2012-06-09 15:40
帖子: 993
送出感谢: 0 次
接收感谢: 7
这个错误怎么解决安装什么软件包就包含?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装maya for linux 报错
帖子发表于 : 2013-03-28 20:58 

注册: 2012-06-09 15:40
帖子: 993
送出感谢: 0 次
接收感谢: 7
root@thinkpad:/home/cc/Maya# sudo dpkg -i composite-2011_2011.0-2460_amd64.deb
(正在读取数据库 ... 系统当前共安装有 167746 个文件和目录。)
正预备替换 composite-2011 2011.0-2460 (使用 composite-2011_2011.0-2460_amd64.deb) ...
正在解压缩将用于更替的包文件 composite-2011 ...
正在设置 composite-2011 (2011.0-2460) ...
python: can't open file '/usr/autodesk/Composite_2011/etc/configure.py': [Errno 2] No such file or directory
dpkg: error processing composite-2011 (--install):
子进程 已安装 post-installation 脚本 返回了错误号 2
在处理时有错误发生:
composite-2011


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装maya for linux 报错
帖子发表于 : 2013-03-28 21:12 

注册: 2012-06-09 15:40
帖子: 993
送出感谢: 0 次
接收感谢: 7
安装libaudiofile
installArchives() failed: Selecting previously unselected package libaudiofile1:amd64.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 217847 files and directories currently installed.)
Unpacking libaudiofile1:amd64 (from .../libaudiofile1_0.3.5-1_amd64.deb) ...
Selecting previously unselected package libaudiofile-dev:amd64.
Unpacking libaudiofile-dev:amd64 (from .../libaudiofile-dev_0.3.5-1_amd64.deb) ...
Setting up composite-2011 (2011.0-2460) ...
python: can't open file '/usr/autodesk/Composite_2011/etc/configure.py': [Errno 2] No such file or directory
dpkg: error processing composite-2011 (--configure):
subprocess installed post-installation script returned error exit status 2
Setting up libaudiofile1:amd64 (0.3.5-1) ...
Setting up libaudiofile-dev:amd64 (0.3.5-1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
composite-2011
Error in function:
Setting up composite-2011 (2011.0-2460) ...
python: can't open file '/usr/autodesk/Composite_2011/etc/configure.py': [Errno 2] No such file or directory
dpkg: error processing composite-2011 (--configure):
subprocess installed post-installation script returned error exit status 2


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装maya for linux 报错
帖子发表于 : 2013-03-28 21:13 

注册: 2012-06-09 15:40
帖子: 993
送出感谢: 0 次
接收感谢: 7
救命啊!!!!!!!!!!!!! :em21


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装maya for linux 报错
帖子发表于 : 2013-03-28 21:27 

注册: 2012-06-09 15:40
帖子: 993
送出感谢: 0 次
接收感谢: 7
root@thinkpad:/usr/lib# maya
/usr/autodesk/maya2011-x64/bin/maya.bin: error while loading shared libraries: libtiff.so.3: cannot open shared object file: No such file or directory


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装maya for linux 报错
帖子发表于 : 2013-03-28 22:49 

注册: 2012-06-09 15:40
帖子: 993
送出感谢: 0 次
接收感谢: 7
为什么卸载也出错root@thinkpad:/home/cc/桌面/crack# apt-get remove adlmapps_1.3.34-1_amd64
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 未发现软件包 adlmapps_1.3.34-1_amd64
E: 无法按照正则表达式 adlmapps_1.3.34-1_amd64 找到任何软件包
root@thinkpad:/home/cc/桌面/crack# apt-get remove adlmapps
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不需要了:
linux-image-generic
Use 'apt-get autoremove' to remove it.
下列软件包将被【卸载】:
adlmapps
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 163 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 77.9 MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 217931 个文件和目录。)
正在卸载 adlmapps ...
正在设置 composite-2011 (2011.0-2460) ...
python: can't open file '/usr/autodesk/Composite_2011/etc/configure.py': [Errno 2] No such file or directory
dpkg: error processing composite-2011 (--configure):
子进程 已安装 post-installation 脚本 返回了错误号 2
在处理时有错误发生:
composite-2011
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@thinkpad:/home/cc/桌面/crack# apt-get remove adlmflexnetclient_1.3.34
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 未发现软件包 adlmflexnetclient_1.3.34
E: 无法按照正则表达式 adlmflexnetclient_1.3.34 找到任何软件包
root@thinkpad:/home/cc/桌面/crack# apt-get remove adlmflexnetclient
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不需要了:
linux-image-generic
Use 'apt-get autoremove' to remove it.
下列软件包将被【卸载】:
adlmflexnetclient
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 163 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 18.0 MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 216716 个文件和目录。)
正在卸载 adlmflexnetclient ...
正在设置 composite-2011 (2011.0-2460) ...
python: can't open file '/usr/autodesk/Composite_2011/etc/configure.py': [Errno 2] No such file or directory
dpkg: error processing composite-2011 (--configure):
子进程 已安装 post-installation 脚本 返回了错误号 2
在处理时有错误发生:
composite-2011
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@thinkpad:/home/cc/桌面/crack# apt-get remove adlmflexnetserver
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不需要了:
linux-image-generic
Use 'apt-get autoremove' to remove it.
下列软件包将被【卸载】:
adlmflexnetserver
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 163 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 5,561 kB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 216705 个文件和目录。)
正在卸载 adlmflexnetserver ...
正在设置 composite-2011 (2011.0-2460) ...
python: can't open file '/usr/autodesk/Composite_2011/etc/configure.py': [Errno 2] No such file or directory
dpkg: error processing composite-2011 (--configure):
子进程 已安装 post-installation 脚本 返回了错误号 2
在处理时有错误发生:
composite-2011
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@thinkpad:/home/cc/桌面/crack# apt-get remove composite
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
Package 'composite' is not installed, so not removed
下列软件包是自动安装的并且现在不需要了:
linux-image-generic
Use 'apt-get autoremove' to remove it.
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 163 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0 B 的额外空间。
正在设置 composite-2011 (2011.0-2460) ...
python: can't open file '/usr/autodesk/Composite_2011/etc/configure.py': [Errno 2] No such file or directory
dpkg: error processing composite-2011 (--configure):
子进程 已安装 post-installation 脚本 返回了错误号 2
在处理时有错误发生:
composite-2011
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@thinkpad:/home/cc/桌面/crack# apt-get remove matchmover
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 未发现软件包 matchmover
root@thinkpad:/home/cc/桌面/crack# apt-get remove maya2011
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 未发现软件包 maya2011
root@thinkpad:/home/cc/桌面/crack# apt-get remove maya
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 未发现软件包 maya
root@thinkpad:/home/cc/桌面/crack# apt-get remove maya2011-0-64
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不需要了:
linux-image-generic
Use 'apt-get autoremove' to remove it.
下列软件包将被【卸载】:
maya2011-0-64
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 163 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 1,077 MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 216696 个文件和目录。)
正在卸载 maya2011-0-64 ...
/var/lib/dpkg/info/maya2011-0-64.prerm: 第 10 行: test: remove: 期待整数表达式
正在设置 composite-2011 (2011.0-2460) ...
python: can't open file '/usr/autodesk/Composite_2011/etc/configure.py': [Errno 2] No such file or directory
dpkg: error processing composite-2011 (--configure):
子进程 已安装 post-installation 脚本 返回了错误号 2
在处理时有错误发生:
composite-2011
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@thinkpad:/home/cc/桌面/crack# apt-get remove matchmover2011-0-64
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不需要了:
linux-image-generic
Use 'apt-get autoremove' to remove it.
下列软件包将被【卸载】:
matchmover2011-0-64
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 163 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 188 MB 的空间。
您希望继续执行吗?[Y/n]t
中止执行。
root@thinkpad:/home/cc/桌面/crack# apt-get remove matchmover2011-0-64
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不需要了:
linux-image-generic
Use 'apt-get autoremove' to remove it.
下列软件包将被【卸载】:
matchmover2011-0-64
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 163 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 188 MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 200427 个文件和目录。)
正在卸载 matchmover2011-0-64 ...
正在设置 composite-2011 (2011.0-2460) ...
python: can't open file '/usr/autodesk/Composite_2011/etc/configure.py': [Errno 2] No such file or directory
dpkg: error processing composite-2011 (--configure):
子进程 已安装 post-installation 脚本 返回了错误号 2
在处理时有错误发生:
composite-2011
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 安装maya for linux 报错
帖子发表于 : 2015-02-10 23:22 
头像

注册: 2008-11-01 13:38
帖子: 1436
送出感谢: 26
接收感谢: 4
243750496, 我装好maya2015了。再ubuntu14.10上。但是界面是英文的。。。是不是只有linux版本是英文?


_________________
有用Telegram的吗?
欢迎加入公共群组:
https://t.me/joinchat/AAAAAApBLdk7AGFEeQo0fQ


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译