当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]MATLAB使用问题
帖子发表于 : 2005-10-16 13:30 

注册: 2005-10-06 12:42
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
ubuntu5.04,安装的是MATLAB 7.0R14,运行有点问题:
1. 现在不能从面板上的按钮起动,只能终端输入命令起动,并且显示:
/opt/matlab/bin/util/oscheck.sh: line 134: /lib/libc.so.6: 权限不够
这条信息在安装时也出现过。

2. MATLAB中调用solve命令时,显示:
Unable to load mex file: /opt/matlab/toolbox/symbolic/maplemex.mexglx.
/opt/matlab/bin/glnx86/libmaple.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference
??? Invalid MEX-file '/opt/matlab/toolbox/symbolic/maplemex.mexglx': .

Error in ==> maple at 104
[result,status] = maplemex(statement);

Error in ==> solve at 62
maple('_EnvExplicit := true;');

Error in ==> c5e02 at 2
[x1,x2,x3]=solve('x1+2*x2+3*x3=11','2*x1+2*x2+5*x3=12','3*x1+5*x2+x3=31')


3. 一些对话框的界面显示方块,安装sun-j2re1.5后,大多数都能显示了,但还是有一些显示方块。

以上几个问题,搜了好多论坛,也没有结果,不知道是怎么回事,有哪位高手帮忙解释一下,有办法搞定么?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-10-17 9:31 

注册: 2005-10-13 13:55
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我的系统和你一样,安装的也和你一样,没有任何问题


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-10-17 10:22 
头像

注册: 2005-05-19 18:38
帖子: 1991
地址: 湖南永州
送出感谢: 0 次
接收感谢: 1
引用:
GLIBC_2.0 not defined in file libc.so.6 with link time reference
??? Invalid MEX-file '/opt/matlab/toolbox/symbolic/maplemex.mexglx': .


libc 版本太高(有好多东东不同了)

我安装pro/e也是这样

可惜商业软件没有源码,

不然就可以自己编译了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-02-24 22:47 

注册: 2006-02-23 2:17
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
设置环境变量
export LD_ASSUME_KERNEL=2.4.1
可以解决符号运算包的问题
来自于matlab的官方


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-02-24 23:30 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
关于显示方块我猜可能会是Java汉字显示问题吧,如果是的话,可以参考:
http://firehare.blogbus.com/logs/2005/11/1557213.html


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-03-08 13:06 
头像

注册: 2006-01-14 17:01
帖子: 136
地址: CNU
送出感谢: 0 次
接收感谢: 0 次
请问一下你的matlab是买的还是?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-03-08 13:06 
头像

注册: 2006-01-14 17:01
帖子: 136
地址: CNU
送出感谢: 0 次
接收感谢: 0 次
请问一下你的matlab是买的还是?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [问题]MATLAB使用问题
帖子发表于 : 2009-04-02 18:41 

注册: 2009-02-04 13:33
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
我按官方网站的办法在终端中执行了export LD_ASSUME_KERNEL=2.4.1
结果在运行Matlab时,终端返回:
/bin/sh: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory,然后就回到提示符了。
我再执行:export LD_ASSUME_KERNEL=2.6.27
再运行Matlab就能打开了,但符号运算有问题,比如不能使用”^“表示乘方,很不方便。
不知如何解决了。大家知道怎么处理这个问题吗?谢谢!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译