[问题]MATLAB使用问题

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
cantor
帖子: 19
注册时间: 2005-10-06 12:42
送出感谢: 0
接收感谢: 0

[问题]MATLAB使用问题

#1

帖子 cantor » 2005-10-16 13:30

ubuntu5.04,安装的是MATLAB 7.0R14,运行有点问题:
1. 现在不能从面板上的按钮起动,只能终端输入命令起动,并且显示:
/opt/matlab/bin/util/oscheck.sh: line 134: /lib/libc.so.6: 权限不够
这条信息在安装时也出现过。

2. MATLAB中调用solve命令时,显示:
Unable to load mex file: /opt/matlab/toolbox/symbolic/maplemex.mexglx.
/opt/matlab/bin/glnx86/libmaple.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference
??? Invalid MEX-file '/opt/matlab/toolbox/symbolic/maplemex.mexglx': .

Error in ==> maple at 104
[result,status] = maplemex(statement);

Error in ==> solve at 62
maple('_EnvExplicit := true;');

Error in ==> c5e02 at 2
[x1,x2,x3]=solve('x1+2*x2+3*x3=11','2*x1+2*x2+5*x3=12','3*x1+5*x2+x3=31')


3. 一些对话框的界面显示方块,安装sun-j2re1.5后,大多数都能显示了,但还是有一些显示方块。

以上几个问题,搜了好多论坛,也没有结果,不知道是怎么回事,有哪位高手帮忙解释一下,有办法搞定么?
xxxwin
帖子: 7
注册时间: 2005-10-13 13:55
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xxxwin » 2005-10-17 9:31

我的系统和你一样,安装的也和你一样,没有任何问题
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 gnix_oag » 2005-10-17 10:22

GLIBC_2.0 not defined in file libc.so.6 with link time reference
??? Invalid MEX-file '/opt/matlab/toolbox/symbolic/maplemex.mexglx': .


libc 版本太高(有好多东东不同了)

我安装pro/e也是这样

可惜商业软件没有源码,

不然就可以自己编译了
zc12
帖子: 8
注册时间: 2006-02-23 2:17
送出感谢: 0
接收感谢: 0

#4

帖子 zc12 » 2006-02-24 22:47

设置环境变量
export LD_ASSUME_KERNEL=2.4.1
可以解决符号运算包的问题
来自于matlab的官方
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#5

帖子 firehare » 2006-02-24 23:30

关于显示方块我猜可能会是Java汉字显示问题吧,如果是的话,可以参考:
http://firehare.blogbus.com/logs/2005/11/1557213.html
我心无畏,源自于我心无知。
图片
头像
shujun579
帖子: 136
注册时间: 2006-01-14 17:01
来自: CNU
送出感谢: 0
接收感谢: 0

#6

帖子 shujun579 » 2006-03-08 13:06

请问一下你的matlab是买的还是?
头像
shujun579
帖子: 136
注册时间: 2006-01-14 17:01
来自: CNU
送出感谢: 0
接收感谢: 0

#7

帖子 shujun579 » 2006-03-08 13:06

请问一下你的matlab是买的还是?
gds8720
帖子: 19
注册时间: 2009-02-04 13:33
送出感谢: 0
接收感谢: 0

Re: [问题]MATLAB使用问题

#8

帖子 gds8720 » 2009-04-02 18:41

我按官方网站的办法在终端中执行了export LD_ASSUME_KERNEL=2.4.1
结果在运行Matlab时,终端返回:
/bin/sh: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory,然后就回到提示符了。
我再执行:export LD_ASSUME_KERNEL=2.6.27
再运行Matlab就能打开了,但符号运算有问题,比如不能使用”^“表示乘方,很不方便。
不知如何解决了。大家知道怎么处理这个问题吗?谢谢!
回复

回到 “办公、图像、机械电子设计等”