请教一个locale的问题

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
JJCH
帖子: 26
注册时间: 2005-10-15 9:56
送出感谢: 0
接收感谢: 0
联系:

请教一个locale的问题

#1

帖子 JJCH » 2005-10-16 16:13

用sudo dpkg-reconfigure locales设置为zh_CN.GBK之后发现根本不起作用,
locale或者重启之后再locale仍然是zh_CN.UTF-8。
因此在ext3分区里的中文文件名都是乱码,请教怎样才能设LANG为GBK?
或者至少把ext3分区里的中文文件名能正确显示也好。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-10-16 19:45

ext3分区以前建立文件时,是什么编码,mount时就应该选什么编码。不关locale的事啊。
简单的修改fstab就可以。
● 鸣学
qchem
帖子: 106
注册时间: 2005-09-04 21:03
送出感谢: 0
接收感谢: 0

#3

帖子 qchem » 2005-10-16 21:48

mount linux的分区不存在编码的问题
是你的文件名用什么编码建的,那就是什么编码
可以用工具convmv来改

$ convmv -f cp936 -t utf8 --notest 文件

要改locale需要修改
/etc/environment文件
修改个人的是改什么文件不知
(晕,在FC下就是改.i18n文件)

用linux其实用utf8好
JJCH
帖子: 26
注册时间: 2005-10-15 9:56
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 JJCH » 2005-10-17 9:26

谢谢两位的帮忙!算了,不改了。
那些文件是我在CentOS-4下用GB2312的编码建立的,昨天一个个地改回来了。
JJCH
帖子: 26
注册时间: 2005-10-15 9:56
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 JJCH » 2005-10-17 18:04

今天又发现在/etc/environment里加上:
LANG=zh_CN.GBK
LC_CTYPE="zh_CN.GBK"
LC_NUMERIC="zh_CN.GBK"
LC_TIME="zh_CN.GBK"
LC_COLLATE="zh_CN.GBK"
LC_MONETARY="zh_CN.GBK"
LC_MESSAGES="zh_CN.GBK"
LC_PAPER="zh_CN.GBK"
LC_NAME="zh_CN.GBK"
LC_ADDRESS="zh_CN.GBK"
LC_TELEPHONE="zh_CN.GBK"
LC_MEASUREMENT="zh_CN.GBK"
LC_IDENTIFICATION="zh_CN.GBK"
LC_ALL=zh_CN.GBK
那些还未改过来的乱码的文件终于可以显示中文名了,
虽然这样设置成GBK,后来用UTF-8的文件还是可以正常显示的。
呵呵,跟我一样情况的朋友可以试试。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2005-10-17 21:30

其实你用gbk挂载那个磁盘就可以的。
● 鸣学
回复

回到 “办公、图像、机械电子设计等”