当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 没有make命令
帖子发表于 : 2005-10-21 17:11 
头像

注册: 2005-10-21 16:57
帖子: 1383
送出感谢: 0 次
接收感谢: 0 次
今天装了ubuntu 5.10 感觉非常好,比fedora core 流畅多了
不过碰到一个问题
下载了一个软件,安装的时候用到make命令
系统提示
bash: make: command not found

需要安装什么东西?
请写出详细解决方法
thx


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-10-21 17:13 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
没有就装啊

sudo apt-get install make


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-10-21 23:51 

注册: 2005-08-11 15:10
帖子: 27
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
按照leal的建议,出现如下的问题,不解:
引用:
sudo apt-get install make
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gstreamer0.8-plugins: 依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


我按照提示,执行sudo apt-get -f install,得到如下的错误提示:
引用:
(正在读取数据库 ... 系统当前总共安装有 71206 个文件和目录。)
正在解压缩 gstreamer0.8-visuals (从 .../gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gstreamer-0.8/libgstgoom.so”,它属于软件包 gstreamer0.8-misc
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.debE: Sub-process /usr/bin/dpkg returned an error code (1)


不明白是怎么了。请高人指点。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-10-21 23:53 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
apt-get remove gstreamer0.8-misc

然后,再

apt-get -f install


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-10-22 0:00 

注册: 2005-08-11 15:10
帖子: 27
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
oneleaf 写道:
apt-get remove gstreamer0.8-misc

然后,再

apt-get -f install

但是,remove的时候就不成功:
引用:
sudo apt-get remove gstreamer0.8-misc
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
gnome-media: 依赖: gstreamer0.8-misc 但是它将不会被安装
gstreamer0.8-lame: 依赖: gstreamer0.8-misc (>= 0.8.10) 但是它将不会被安装
gstreamer0.8-plugins: 依赖: gstreamer0.8-misc (>= 0.8.11) 但是它将不会被安装
依赖: gstreamer0.8-visuals (>= 0.8.11) 但是它将不会被安 装
gstreamer0.8-vorbis: 依赖: gstreamer0.8-misc (>= 0.8.11) 但是它将不会被安装
rhythmbox: 依赖: gstreamer0.8-misc 但是它将不会被安装
sound-juicer: 依赖: gstreamer0.8-misc 但是它将不会被安装
ubuntu-desktop: 依赖: gstreamer0.8-misc 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


再执行install,错误依旧:
引用:
sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列的额外的软件包:
gstreamer0.8-visuals
下列【新】软件包将被安装:
gstreamer0.8-visuals
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 43 个软件未被升 级。
有 11 个软件包没有被完全安装或卸载。
需要下载 0B/63.0kB 的软件包。
解压缩后会消耗掉 176kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过认证!
gstreamer0.8-visuals
不经验证就安装这些软件包么?[y/N] y

正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 71206 个文件和目录。)
正在解压缩 gstreamer0.8-visuals (从 .../gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gstreamer-0.8/libgstgoom.so”,它属于软件包 gstreamer0.8-misc
在处理时有错误发生:
/var/cache/apt/archives/gstreamer0.8-visuals_0.8.11-0unofficialubuntu3_i386.debE: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-10-24 19:49 

注册: 2005-08-11 15:10
帖子: 27
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
莫名其妙的搞定了:
sudo apt-get update
sudo apt-get upgrade
然后按照提示执行。
sudo apt-get -f upgrade

问题虽然解决了,但是不知道为什么是这样。是否和源有关呢? :?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-02 21:01 

注册: 2007-03-27 12:29
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
楼上的真实牛阿,我就是按照你的方法搞定的,估计是某些软件的依赖关系么有满足,更新一下就满足了。


_________________
扫描仪microtek x9800不能驱动;
cad格式qcad不支持;
其余都在ubuntu下面搞定。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译