应该有个办法解决这种编译时依赖版本问题。

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

应该有个办法解决这种编译时依赖版本问题。

#1

帖子 eexpress » 2005-10-30 21:55

./configure的提示

代码: 全选

checking pkg-config is at least version 0.9.0... yes
checking for NAUTILUS... [b]Package libnautilus-extension was not found in the pkg-config search path[/b].
Perhaps you should add the directory containing `libnautilus-extension.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libnautilus-extension' found
configure: [b][color=red]error: Package requirements (libnautilus-extension >= 2.10.0)[/color][/b] were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the NAUTILUS_CFLAGS and NAUTILUS_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.

代码: 全选

$ ls -l /usr/lib/libnautilus-extension.so.1*
lrwxrwxrwx  1 root root    30 2005-09-16 20:09 /usr/lib/libnautilus-extension.so.1 -> libnautilus-extension.so.1.0.0
-rw-r--r--  1 root root 24916 2005-04-05 07:40 /usr/lib/libnautilus-extension.so.1.0.0

主要是老是带-0ubuntu后缀的好像不认。

代码: 全选

$ dpkg -l libnautilus-extension* |grep ii
ii  libnautilus-ex [color=red][b]2.10.0-0ubuntu[/b][/color] libraries for nautilus components - runtime
● 鸣学
头像
DarkEyes
帖子: 548
注册时间: 2005-07-01 13:09
来自: 广西南宁
送出感谢: 0
接收感谢: 1 次

#2

帖子 DarkEyes » 2005-10-30 22:04

我安装CHMSEE时候的

代码: 全选

checking GTK_CFLAGS... -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
checking GTK_LIBS... -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXinerama -lXi -lXrandr -lXext -lXcursor -lXfixes -lpango-1.0 -lcairo -lXrender -lX11 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
checking for libgtkhtml-3.1 >= 3.1.8... Package libgtkhtml-3.1 was not found in the pkg-config search path. Perhaps you should add the directory containing `libgtkhtml-3.1.pc' to the PKG_CONFIG_PATH environment variable No package 'libgtkhtml-3.1' found
configure: error: Library requirements (libgtkhtml-3.1 >= 3.1.8) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
最新座驾:华晨中华酷宝 1.8T手动
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2005-10-30 22:07

PKG_CONFIG_PATH
一样 :lol:
● 鸣学
回复

回到 “办公、图像、机械电子设计等”