当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Texlive 2007 + kile 德文的问题 [已解决]
帖子发表于 : 2007-05-20 18:19 

注册: 2007-05-15 6:22
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
按照下面两个链接我在ubuntu 7.04 上安装了Texlive 2007 和 kile 1.9

http://ubuntuforums.org/showthread.php?t=131507

http://ubuntuforums.org/showthread.php?p=807144

然后写了一个最简单的tex文档
代码:
 
\documentclass[a4paper,10pt]{article}

\usepackage[latin1]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage[dvips,pdftex]{graphicx}

\author{ZC}
\title{Erstes deutsches Beispiel}
\date{2007-05-19}

\begin{document}
Los geht's!
\end{document


kile 报出的错误是
代码:
[PDFLaTeX] 3.tex => 3.pdf (pdflatex)
[PDFLaTeX] finished with exit status 1
/usr/share/texmf-tetex/tex/latex/base/fontenc.sty:100:Font T1/cmr/m/n/10=ecrm1000 at 10.0pt not loadable: Metric (TFM) file not found. \fontencoding\encodingdefault\selectfont
[PDFLaTeX] 1 error, 0 warnings, 0 badboxes

我感觉是有关字体的问题, 但我不知道应该怎么设置,我在网上查了一下,也没有查到相关的解决办法。
还请各位多帮忙!!谢谢!

---------------------------------------------------------------------------------------------------
解决办法:

按照这个说明重新安装了texlive 2007
http://www.tug.org/texlive/doc/texlive-en/live.html
原来的连接
http://ubuntuforums.org/showthread.php?p=807144
中缺少了部分的post-installation的命令。重新安装后,采用
代码:
\usepackage[utf8]{inputenc}
解决了上面的问题。
按照http://mailboxpublic.googlepages.com/texlive2007cjkchinesehowto可以实现中文的输出问题。


最后由 pferd 编辑于 2007-08-11 22:33,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-21 18:31 

注册: 2005-09-05 16:00
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
文件应该改为这样:
\documentclass[a4paper,10pt]{article}

\usepackage[latin1]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage[dvips,pdftex]{graphicx}
\begin{document}
\author{ZC}
\title{Erstes deutsches Beispiel}
\date{2007-05-19}
\maketitle

Los geht's!
\end{document}


$pdflatex test.tex

因为不允许提交pdf文件,没有办法上传。


_________________
OS: Fedora 9
Office: latex, gnuplot, chem-groff, metapost
cpu: intel p2.4G


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-22 1:10 

注册: 2007-05-15 6:22
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
为什么要这样改呢? 能说一下原因么?
我又试了一下,按照你上面的代码,也是同样的问题,同样的错误。 而且我直接是试了命令行latex 3.tex,它也能够生成pdf文件,但是如果tex文件中有德语的特殊字符(上面代点的字符),生成的pdf文件中特殊字符都是乱码。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-22 17:13 

注册: 2005-09-05 16:00
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
pferd 写道:
为什么要这样改呢? 能说一下原因么?
我又试了一下,按照你上面的代码,也是同样的问题,同样的错误。 而且我直接是试了命令行latex 3.tex,它也能够生成pdf文件,但是如果tex文件中有德语的特殊字符(上面代点的字符),生成的pdf文件中特殊字符都是乱码。

========================================
可能你的软件有问题。我这儿没有问题。


_________________
OS: Fedora 9
Office: latex, gnuplot, chem-groff, metapost
cpu: intel p2.4G


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-05-23 1:53 

注册: 2007-05-15 6:22
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
是啊,只是包含特殊字符的时候才有问题, 应该是字体生成的问题,有人有解决的办法么?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-06-02 17:30 
头像

注册: 2006-09-17 17:31
帖子: 107
送出感谢: 0 次
接收感谢: 0 次
但是楼主给的里子里面并不带变元音啊,你把los geht's改成let's start试试,看能不能正确输出


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-06-09 19:26 

注册: 2007-05-15 6:22
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
james_xl 写道:
但是楼主给的里子里面并不带变元音啊,你把los geht's改成let's start试试,看能不能正确输出

不能。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译