关于scim的两个问题[OK了]

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

关于scim的两个问题[OK了]

#1

帖子 glade » 2005-11-10 20:36

1. scim在enlightenment桌面下怎么用,以前用fcitx都进入桌面就有了,换成scim就不行,按热键也没反应
2. 我的scim输入法状态条太长了,半角,标点后面还有字,我把所有设置选项都设了一遍了,就是无法去掉注释文字,见图
附件
scim-1.png
scim-1.png (3.28 KiB) 查看 775 次
上次由 glade 在 2005-11-12 1:18,总共编辑 2 次。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-11-10 21:04

少装了中文包。对一下主页的说明,看少了什么。
● 鸣学
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#3

帖子 glade » 2005-11-10 23:07

什么中文包?
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

Re: 关于scim的两个问题

#4

帖子 catinsnow » 2005-11-10 23:43

glade 写了:2. 我的scim输入法状态条太长了,半角,标点后面还有字,我把所有设置选项都设了一遍了,就是无法去掉注释文字,见图

设置里的GTK页,去掉"显示输入法名称".不起作用可能是有GTK模块没有装好.先把scim包带gtk的装上试试.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#5

帖子 glade » 2005-11-12 0:44

更改这个选项还是无效
我用apt-get remove scim? 删了它
然后重装还是不行
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#6

帖子 glade » 2005-11-12 1:16

apt-get install scim-gtk2-immodule
enlightenment下面也可以输入中文了
又出现新的问题firefox 1.5死也启动不了了,1.07倒是正常
提示:/root/firefox/run-mozilla.sh: line 131: 7691 Segmentation fault "$prog" ${1+"$@"}
再来一个
apt-get remove scim-gtk2-immodule
就正常了
看来enlightenment和firefox不可得兼

感谢你们的帮助
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#7

帖子 catinsnow » 2005-11-12 13:09

glade 写了:apt-get install scim-gtk2-immodule
enlightenment下面也可以输入中文了
又出现新的问题firefox 1.5死也启动不了了,1.07倒是正常
提示:/root/firefox/run-mozilla.sh: line 131: 7691 Segmentation fault "$prog" ${1+"$@"}
再来一个
apt-get remove scim-gtk2-immodule
就正常了
看来enlightenment和firefox不可得兼

感谢你们的帮助

因为官方编译的firefox1.5使用的libstc++5,scim对链接到libstc++的程序有点问题.
将export GTK_IM_MODULE="scim"
改成export GTK_IM_MODULE="xim"
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#8

帖子 glade » 2005-11-12 13:25

贼心不死,又试了一下1.5RC2,不行
用了catinsnow的方法,好了,谢谢
scim问题还真多啊
以前用fcitx从来不用调整
回复

回到 “办公、图像、机械电子设计等”