当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 重装xserver-xorg-core后,还是无法进入图形界面
帖子发表于 : 2005-11-12 20:52 

注册: 2005-11-05 17:49
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
新人,不太懂,见谅了,呵呵

我是在编译MPlayer前装了一下东西后重启就无法进入图形见面了

开始在配置configure时提示说无法找到X11
我在MPlayer的主页上找到支持MPlayer的环境中有XFree86这一项
并且还看到X11和XFree86有关系,于是就到XFree86的主页上下了一个最新的发行版给装上
结果还是不能配置成功,提示无法找到XShape
然后在网上找找又看到要装x-window-system-dev,把这个装上后MPlayer就可以编译了

MPlayer是编译好了,但我重启一下后,却不能进入图形界面了
提示说在某某X11的目录下找不到什么,具体没记清

我怀疑是装XFree86和x-window-system-dev惹的祸
请问一下这个应该怎样恢复
谢谢了


最后由 幽谷绅 编辑于 2005-11-13 22:35,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-11-12 22:32 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
xfree86和现在ubuntu所用的xorg应该是冲突的,是两种X系统,一起肯定会出问题的吧.编译mplayer你应该装xorg的开发包,应该是这个吧x11proto-core-dev.现在你可以试试重装xserver-xorg-core.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-11-12 22:57 

注册: 2005-11-05 17:49
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
catinsnow 写道:
xfree86和现在ubuntu所用的xorg应该是冲突的,是两种X系统,一起肯定会出问题的吧.编译mplayer你应该装xorg的开发包,应该是这个吧x11proto-core-dev.现在你可以试试重装xserver-xorg-core.


知道了,谢谢
我先试试
:D


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-11-13 22:39 

注册: 2005-11-05 17:49
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
Xorg.0.log里面主要的错误提示就是:

(II) LoadModule: "nv"
(WW) Warning, couldn't open module nv
(II) UnloadModule: "nv"
(EE) Failed to load module "nv" (module does not exist, 0)
(II) LoadModule: "kbd"
(WW) Warning, couldn't open module kbd
(II) UnloadModule: "kbd"
(EE) Failed to load module "kbd" (module does not exist, 0)
(II) LoadModule: "mouse"
(WW) Warning, couldn't open module mouse
(II) UnloadModule: "mouse"
(EE) Failed to load module "mouse" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

我想是显示器、显卡、鼠标、键盘没设置正确
但我不知道怎么设置

Xorg.conf是这样的:

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV17 [GeForce4 MX 440]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "SyncMaster"
Option "DPMS"
HorizSync 30-61
VertRefresh 56-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV17 [GeForce4 MX 440]"
Monitor "SyncMaster"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-11-13 22:50 

注册: 2005-11-05 17:49
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
显卡型号:NVIDIA GeForce4 MX 440
显示器:Samsung SyncMaster 510N/512N/MagicSyncMaster CX501N/CX511N [15" LCD]
鼠标键盘就是罗技的标准套件


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-11-13 22:55 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
xorgconfig用了吗。


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-11-14 19:06 

注册: 2005-11-05 17:49
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
有用过
dpkg-reconfigure xserver-xorg


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-11-14 23:42 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
重装xserver-xorg-driver-nv
xserver-xorg-driver-xkb
xserver-xorg-driver-mouse
如果还出错装对应的包,
以至重装xserver-xorg-driver-开头的所有包,以恢复被xfree86覆盖的文件.
耐心试试,或许过程中会体会到不少东西. :)


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-11-15 21:28 

注册: 2005-11-05 17:49
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
catinsnow 写道:
重装xserver-xorg-driver-nv
xserver-xorg-driver-xkb
xserver-xorg-driver-mouse
如果还出错装对应的包,
以至重装xserver-xorg-driver-开头的所有包,以恢复被xfree86覆盖的文件.
耐心试试,或许过程中会体会到不少东西. :)

谢谢了
我也是这样做得,而且已经解决了
先是按主页上的安装nvidia的驱动
在重新了xserver-xorg-driver-kbd xserver-xorg-driver-mouse
就好了
还是谢谢大家的帮忙
虽然弄了好几天但是从中也学到好多东西


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-11-15 22:18 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
最好还是在新立得里把其它xserver-xorg相关的包也重装一下,也许现在用不到,用到时可能会出问题.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 重装xserver-xorg-core后,还是无法进入图形界面
帖子发表于 : 2011-10-13 10:27 
头像

注册: 2011-09-24 16:19
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
:em20 :em20 :em20 :em20 :em20 :em20 :em20


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译