重装xserver-xorg-core后,还是无法进入图形界面

OOo,TeX,KO,ABI,GIMP,Picasa,ProE,QCAD,Inkscape,Kicad,Eagle
回复
幽谷绅
帖子: 6
注册时间: 2005-11-05 17:49
送出感谢: 0
接收感谢: 0

重装xserver-xorg-core后,还是无法进入图形界面

#1

帖子 幽谷绅 » 2005-11-12 20:52

新人,不太懂,见谅了,呵呵

我是在编译MPlayer前装了一下东西后重启就无法进入图形见面了

开始在配置configure时提示说无法找到X11
我在MPlayer的主页上找到支持MPlayer的环境中有XFree86这一项
并且还看到X11和XFree86有关系,于是就到XFree86的主页上下了一个最新的发行版给装上
结果还是不能配置成功,提示无法找到XShape
然后在网上找找又看到要装x-window-system-dev,把这个装上后MPlayer就可以编译了

MPlayer是编译好了,但我重启一下后,却不能进入图形界面了
提示说在某某X11的目录下找不到什么,具体没记清

我怀疑是装XFree86和x-window-system-dev惹的祸
请问一下这个应该怎样恢复
谢谢了
上次由 幽谷绅 在 2005-11-13 22:35,总共编辑 1 次。
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#2

帖子 catinsnow » 2005-11-12 22:32

xfree86和现在ubuntu所用的xorg应该是冲突的,是两种X系统,一起肯定会出问题的吧.编译mplayer你应该装xorg的开发包,应该是这个吧x11proto-core-dev.现在你可以试试重装xserver-xorg-core.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
幽谷绅
帖子: 6
注册时间: 2005-11-05 17:49
送出感谢: 0
接收感谢: 0

#3

帖子 幽谷绅 » 2005-11-12 22:57

catinsnow 写了:xfree86和现在ubuntu所用的xorg应该是冲突的,是两种X系统,一起肯定会出问题的吧.编译mplayer你应该装xorg的开发包,应该是这个吧x11proto-core-dev.现在你可以试试重装xserver-xorg-core.
知道了,谢谢
我先试试
:D
幽谷绅
帖子: 6
注册时间: 2005-11-05 17:49
送出感谢: 0
接收感谢: 0

#4

帖子 幽谷绅 » 2005-11-13 22:39

Xorg.0.log里面主要的错误提示就是:

(II) LoadModule: "nv"
(WW) Warning, couldn't open module nv
(II) UnloadModule: "nv"
(EE) Failed to load module "nv" (module does not exist, 0)
(II) LoadModule: "kbd"
(WW) Warning, couldn't open module kbd
(II) UnloadModule: "kbd"
(EE) Failed to load module "kbd" (module does not exist, 0)
(II) LoadModule: "mouse"
(WW) Warning, couldn't open module mouse
(II) UnloadModule: "mouse"
(EE) Failed to load module "mouse" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

我想是显示器、显卡、鼠标、键盘没设置正确
但我不知道怎么设置

Xorg.conf是这样的:

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV17 [GeForce4 MX 440]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "SyncMaster"
Option "DPMS"
HorizSync 30-61
VertRefresh 56-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV17 [GeForce4 MX 440]"
Monitor "SyncMaster"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection
幽谷绅
帖子: 6
注册时间: 2005-11-05 17:49
送出感谢: 0
接收感谢: 0

#5

帖子 幽谷绅 » 2005-11-13 22:50

显卡型号:NVIDIA GeForce4 MX 440
显示器:Samsung SyncMaster 510N/512N/MagicSyncMaster CX501N/CX511N [15" LCD]
鼠标键盘就是罗技的标准套件
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2005-11-13 22:55

xorgconfig用了吗。
● 鸣学
幽谷绅
帖子: 6
注册时间: 2005-11-05 17:49
送出感谢: 0
接收感谢: 0

#7

帖子 幽谷绅 » 2005-11-14 19:06

有用过
dpkg-reconfigure xserver-xorg
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#8

帖子 catinsnow » 2005-11-14 23:42

重装xserver-xorg-driver-nv
xserver-xorg-driver-xkb
xserver-xorg-driver-mouse
如果还出错装对应的包,
以至重装xserver-xorg-driver-开头的所有包,以恢复被xfree86覆盖的文件.
耐心试试,或许过程中会体会到不少东西. :)
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
幽谷绅
帖子: 6
注册时间: 2005-11-05 17:49
送出感谢: 0
接收感谢: 0

#9

帖子 幽谷绅 » 2005-11-15 21:28

catinsnow 写了:重装xserver-xorg-driver-nv
xserver-xorg-driver-xkb
xserver-xorg-driver-mouse
如果还出错装对应的包,
以至重装xserver-xorg-driver-开头的所有包,以恢复被xfree86覆盖的文件.
耐心试试,或许过程中会体会到不少东西. :)
谢谢了
我也是这样做得,而且已经解决了
先是按主页上的安装nvidia的驱动
在重新了xserver-xorg-driver-kbd xserver-xorg-driver-mouse
就好了
还是谢谢大家的帮忙
虽然弄了好几天但是从中也学到好多东西
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#10

帖子 catinsnow » 2005-11-15 22:18

最好还是在新立得里把其它xserver-xorg相关的包也重装一下,也许现在用不到,用到时可能会出问题.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
jonn
帖子: 36
注册时间: 2011-09-24 16:19
送出感谢: 0
接收感谢: 0

Re: 重装xserver-xorg-core后,还是无法进入图形界面

#11

帖子 jonn » 2011-10-13 10:27

:em20 :em20 :em20 :em20 :em20 :em20 :em20
回复

回到 “办公、图像、机械电子设计等”